Welcome to discussions

Quick Suggestions

  • D3uZ
    16 posts
    Verify Game files, worked for me to get everything back

    This is wrong. Yes I got my gear back + helix credits. BUT gear is back to how it was when I bough it on store. NOT upgraded and Zero runes.

  • Ubi-Borealis
    Ubisoft Support Staff 3562 posts
    Best Answer

    Hello all!

    I've merged together several threads about this incident together into one megathread. This has since been resolved by the development team, and we will now be closing this thread.

    If you have encountered any further issues with Opal/Helix credit purchased items disappearing from your inventory, please can you open up a new thread so we can take a closer look at this. You can also contact our support team directly by opening a support ticket or starting a live chat.

    Thanks! 😊

    Official Response
  • D3uZ
    16 posts
    This post is deleted!
  • AyriusX
    2 posts

    Guys i think they fixed it already. Exit the game and enter in again 🙂

  • D3uZ
    16 posts
    This post is deleted!
  • andrewwang916
    4 posts

    Same here.
    I having fun with the wolf mount for 50hours.
    Even after yesterday 1.04 patch update, I still able to use.
    All the sudden, today I open my game the wolf mount is missing.
    Even I go to stable, wolf mount is totally not in there.
    I need help please

  • HumanCrasher
    1 posts

    i am reporting a bug where i have lost all my opals, save on november 22 with around 170 opals and now today log back in and i have 2, reda gave me 50 like i have never spoke to him before.
    i never bought anything from his store was saving for better weapons...
    how can i get them back ?

  • PTSilencer
    2 posts

    @piercehead I did the file validation and solved all issues, had to load a older save tho.. autosave was all messed up.

  • WarshaXx
    4 posts

    Yes, the gear is back again. BUT all the upgrades are gone back to the initial rank...

  • theMythBOI
    2 posts

    @humancrasher Same man, just lost 130 for no reason.

  • D3uZ
    16 posts
    i read in another thread that if you verify your game files the dissapeard gear will come back, tried it. it worked.
    BUT!!! the level of the gear was reset to default when i got it. i had all my drugar gear maxed out.

    Manually loaded an older game save. the gear was in the right level and im back to business.

    I can confirm this works, but the question is how long?

  • TheIronChariot
    4 posts

    Similar issue for me, loaded game today, a lot of gear is just gone... gear I paid for, gear from Reba and looted gear in the game...

    It's strange, when I load the save everything looks okay, then when I pan the camera around I go naked, and check inventory and most everything is gone... but not everything. Really weird, don't think I should play the game in this state. Was working flawless yesterday. I'm playing the patched version on PC.

  • greennhunter2
    2 posts

    @johnchikr have that same problem since today, but before you get an answer from the support department 😑

  • VorkdeBalbek
    2 posts

    Fixed. I got my gear back.( But unranked 😞 )

  • rosen22
    2 posts

    Not sure how this has happened but my Opal (I had around 200 in my inventory and haven't made a purchase yet) when going into Redas shop it seems to tell me I only have 50 there is also nothing to purchase in the store so wondering if its connected with that issue. But I want my opal back considering I spent helix on the opal map finder.

  • D3uZ
    16 posts

    @piercehead Found a "fix" for now. Verify Files + load and older save file when you are ingame, this restores gear you had with runes + upgrades. How long this will last is a better question.

  • Jaqlin
    2 posts

    @sparxeh92 I just logged in and my stuff is back. But without all the runes i have put in 😕 . But at least it's all back

  • huntsman34
    6 posts

    YEs the upgrades were gone but I had the materials that I'd spent upgrading them

  • Sparxeh92
    3 posts

    @jaqlin Same. Try your old saves, lose some progression but your stuff is back!

    No idea Ubi is reading this and tried a fix of sorts, or if the bugged itself with a fix... But after having the game crash after making this post, I rebooted my PC - loaded up Valhalla again and at the menus I noticed the right side pinged up with all the reward items again like I'd just redeemed it for the first time.

    Logged in my latest save, still naked but the items are back in my bag but all level 1 and no runes! BUT... I loaded my previous save from a few days ago, and my items are in tact with the upgrades and runes. So weirdly it's fixed itself? I've just lost few hours progression though but eh. Rather have my gear back!

  • Graesholt
    9 posts

    I have the same issue.
    This is honestly embarrassing.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    Hey all! Thanks for reaching out with this. Our team has been made aware and are working to implement a solution. At this time, I've seen positive updates regarding the investigation. Is it possible to try checking in-game at this time to see if the issue persists?

    Official Response

Suggested Topics

Community Details