Welcome to discussions

Quick Suggestions

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey all! We greatly appreciate these reports for visibility on the issue regarding missing store-bought items. Our team was made aware of this, and they've reported a solution having been pushed out. Could those affected try to re-launch the game at this time? 

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hello all!

    I've merged together several threads about this incident together into one megathread. This has since been resolved by the development team, and we will now be closing this thread.

    If you have encountered any further issues with Opal/Helix credit purchased items disappearing from your inventory, please can you open up a new thread so we can take a closer look at this. You can also contact our support team directly by opening a support ticket or starting a live chat.

    Thanks! 😊

    Official Response
  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @valdarious Hey there. Thanks for reaching out with this. Our team has been made aware of this issue regarding store items not showing up in-game, and have reported a potential solution for this issue. Can you load back in-game and let us know if this issue persists at this time? If so, are you able to load a different / previous save file?

    Official Response
  • RedIndianRobin
    186 posts

    @ubiwan Nope no solution has been pushed out. My connect rewards went missing as well.

  • TurukMaktoo
    1 posts



    UbiWan  " Hey there. Thanks for reaching out with this. Our team has been made aware of this issue regarding store items not showing up in-game, and have reported a potential solution for this issue. Can you load back in-game and let us know if this issue persists at this time? If so, are you able to load a different / previous save file? "

    Yes guys you all returned, but without runes and upgrades! I spent 50 hours to get it all, now I don't have any previous saves to fix it . what should I do? I gave you more money than the game is worth, And I got such a problem, it would not have been if I was carrying weapons and gear not from the store


  • patriot_247
    1 posts

    I should have looked first (I feel like an idiot). I dropped 50 bucks on in-game content to decrease the grind. I bought the silver pack and the resources pack. I am not down to 1000 helix from the large pack of it I bought and NONE of the items are showing up in game.

    Bugs can happen in a game, but when IRL money is involved, this is in NO way acceptable. There are several threads about these issues already and not ONE of them has been responded to.

    Again - do NOT buy from these people. They take your money, even give you some BS warning about it being a binding contract, then don't even deliver. Downright shameful.

  • SofaJockey
    169 posts

    @patriot_247 To be fair, I'm brimming with silver and resources just by playing the game. Do you really think the game is 'grindy'?

    The absence could just be an account issue - as this relates to paid content, I imagine you could raise a support ticket and get a prompt(ish) response.

  • Graesholt
    9 posts

    I should add that this extends to the Blood Eagle boat pack that you can get as a twitch drop.
    After installing the update, I cannot aceess items from either pack...

  • Bodden60
    3 posts

    Verified Files and loaded an older manual save the auto saves wouldnt work. got my gear back to level along with runes but lost all progress for today

  • Anghya
    2 posts

    @ubiwan The issue seems to be solved for me, thanks. As I have discovered later, also Helix points were missing and my store/Reda gear disappeared from the save made after this issue appeared (but loading an earlier saved game solved it). Unfortunately, a part of your solution apparently was a change of things offered by Reda, so I will need to wait for the stuff I like again (but no big deal, of course). 😉

  • Foxed64
    2 posts

    I started the game up again. Loading both my newest and previous save. Previous save worked best since it kept my old Scimitar and its runes (the newest gave me back the opal items as if it was the first time for the save while the previous acted as if I had never lost anything). The 300 Helix credits are back. Opal count went to 35, which must be what I had before. I'm totally find with losing what I had earned form dailies today since those also reset and I can just earn them back.

    The fix worked, thank you so much!

  • aldough22
    4 posts

    Yeah I noticed that when I installed the update, the Drekar Shield at the merchants is gone. It really sucks because the game is genuinely gun but the constant glitches I've had to deal with for +50 hours is ridiculous.

  • Sparxeh92
    3 posts

    @gloomseeker Yep this is what eventually fixed it. An older save didn't resolve the issue at first, it still wiped my gear.

    But after rebooting pc/client/game a little while later (30-40 mins)... The main menu showed the gear being redeemed again which was weird. I tried loading the autosave and the gera was in my bag but no upgrades/runes, like it had just added them fresh. So I tried an old save and everything is fine again now. 🙂

  • Centdebile
    9 posts

    FOUNDTO NOWHERE BUT IT OWN I SAID IT ,INVENTIRIES MY IN SHOW NEVER BUT SHOP REDA FROM SHIELD VALKYRIE THE BOUGHT I

  • Graesholt
    9 posts

    For me, I was able to validate my game and load my latest save, which unlocked both bugged packs for me anew.
    Lost my runes, like everyone else, though...

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Hey folks,

    Thanks for reaching out about this issue.

    I have passed this info onto the team to investigate further.

    Official Response
  • Evillution60
    1 posts

    @ubiwan When you go to the in-game purchase the items are there, but in the equipment everything has disappeared since the last update.

  • Valdarious
    10 posts

    @ubiwan I followed the guidance of I think you from another post. Loading a previous autosave from like 2 mins earlier restored all my stuff. Thanks.

  • wolf-MAN010
    10 posts

    @xpwnintanoobsx thanks tip will play the game offline for now till this is fixed

  • OldScratch6
    1 posts

    @d3uz I have similar issue. Bought in store gear and immediately lost all equipped gear and runes that came from ultimate edition. submitted report and 4 days later still no response ...

  • G-H-A-Z-T
    1 posts

    I just finished doing the main story for Suthsexe and after I went to Reda just to notice all my opals were gone. Granted I only had little over 130, that is still a lot to lose and very annoying. I noticed a few people on reddit have this problem and it would be nice to those who also had this glitched as I have to be compensated the opals back. I’m not sure if there is a specific way to trigger this bug but I advise everyone else to check on your opals Incase this does happen to you. I do hope Ubisoft does gift back all of our missing stuff.

Suggested Topics

Community Details

128
Online
139.7k
Users
24.6k
Topics
127.4k
Posts