Welcome to discussions

Quick Suggestions

  • ATFDrEvil
    4 posts

    @js6868 It's everyone

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello all!

    I've merged together several threads about this incident together into one megathread. This has since been resolved by the development team, and we will now be closing this thread.

    If you have encountered any further issues with Opal/Helix credit purchased items disappearing from your inventory, please can you open up a new thread so we can take a closer look at this. You can also contact our support team directly by opening a support ticket or starting a live chat.

    Thanks! 😊

    Official Response
  • TheHuwa
    1 posts

    Me also. Yesterday my game crashed. Today I wanted to continue but Ubisoft Connect had network issues. So I continued offline. My quest (the berserk questline) bugged. No quest there anymore available. Waited till Ubisoft Connect is online again and restarted my game. Quest is back but Im naked. I had the Twitch Prime gear. Doublechecked the linking of my account.

  • xPwninTaNoobsx
    9 posts

    Good morning,
    I was playing and went against one of the bosses (can't remember her name, naked lady in the swamp) and after I died and reloaded my save, my time as reset to 0 h 0 s and all my helix and DLC content has disappeared permanently and doesn't even show in the main menu store that I bought them! What is going on? I spent a lot of money on that stuff, on top of my Ultimate purchase!!!

  • ATFDrEvil
    4 posts

    @fgx1988 Everyone lost anything connected to online services including opals.

  • Yughelle
    2 posts

    I've just lost all my Twitch Prime Carolingian set items as well. Guess servers aren't checking for add-ons correctly.

  • Schtingah
    1 posts

    This happened to me too, though for me it was a weapon (Scimitar) I bought from Reda's Store as well as all my opals that are gone. I can see the weapon on my back when loading in but then it vanishes.

  • lancotdulac
    1 posts

    Good morning
    Today I tried to play, and I found my character naked .. disappeared the Carolingian set (prime gaming) an object taken from Reda's shop (the armguard draught or as you write) and about 20/30 opals, the rest I still have to verify..

  • Stephke999
    8 posts

    Oh I'm not the only one then

  • GriffinNinja
    1 posts

    Same. It was fine working last night at 12 am EST, but this morning it is gone. What is going on?

  • Anghya
    2 posts

    The exactly same thing happened to me. My amount of opals got reduced to 50. I tried to restart the game and also to complete one contract to check if it won't help, but no luck. I have noticed no connectivity issues and no errors were thrown, Reda is also working without any problems (the shop is displayed, contracts are available). That's quite annoying especially when there is finally something in the shop I would like to have.

  • PTSilencer
    2 posts

    I've the exact same issue, all bought gear and all unused helix credits are not visible. The ultimate pack stuff is there tho....

  • ATFDrEvil
    4 posts

    @danarus Don't think this is related to that patch as that was yesterday and it looks like connection to ubisoft is down.

    3 posts

    @fgx1988 I lost all mine as well. I had not spent a single Opal since I started the game. Finally found an item I wanted to get and game says I don't have the Opal. I had almost 300.

  • chrisvenn
    2 posts


    Can confirm also have this issue and need the armor back as the game will now be broken as used all my stuff to upgrade the armor. Also missing all the Runes that were in them

    without this I wont want to play the game any more

  • sniper25741
    3 posts

    having the same issue i own two packs of gear sets and various weapons and had opals all delted wth is going on

  • Valdarious
    10 posts

    @tiltrush I just posted this also and it looks like it is happening to a lot of people now.

  • Stephke999
    8 posts

    This happened to me as well. I bought the Huldufolk set and it disappeared after the patch. It's very annoying.

  • Irakandjii
    1 posts

    I too lost my Opals, I had 227 less than most of you but still all I had. This is frustrating.

  • Limitless_808
    1 posts

    I too am experiencing this issue. It seems that after the new update was pushed, I load in with my armor set and everything, and seconds later it is gone. does not show up in inventory, or anything. I cannot even see that I have purchased any helix credits. I have recorded video as evidence that I have these items if it will help!

  • chrisvenn
    2 posts

    @tiltrush Also got the same issues.......not good

Suggested Topics

Community Details