Welcome to discussions

Quick Suggestions

  • LJStark
    10 posts

    This a continuation of a persistent glitch that I have previously reported here but received no acknowledgement on: https://discussions.ubisoft.com/topic/85072/vegisir-tattoo-galloglach-armor-bug-still-present-on-xbox-one-after-patch-1-0-4

    When I take the Vegvisir torso tattoo scheme to Svend in Ravensthrope, the tattoo is not available to be applied. When I exit the tattoo application scheme and dialogue with Svend, the Galloglach chest armor (Superior-level, one upgrade) appears in my inventory. If I go acquire the Galloglach armor from its chest location (Superior-level, three upgrades) before talking to Svend, I end up with a duplicate Galloglach armor and both of them have their upgrades set back to just one. This has persisted despite the 1.0.4 and 1.1.0 patches. It occurs exactly as documented in this other user's video:

    This specific bug appears to be affecting multiple players across multiple platforms, and may even recur with different tattoo scheme/armor pairings as well:

    It also may be linked the armor duplication bug that many people have reported, with exemplar posts here:

    I essentially cannot change my character's appearance at the tattoo shop until this is resolved because it generates this issue, and I don't want to (A) risk corrupting my save files with duplicate armors in my inventory and (B) don't want to lose the tattoo scheme and potentially never recover it.

  • Redlegz19
    3 posts

    So I have a galloglach torso piece that I have upgraded to flawless(not sure where I picked it up at). I am currently starting to explore Lincolnscire and started with the wealth piece in Spalding Bandit Lair and when I opened the chest to my surprise was another galloglach torso piece. Not only did I get a duplicate torso piece but it reverted my flawless piece to a superior piece, so now I have two superior galloglach torso pieces. I was assuming only 1 piece per set of armor. Was really hoping the new update would fix this. I refuse to advance in the game because I’m sure something else will bug and either ruin the whole game and/or not get to enjoy everything the game has to offer. Please help!!!!!

  • UbiKoality
    Community Manager 440 posts

    @lokkorulez Hello! My apologies for any inconvenience that this bug may have caused you. Can you please provide more details regarding your specific encounter with this bug?

    Official Response
  • SloodyBady
    1 posts

    I have run into the same issue but with the Huntsman armor. The closest save without the bug that I can go to is more than 1h ago. Is there any fix or do I just have to re-do the last hour or gameplay?

  • KAM0TS
    1 posts

    @ljstark Excellent compilation of the issue! There's definitely something still wrong with item duplication in general but Ubisoft has not updated the Issues Megathread: https://discussions.ubisoft.com/topic/81608/updated-15-12-reported-issue-megathreads-check-here-for-your-issue

    @Ubi-Woofer Any chance we can get this added to the Issues Megathread and an official stance if this is still under investigation or not picked up yet? Perhaps even a clarification if this will affect our save games and we're ok to still play. Thank you.

  • Redlegz19
    3 posts


    ya it happened to me with a daughter of lerion I had to go back and replay from my last save point. I have now always manual saved right before picking up or interacting with anything just in case it messes up

  • Ungorisz
    4 posts

    1 months, 2 bit patches since release ... 1.0.4 didn't fixed this, and nor do 1.1.0

    The issue is still there i can still repro the item dupe with f.e. the Muninn Call Scheme (Front), and still have the dupes in the inventory / jomsviking's inventroy ... but the worst offender is that it's been reported multiple times with repro steps and it's still not even in the Known bugs thread ...

  • ImaginaryRuins
    418 posts

    @ungorisz Yep, confirm that patch 1.1.0 (Xbox One) does not address the issue. Once I talk to the tattoo shop girl, the duplication glitch immediately triggers.

  • Kormac67
    652 posts

    Yanli: "Can't have too many!"
    Me: "Yeah, right, so hand over a second bow so I can start duping weapon gems as well."

  • benzy4792
    30 posts

    Just beat my first Daughter of Lerion.
    The 'easy one' in Granterbridge.
    The dagger which you get got bugged out, and I got an *extra* hunter torso (which I already own).
    Not so sure what to do 😞
    P.S I'm playing on Xbox series S

  • gentester
    65 posts

    confirm 1.1 patch on PC doesn't fix issue
    I have duplicate Galloglach and Huntsman Armor Torso's
    Duplicate runes and Duplicate order Medallions

  • sattium85
    72 posts

    @ubi-spud Not fixed in 1.1.0. Just got a duplicate hunter armor just by going to the change tattoo and hairstyle menu.

  • sattium85
    72 posts

    @tricktrickster Not fixed in 1.1.0. Just got a duplicate hunter armor just by going to the change tattoo and hairstyle menu.

  • MadnessReigns33
    21 posts

    Hopefully this gets fixed at some point. Had the duplicate Huntsman Armor torso for a while now and just found the dreaded second Gallochan Armor torso in a chest in Lincolnshire. Ended up resetting the upgrades I put on the fake one 😑

  • Zuriel81
    2 posts

    I had the Huntsman Chest piece fully Upgraded to Mythic and also fully upgraded otherwise. After I finished the Villi questline and got back to the Settlement I upgraded a couple of other pieces to the next level and then noticed I was missing my chest piece. I had it hidden for a bit so not sure if that caused it. It became Superior again and lost all upgrades. I upgraded fully at Superior and then made flawless and then Mythic again. Won't upgrade. but somehow my original piece showed up again with all of the runes on it fully upgraded at mythic. tried selecting that. after that it changed back to the other one. So I have currently two Mythic one fully upgraded one not and one Superior. It won't let me keep wearing the fully upgraded Mythic but keeps changing back to the other mythic. Not sure what caused it or how to fix and I've accomplished too much to wanna try to reopen an older save.

  • kittykb
    2 posts

    I have the same issue. I also have a duplicate of the Galloglach torso. When I upgraded them with the blacksmith, they both upgraded, but the duplicate set went back to its original level eventually, and brought down the actual sets level for some reason, but that would go back to its new level eventually too??

  • hroozenbeek
    1024 posts

    I also have two sets of Galloglach torso armor. One of them is upgraded, but the upgrade disappears when I interact with the armor in the inventory (and later reappears, etc.). The 1.1.0-update has not fixed this.

  • sattium85
    72 posts
    This post is deleted!
  • sattium85
    72 posts

    @ubi-spud The glitch of duplicate items was not fixed in version 1.1.0. (The error was caused with the purchase of tattoos and a visit to Tove). I recorded a video where I fully reproduced this error in order to make it easier to solve.

  • Manik_RTH
    1 posts

    I purchased the munin's call chest tattoo schematics from the shop in Raventhorpe, upon handing it into the tattoo artist, my huntsman chestpiece is duplicated. Moving the cursor over the duplicated piece resets the upgrades of the non-duplicated one. I basically can't use the tattoo shop or change any cosmetics.

Suggested Topics

Community Details