Welcome to discussions

Quick Suggestions

  • ImaginaryRuins
    397 posts

    @ungorisz Yep, confirm that patch 1.1.0 (Xbox One) does not address the issue. Once I talk to the tattoo shop girl, the duplication glitch immediately triggers.

  • Kormac67
    613 posts

    Yanli: "Can't have too many!"
    Me: "Yeah, right, so hand over a second bow so I can start duping weapon gems as well."

  • benzy4792
    30 posts

    Hey!
    Just beat my first Daughter of Lerion.
    The 'easy one' in Granterbridge.
    The dagger which you get got bugged out, and I got an *extra* hunter torso (which I already own).
    Not so sure what to do 😞
    Help?
    P.S I'm playing on Xbox series S

  • gentester
    64 posts

    confirm 1.1 patch on PC doesn't fix issue
    I have duplicate Galloglach and Huntsman Armor Torso's
    Duplicate runes and Duplicate order Medallions

  • sattium85
    72 posts

    @ubi-spud Not fixed in 1.1.0. Just got a duplicate hunter armor just by going to the change tattoo and hairstyle menu.

  • sattium85
    72 posts

    @tricktrickster Not fixed in 1.1.0. Just got a duplicate hunter armor just by going to the change tattoo and hairstyle menu.

  • MadnessReigns33
    21 posts

    Hopefully this gets fixed at some point. Had the duplicate Huntsman Armor torso for a while now and just found the dreaded second Gallochan Armor torso in a chest in Lincolnshire. Ended up resetting the upgrades I put on the fake one 😑

  • Zuriel81
    2 posts

    I had the Huntsman Chest piece fully Upgraded to Mythic and also fully upgraded otherwise. After I finished the Villi questline and got back to the Settlement I upgraded a couple of other pieces to the next level and then noticed I was missing my chest piece. I had it hidden for a bit so not sure if that caused it. It became Superior again and lost all upgrades. I upgraded fully at Superior and then made flawless and then Mythic again. Won't upgrade. but somehow my original piece showed up again with all of the runes on it fully upgraded at mythic. tried selecting that. after that it changed back to the other one. So I have currently two Mythic one fully upgraded one not and one Superior. It won't let me keep wearing the fully upgraded Mythic but keeps changing back to the other mythic. Not sure what caused it or how to fix and I've accomplished too much to wanna try to reopen an older save.

  • kittykb
    2 posts

    I have the same issue. I also have a duplicate of the Galloglach torso. When I upgraded them with the blacksmith, they both upgraded, but the duplicate set went back to its original level eventually, and brought down the actual sets level for some reason, but that would go back to its new level eventually too??

  • hroozenbeek
    1024 posts

    I also have two sets of Galloglach torso armor. One of them is upgraded, but the upgrade disappears when I interact with the armor in the inventory (and later reappears, etc.). The 1.1.0-update has not fixed this.

  • sattium85
    72 posts
    This post is deleted!
  • sattium85
    72 posts

    @ubi-spud The glitch of duplicate items was not fixed in version 1.1.0. (The error was caused with the purchase of tattoos and a visit to Tove). I recorded a video where I fully reproduced this error in order to make it easier to solve.

  • Manik_RTH
    1 posts

    I purchased the munin's call chest tattoo schematics from the shop in Raventhorpe, upon handing it into the tattoo artist, my huntsman chestpiece is duplicated. Moving the cursor over the duplicated piece resets the upgrades of the non-duplicated one. I basically can't use the tattoo shop or change any cosmetics.

  • Zuriel81
    2 posts

    @manik_rth well this explains what caused mine. Cause I had just bought those tattoos as well. And same piece of armor as well

  • Youldinho
    19 posts

    two pieces of armour are duplicating when I have turned in a tattoo schematic (Munir Call - Huntsman & Vegisir - Gallogach) this is very annoying and when I upgrade or equip armour the stats change?

    any advice please

  • Youldinho
    19 posts

    Exactly the same for me! There’s another glitch which duplicates the Gallogach armour also

  • ImaginaryRuins
    397 posts

    Yes this issue has been reported for multiple times already but Ubisoft has still not addressed it. This happened in my game as well.

    For now, avoid handing in any tattoo designs to the tattoo shop.

  • Youldinho
    19 posts

    @imaginaryruins imagine it being reported many times and them not responding! Meaning we have to avoid customising our character!

    embarrassing

  • Youldinho
    19 posts

    @ubi-spud is there any update on this?

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    Hello all!

    I can confirm this issue has not been resolved just yet, however our team has been hard at work and we should have more information soon. Please keep an eye out in our News & Announcements section for any future patch notes.

    @Ungorisz Thank you for listing everything from your experience. I don't have a comprehensive list myself but this should be behind us very soon 🙂

    All the best!

    Official Response

Suggested Topics

Community Details

44
Online
138.5k
Users
24.2k
Topics
125.7k
Posts