Welcome to discussions

Quick Suggestions

  • johnnyoliver190
    1 posts

    I have noticed that the duplicating armour glitch is still not fixed from 1.04 and even with the most recent update which is honestly quite frustrating.

    It happens when you hand in tattoo sheets to the tattooist for your settlement and for some reason he is still giving me duplicate huntsman and galloglaich armour. I believe it’s linked to certain tattoo designs that you hand in.

    To make matters worse, you can then duplicate the armours further by upgrading it once and then equipping and un-equipping so you can have as many as your materials permit you to!

    Because of this, I don’t want to hand in anything else and then get more random duplicates so please actually address and correct this bug!

    If it’s not possible to remove the duplicates then just allow us to sell the excess equipment as it’s missing up inventory and upgrades too.

  • LJStark
    10 posts

    @kam0ts The only official response I've seen on this issue was from @Ubi-Spud all the way back in November. At this point, I would take just a statement on if the duplicate armors do in fact corrupt save files, as I'd really like to be able to customize my character. Especially since the Yule Festival offers more character customization content, it kind of seems like a waste of a special event to be sitting on my hands over this duplicate armor bug.

  • Totalnerd
    2 posts

    I am also seeing this issue with both gollaglach and huntsman armors.

  • JCar4327
    606 posts

    @totalnerd They supposedly fixed this in 1.0.4, but it seems to be persistent because I still have double pieces on all three of my saves (one save for each character choice).

  • garumental
    2 posts

    Armor duplication is still not fixed. It is happened to me today. I have 3 Galloglach chests. PLEASE FIX THIS

  • garumental
    2 posts

    @garumental just after I upgrade an armor , it is duplicated

  • sh3p3003
    2 posts

    @jorge4rturo

    Same on ps5 though can't seem to figure whether the glitch items have replaced what should of been picked up or wether it's just adding a new item gotta admit after not being able 2 claim free ps5 upgrade all yule quests bugging out and every time loading game eivor being drunk af and seer quest not progressing and the sneaky adding of boosters after review cycles and now this I'm not buying another ubisoft title again nearly as bad as cyberpunk 2077

  • Draeoth
    24 posts

    I had this armor increased to silver quality. After finishing snotinghamscire and reading the letter from vili i noticed i now had 2 galloglach armors and they are both bronze quality. So the armor duplicated and lowered in quality. The lowering in quality from silver isnt a huge issue but had it been gold it would be worse with there being a limit to the amount of tungsten in the game.

  • ThoughtCobra06
    1 posts

    When handing in tattoos Galloglach Armor chest piece duplicates and being able to purchase unlimited Mark of Sol and having duplicates of said item in inventory.

  • Mid-Kendov-Kaan
    6 posts

    I've noticed that when I have gone to turn in a tattoo pattern I suddenly have a duplicate piece of armour. Sadly even when I hover over (not even clicking on it) the item resets my previously owned (and fully upgraded I might add) piece.

    I've gone as far back in my saves (or as far I would care to go without losing hours of game time and progress) and found that the duplicate piece is no longer in my possession. This has mainly occured with the Huntsman and the Galloglach torso armour pieces.

    Others have noticed and commented about it in various discussion boards so I know I'm not the only one struggling with this.

    I have every intention of playing and just hoping that one day there will be a patch/update that fixes this slightly inconvenient bug. don't mind having the duplicates (if they went I wouldn't mind either), it's the resetting of my upgraded that I take issue.

  • Kormac67
    581 posts

    @mid-kendov-kaan You can dupe runes and make a lot of silver with this glitch. 🙂

  • Gergid
    27 posts

    @Mid-Kendov-Kaan
    Hope they will fix this issue in the upcoming weeks otherwise i will finish my game without using the Tattoo Shop. Luckily I am pleased with the look of my Eivor which I set back in Fornburg but it's ridiculous that you can't use a game element because it's not working properly.

  • ImaginaryRuins
    382 posts

    @mid-kendov-kaan Indeed this happens to my game as well. Xbox One patched 1.1.0. Ubisoft claimed that they fixed this but it was not the case.

    Fortunately I noticed it before long so I have been holding onto all tattoo designs in my Inventory, as a means to avoid this glitch.

  • killerpanties
    2 posts

    @jcar4327 I just defeated a zealot outside of Wincestre and I noticed I have two Gallogach torso armors, one upgraded by me and the second being brown. The funny thing is that if I select the duplicate it downgrades the golden one into brown aswell. If I try to upgrade the duplicate nothing happens, when I upgrade the original it stays upgraded. When I equip the duplicate it equips the, now downgraded, original one aswell, as if I'm wearing both torso armors. What in the name of Odin is this?! This is almost gamebreaking, the amount of resources went into fully upgrading that piece of armor was no walk in the park, and now I have to do it AGAIN?! Or just don't select the glitched armor?
    I will just avoid selecting the glitched armor, but if you release a patch, please do it so that the one I upgraded stays and not the brown one with only one bar. I want to upgrade other armors aswell and I don't have time to waste to upgrade the same armor again.
    Do something with it. Let us send you our saves for example, and fix those files so there are no duplicates.

    I also have duplicates of the ship design...

  • Antipotheosis
    8 posts

    Hello, 
    Last night I noticed that in my inventory where I used to have a fully upgraded Huntsman Armour Mythical Torso, I now have two Huntman Armour torsos that are now at the lowest level and the runes inserted have been removed, possibly lost completely.
    I keep my savegames in a looping cycle so that the oldest one gets replaced each time I save the game and looking at some earlier savegames I still have the fully upgraded torso piece with the runes inserted. 
    Instead of losing hours of gameplay, is it possible to simply fix my latest savegame so that the glitch can be repaired?
    I have no idea what caused the glitch so no way of knowing if there's a way of preventing it happening again.

    What I should have equipped on Eivor is the following torso item:
    Huntsman Armour Mythical Torso
    Increase range resistance diamond rune
    +3.0 armour rune
    +4.0 armour rune

    Some of my older savegames still show this item before the glitch occurred.

    Any help would be very much appreciated.

  • JCar4327
    606 posts

    @killerpanties You should have probably sent this to @Ubi-Spud.

  • Antipotheosis
    8 posts

    if anyone else has this problem then apparently it's a glitch that is being used as an exploit. Something to do with the tattoos bought from Yanli are making items duplicate at their lowest level.
    Apparently it's being used as an exploit but for my fully upgraded torso armour disappearing is is a massive annoyance. I'm having to abandon hours of gameplay and continue on from an earlier game instead.



    tech support have been informed but I likely won't get the glitch reversed.

  • MagdaHitHard1
    2 posts

    @ubi-raziel
    I've had the same issue last week, with same tattoo and same armor set. The tattoo "Muninn Call (Front)" (bought from Yanli) is disappear... and the Huntsman armor is now in double.
    And had the same issue yesterday, I bought all scheme of "Auki symbol", and in tattoo shop the Front and 2 arms are disappear...

    Sorry but no video avalaible.

    Wish that this issue will be fix quickly.

  • Kormac67
    581 posts

    @magdahithard1 Well we have had two patches since launch (not including the day 0), but this was never fixed. "removed duplicate items" was in the patch notes but not actually implemented.
    You can use the duplicate armor to duplicate gems and boost your silver. 🙂

  • MagdaHitHard1
    2 posts

    @kormac67
    And if I want the missing tattoos schemes ? ;o)

Suggested Topics

Community Details

77
Online
130.8k
Users
22.7k
Topics
117.7k
Posts