ubisoft discussions

Quick Suggestions

  • Errza
    2 posts

    @ubiexcellent sure, the one with one upgrade is the one that spawn in my inventory the other one is the one i find when i check if i didn't already loot the chest.undefinedundefined

  • Ubi-Raziel
    197 posts

    Hello! I'm sorry this issue affected you both, we will try to get this resolved.

    • Would anyone be able to provide a video of this happening?
    • Do you recall what other tattoos / armour pieces this has happened with?

    This will help us reproduce the issue in a testing environment.

    Thank you!

  • RaMan1972
    11 posts

    Hi there, this seems to be the only way to get through to support atm.

    I seem to have gotten two copies of the Galloglach armor torso, which I think must be a mistake. I don't really mind, except that it looks like there may be limited slots to "carry" armors in, and if that's the case, it may get in my way later in the game. Also might be a bug worth looking into for yourselves, I suppose. I'd like if you could delete one of the two copies, regardless, just for the sake of neatness. I don't know if you are able to do that.


  • FieserMoep
    19 posts

    @raman1972 Same with Hunter Chest Armor for me.

  • NChabb
    4 posts

    Hi there,

    So I just reached the point where I had to report back to Ravensthrope after gaining alliance with both Ledecestrescire and Grantebridgescire, which result in a specific story event. After completion of the quest/event, I noticed I had a second Hunstman armor chest in my inventory (I found my original first copy by exploring a few hours ago). They act like one of the same (equipping one make me equip both at the same time).

    Since there is no way to salvage or get rid of armor pieces, this is a nuisance in my inventory now 😐

  • Fuzzi_23
    2 posts

    so i just built the tattoo shop in my settlement. when i talk to svend (the tattoo guy) something weird happend in my chest armor inventory.
    My huntsman armor which i upgraded to lvl 4 gets reset to lvl 1; a second lvl 1 huntsman armor which i can't upgrade gets added to my inventory and a chestpiece called "galloglach armor" which i have never collected, gets added to my inventory.

    is any of this supposed to happen?

  • Fuzzi_23
    2 posts

    also if i should just get the galloglach armor, is there any way to prevent the duplication of the huntsman armor?

    1 posts

    I had picked up a treasure loot and got same item which I already had it on me. So now there are 3 similar items in my inventory.undefined

  • Melle149600
    1 posts

    The option to talk to svend isn’t even there for me. Even tho I build his house and everything

  • Ubi-MrM
    Ubisoft Support Staff 2889 posts

    Hey Melle149600, I am sorry to hear that you're experiencing this additional issue with talking to Svend. Are you able to provide a video of the issue, as requested by my colleague Raziel? It would also be helpful if you could clarify any troubleshooting steps you've tried as well. Thank you!

    Official Response
  • WightWalker94
    1 posts

    I was playing and noticed after building some huts in my village it had duplicated and went down in both upgrades (as in flawless down to superior and the up grades done with iron and leather) there is now two of the armor in my inventory I have saved and reloaded and it has not gone away.

  • MadnessReigns33
    21 posts

    Playing and killed Hunta, son of Hunta and he dropped a Huntsman armor chestpiece. Didn’t think anything of it and started looting different places. I then looted a chest in Grantebridgescire and ended up getting the exact same chest piece. When I equip the first one I got it shows just that one equipped; if I equip the second it shows both the first and second equipped. I also tried to upgrade one of them and it shows each upgrading separately. Any way I can get one of them out of my inventory?

  • IronHades21
    1 posts

    Whenever I upgrade a piece of armor in my inventory, if I remove the armor and then equip it again, it duplicates it. I was just upgrading armor. I don’t want any of it because it actually gets rid of the upgrade on the new one. Plus it’s cheating... Only tried on the Galloglach Armor Torso. Also took my rune. I have five and no way to rid them. I haven’t tried it on any other weapon or armor.



  • Ubi-Baron
    Ubisoft Support Staff 795 posts

    @IronHades21 Thank you for the report.

    We are aware of issues with item duplication and this has been passed on to the team to be looked into.

    Thank you for the extra details you have provided us to help us work out the issue.

    Official Response
  • Ubi-Baron
    Ubisoft Support Staff 795 posts

    @MadnessReigns33 Thank you for reporting this to us.

    We are aware of this issue occurring and it's currently being looked into by the team. At the moment there is currently no way to remove it.

    Official Response
  • chaosandcoffee
    94 posts

    this happened to me too, not sure where i got the second piece but i noticed i had two in my inventory

  • Cripzore
    2 posts

    Today I had a weird glitch, when after a certain wedding in East England I came to our settlement and decided to build Tattoo Shop.
    Something weird happened and when I talked to the NPC to browse tattoos and hairstyles, the Huntsman Armor duplicated.
    If it helps, may contain story and NPC spoilers:


  • Dark_Conqueror
    1 posts

    I have the same problem, except it happens just by interacting with Svend, even if the building has not been built.

  • JugoLama
    1 posts

    @errza I've had this same issue with the Raven Clan shield, which adds another layer to this issue as I'm sometimes able to then dual wield the shield and sometimes not.
    Here are some screenshots:

    - shield present and wieldable in both hands;
    - in-game example;
    - shield now appearing as two different icons, both wielded in the off hand. Upgrading the shield to flawless level makes this even more confusing. I now find myself with three different icons for the Raven Clan shield, one of which is a fully upgraded version, while the two others are duplicate items.
    - screenshot of this.

  • RogueSharkey
    2 posts

    It has now also happened with the Galloglach Armor.undefined

Suggested Topics