ubisoft discussions

quick-suggestions

  • locked topic_solved [RESOLVED] Unable to move shelf in Evinghou tower in "Blood from a Stone" | POST HERE

    0 likes/578 replies/13355 views
    Dannyg1523
    ubisoft:x-posts, 3

    @spikeydave being trying this for days cant get it to work. Do you stop pressing all buttons for it to slide you into the box?

  • Dannyg1523
    ubisoft:x-posts, 3

    @ubiwan is there a fix to this issue yet. Was first reported two weeks ago?

  • Kailiano
    ubisoft:x-posts, 1

    the movable object won’t move so I can’t complete blood from a stone at Evinghou Tower plz fix

  • Khelben3
    ubisoft:x-posts, 2

    Well I have been exploring the map for a week now since I cannot progress with the main story. By the time the game gets patched and I can resume, I'll be level 300 will have cleared over half the map. I encountered glitches before, but one that completely stops me from continuing the story is a new one. This sucks, hope it gets patched soon.

  • KnightD70
    ubisoft:x-posts, 1

    Playing on PS4 pro.
    The movable door/shelves at the bottom of Evinghou tower will not move. I have destroyed the barrels and pots in front from within the cave but it still remains stuck so I can’t get the artifact from the room. There is a tiny loot item on the floor where the barrels were so I wonder if this is the problem. I can’t do anything about the loot item from the cave or the front.


  • susan_o
    ubisoft:x-posts, 2

    Blood from a stone quest - Can't move the rack as the other guys.
    However have seen that on the other quest "Chipping Away"- Weaken Eadwyn's hold on Oxenefordscire, it doesn't show at all the locations of the tasks that I need to do to progress. Upon checking some other people (streamers) they have simply showed on the map where the locations are. I simply do not have any location where to go/follow to finish the quest.

    I am playing on a PC.

  • lelerammos
    ubisoft:x-posts, 3

    The closet does not move to continue the story. I have moved it in the past.undefined

  • Archanfel80HUN
    ubisoft:x-posts, 1

    The blood from stone quest - Search for the saga stone part unable to complete and broke the game main story.
    In the location Evinghou tower where the player need to find the stone (the body of who had the stone), its need to move a crate to open a door behind it.
    The crate wont move even if there is no obstacles around it.

    Tried several game relaunch, reload nothing helps.
    Every other crates like this can be move just this one not.

    System: Xbox Series X
    Digital copy

  • lukasteles
    ubisoft:x-posts, 1

    He same thing happened to me and I managed to solve it like that

  • Ravnsmod
    ubisoft:x-posts, 13

    @ubiexcellent just as an FYI I have this problem on ps4

  • Hassel99
    ubisoft:x-posts, 3

    Patch coming tomorrow Nov 26th

    I saw this in the patch notes

    • Addressed various issues with quests or world events that prevented players from completing them.


    https://www.ubisoft.com/en-us/game/assassins-creed/valhalla/news-updates/1uwOfZmlGNKNuMfFuWoybD/assassins-creed-valhalla-title-update-104

    Lets hope this gets fixed as i am stuck here as well.

  • Draefilk
    ubisoft:x-posts, 1

    @nessy_degrelle
    Everyone, this works. To help I've broken it down:

    1. Open the door
    2. Grab the 'moveable' object by pressing appropriate button.
    3. Don't hammer buttons in frustration! any extra button pressing may make you go past the glitch and have to start again!
    4. If you're lucky it will glitch you inside the 'moveable' object.
    5. At this point, face with your back to the room you want to get into. (Facing the room you were just in - see video)
    6. Press your crouch key once, this should glitch you into the room.


    There's nothing in the room, apart from a note to look at. So dont go back in there!
    The hardest part is getting the glitch to happen, I think moving towards the box then grabbing it helps, but I may be wrong.
    Open to ideas to make the initial glitch happen, any surefire solutions? it only took me a minute to get it to happen on PC.

    Good luck!

  • Ness_138
    ubisoft:x-posts, 2

    Found a fix! On Xbox, I opened the door from the left, went to the middle of the moveable shelf and spammed Y and B while moving forward. Once in the moveable shelf, I stopped moving and pressed B. I was able to go right into the room.

  • Ness_138
    ubisoft:x-posts, 2

    Found a fix! On Xbox, I opened the door from the left, went to the middle of the moveable shelf and spammed Y and B while moving forward. Once in the moveable shelf, I stopped moving and pressed B. I was able to go right into the room.

  • Dekrayzis01
    ubisoft:x-posts, 6

    Downloaded the latest patch v1.0.4 and STILL the glitch remains on PC for the 'Blood from a stone' quest when a cut scene should play right after speaking with Sigurd about the stone being taken and standing next to the dead body.

  • Georg1982
    ubisoft:x-posts, 3

    @georg1982 In Patch 1,0,4 its still broken .

    I whent to norway and back but its still stuck in the box on the right of it .
    what can I try to do ?

  • thatrouge
    ubisoft:x-posts, 2

    @UbiWan

    Tested after today's update still ongoing issue.

    Could we please get an update/Timeline for this Main story bug.

    Is it possible to change this into a rockwall that can be destroyed? or open up one of the windows as an Alternate way to get in, while I understand this can be a slow process it should be said in the future for MAIN story missions to at choke points have different ways to enter or complete. It seems after looking around on Forums / Reddit a lot of people are having this issue. Was really looking forward to moving on with the story with todays Patch and am sad to find this is still not fixed.

    Looking forward to your update

    Kind regards

  • Minamugi32
    ubisoft:x-posts, 2

    I have insalled the patch and hoped that all my bugs where fixed. NOT ONE HAS BEEN FIXED. such a dissapointment

  • STANKdankNIKKA1
    ubisoft:x-posts, 3

    Unable to move sliding wall to Paul and the saga stone. Restarting the game does not work nor does completely turning of the whole Xbox series x system.

  • guysch
    ubisoft:x-posts, 3

    Same here, Patch 1.04 installed on PS4

Suggested Topics