Welcome to discussions

Quick Suggestions

  • lucablight27
    1 posts

    Thats some top class ubisoft problem solving.

    Players: Hey, we encountered a literal story breaking bug, luckily we found a glitch that bypasses the problem but please fix the bug.

    Ubisoft: we will make sure you cant use that glitch anymore.

    The Brain Meme Will Expand Your Mindundefined

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I apologise for the double post. I'd like to reach out to you all with an update. I'm happy to announce that the issue wherein the shelf in Evinghou Tower cannot be moved is due to be fixed in TU 1.2.1. This update will deployed 27 April, 2021 at 1 PM CEST / 8 AM ET.
     
    If you are still encountering issues with Evinghou Tower following TU 1.2.1, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have TU 1.2.1. installed. You can view this information in the opening game menu in the bottom right-hand corner.
    • The issue still occuring in-game.

     
    Thanks all! 😊

    Official Response
  • Dylan_Black
    1 posts

    i have same issue, also the goliath underneath respawned. im on PS4

  • JONQ876
    1 posts

    This still isnt fixed even with the recent patch.

  • KLUEW
    13 posts

    @carmifele123 ok I see what u mean. I'll look up the location of the robe and ill travel there my self to have a look. That area is probably undiscovered for me but ill check it out for you soon as I get home.

  • Carmifele123
    16 posts

    @kluew here-s the location
    Suthexe
    undefined

  • AvELibre
    1 posts

    @wjack316 it worked but I felt a little bad for the dead guy I kept throwing at the blockade.

  • karolmc02
    1 posts

    Hi,

    I'm stuck in the Blood From A Stone mission.

    I arrive at the Ivinghoe tower and cannot move the shelf in order to open the door.

    I arrived at this tower once before this mission while exploring the world. I believe that to the left of the shelf there was a box I had to destroy in order to move the shelf however when I arrive at this tower in this mission this box is not there and I cannot move the shelf.

    I hope I explained myself. If not please ask for more info.

    It would be awesome if you could help me because I would like to avoid restarting the game because I already have like 40 hours played.

    Thanks in advance.

    Greeatings,
    Karol

  • Zinc.....
    1 posts

    THIS WORKED:

    There is a Goliath in the tower below. Use V (on pc) or Odins sight to highlight the enemy. You can access him via the outside of the tower. He is on the floor below. Access via window. I just used arrows to kill then carry. Throw body out of window and carry to the shelf room. As mentioned before, stand on box to the right and throw body to move shelf from right to the left. Eventually moves enough to access door.
    P.s Glitch didn't work for me. thanks Any way.

  • KLUEW
    13 posts

    @carmifele123 Well my dude I went and was able to move both obstacles to get the Mentor Robe. I seen no issue. The first obstacle u can't move cuz there is a box behind it so to the right there is a breakable floor that you shoot with an arrow then u dropit down break a door lock then go into the church. Is dark so u need ur torch. There is another obstacle to the left break them boxes then the chest is in the room. Use the same obstacle to reach the ladder to exit the church. Hope this helps.

  • Carmifele123
    16 posts

    @kluew
    yeah
    i know how it's supposed to work
    i canìt move the "another obstacle to the left" for some sort of bug
    just like i was perfectly able to finish the story without encountering the bug this post is about but you couldnt(on your first try at least)
    you can open that chest but i cant

  • MrCylon
    2 posts

    @kailiano Same here; playing on PC but it seems like this is happening cross-platform.

  • MrCylon
    2 posts

    @zinc If I were a woman I would bear your babies (unless you're a woman and...I'm not sure that works the other way). You are a God, thank you for helping me to bypass this bug and not lose hours of gameplay.

  • BerkerGoker
    1 posts

    @kluew You are the real hero. I've spend hours to this bug. The moment I'm so close to give up, I give it a chance and tried your method. After 40 throws somehow I managed to pass. May the odin guide you!! 🙂

  • Serefceliktas
    1 posts

    I am happy that it was a game error, I did not know whether I was sorry or not, we got stuck, what should we do Kill the NPC?

  • VladIIIMircea
    1 posts

    Hi, I have problem in Saga of Stone. The doors are blocked by an obsacle which could be moved but it is not possible. According to videos on Youtube, the obstacle should me moved to left. There should be a box which has to be destroy firstly. But I do not have this box, seems nothing to block but still the obstacle in front of the door is not possible to move and it is not possible to enter the room.

  • KLUEW
    13 posts

    @berkergoker your welcome brother, may we feast together in the great halls of Vahalla.

  • Dannyg1523
    3 posts

    @lionskin42 throwing the body worked, the jar didn't. Thank [censored] that's done

  • Dbz4life82
    2 posts

    I have xbox 1, the original, and I too have a bug on misson blood from a stone. It will not allow me to move the object in front of the door to enter room. I can no longer progress. Its slowly killing the fun in the game.

  • Dbz4life82
    2 posts

    I have the old school xbox 1. And the mission blood from a stone has a major bug. I cannot move the object in front of the door. And I've noticed this bug hasn't been fixed for awhile by reading some of these comments. It quickly killing the experience for me. :^( please fix.


  • mrvfc221
    1 posts

Suggested Topics

Community Details

63
Online
139.1k
Users
24.4k
Topics
126.2k
Posts