ubisoft discussions

Quick Suggestions

  • DargoDargo38
    2 posts

    Same. Can't do anything after talking to Basim
    Pease Fix it!

  • mrendler
    2 posts

    @jjbakes87 I can confirm that I tried this method and it worked for me as well. I didn't get any indication on how to proceed with the quest, went to Dover fortress to try what you posted, and after I assassinated him I was able to progress with the quest.

  • mrendler
    2 posts

    @dargodargo38 Go to Dover Fortress and go the middle building close to where the ability point is. Use Odin vision until you find a man who shows up blue, assassinate him and the quest will be able to continue. It worked for me.

  • DargoDargo38
    2 posts

    @mrendler nice thx worked

  • oh777yeah
    1 posts

    I have the exact same problem, originally I was unable to talk to anyone with a chat bubble, despite reloading, but killing civilians did work. However, the objective still doesn't populate nor is there anyone in the Inn with a chat bubble.

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    @oh777yeah Thank you for reporting this to us.

    Which objective are you currently stuck at?

    Official Response
  • Steinbach009
    3 posts

    I was doing the story line in cent "the abbot's gambit" i just talked to the bishop and i have to go to a messenger to get some information. On the way i did a mystery mission but it failed and i got black screen but i could run around. Decided to turn the game off and on again and afterwards i couldn't proceed with the mission.

  • xXelfninoXx
    4 posts

    In "The Abbot's Gambit" quest in the Cent storyline there is a sequence where I have to talk to people in a small village to find out where someone went. I cannot talk to anyone to complete the quest. I tried restarting the game, the console, fast traveling, saving. I have tried everything I can think of. I am stuck on this quest and cannot continue with the storyline...or talk to anyone any reason. Please fix this ASAP. I am playing on Xbox One. I absolutely love the game, but this has stopped my playing entirely. Please contact me via email and let me know if there is a fix or an update coming to fix the issue.

  • kjubaran
    7 posts

    Same issue here, raider that nearby monastery withc glithced the game, after reading this, i raided Dover Fotress and one of the soldier had orders. Thx

  • Moi2099
    2 posts

    I'm encountering some issues too. I raided the monastery before doing the quest and so, when I'm tracking the quest, nothing pops, there s just "The Abbot's Gambit". I'm in distrust area and I cant talk to anyone, and I've tried all of the above but nothing. I m at 50 hours and I will not do a new game since i ve completed at 100% a lot of territories. Please fix this fast !

  • A Former User
    0 posts

    If you are stuck on this, reload the save, and instead of chucking him into the river, walk into it while carrying him. This worked for me.

  • Steinbach009
    3 posts

    Is there a way to fully reset the mission because i did some other missions while the bug was active.

  • Ellyham
    1 posts

    Hey guys! I stepped out of the animus and walked around as Layla for a bit, then talked to the NPCs and got back in and it worked. I was standing just outside the inn and Eivor immediately began the story dialog and the quest updated. My friend did this as well and it worked for him too.

  • Revenskrev
    21 posts

    @wongzilla13 Had to meditate 3 times for it to work here.

  • cellq7
    11 posts

    Arrive at the Inn where the quest said but the quest log is blank and unable to talk to anybody

  • stardhstonew
    1 posts

    So I’ve been reading a lot of threads which point out how people can’t interact with the people in the inn, or the bard keeps glitching. I’ve progressed past that point, but at the bit where it tells me to “find and get the message”, I can’t progress because the messenger in question does not exist in my game. I’ve meditated, killed civilians, restarted the game, but none of these have worked for me. I’m 70 hours in, so restarting isn’t a plausible option for me, and I completed the Jotunheim story arc hoping by the time I was done the Fortress would reset itself (it did but still no messenger), so trying to go back all the way to when it initially glitched is also out of the question. Any help would be appreciated!

  • Ubi-Wan
    Community Representative 636 posts

    @stardhstonew Hello there! Thanks for reaching out about this, and sorry to hear you've still had trouble after preforming all these steps! I'd like to have a closer look at this issue in your game specifically. Could you perhaps provide us with a video of this occurring for review?

    Official Response
  • usrhlp
    5 posts

    Ffs Ubisoft does no one test this stuff?

  • guest-7sQVFkOG
    1 posts

    I have a similar issue to others. After speaking to Basim and the monk, nothing happens. I went off and spent days on other missions and came back to this after not being able to progress furher.
    I decided to load a previous save and lose all my progress to retry this mission.
    BUT it still has the sane issue.
    So frustrating and i cant play this game any further without completing this mission that blocks me from starting it???

  • BlueLupe
    7 posts

    I meditated for a bit and then it sorted itself out! Hope it works for everyone else too.

    I'm still stuck with the arrows bug though... I've upgraded my arrow capacity twice and instead of it going up in capacity, it's gone down. I daren't upgrade it again in case it goes down further. Going to Vinland doesn't work, as some have suggested.

Suggested Topics