Welcome to discussions

Quick Suggestions

  • alexwhitewell
    4 posts

    @ubikobold unfortunately i'm on a pc so can't do any of these things

  • BarciOBZ
    1 posts

    When in Xbox bug with Brother keeper Will be fixed?

  • burrocke
    7 posts

    @ubikobold you can only restore licenses on a PlayStation, I am playing on Xbox one

    fix this, a bug now deleted all my saves so thanks for the wasted money. And 80 hours wasted since release.

    fix your game, otherwise I’ll be requesting a refund and I’m sure many others in this thread will be doing the same

  • Greenough84
    4 posts

    @ubikobold Tried all of these methods, but unfortunately none of them worked for me. Restoring license on PS4 didn't work.

  • FYRAfyragyp
    1 posts

    I am having same exact issue as everyone else. Tried multiple methods of bypassing the bug but clearly is something that needs to be fixed. Also lost hours of progress for the third time since buying the game.

    I was initially excited that the game came out earlier than expected (Originally set to release Dec 31 back in May) but I would have rather waited a couple of weeks to start playing had I known there would be soooo many bugs.

  • ActingLeech8316
    1 posts

    Yet again 6 days [censored] later I am still unable to complete a game that has cost me £60 is there going to be a hot fix for this issue with this mission or are we all going to demand a [censored] refund getting really sick and tired reloading and competing it to be stuck in a room without a final boss fight. Tbh this is an absolute discrase brand new game that is completely broken and unable to complete with 0 reply’s from ea on when this issue will be resolved

  • Tylar23
    1 posts

    Over 80 hours poured into Valhalla just to get to the brothers keeper quest and have an unfixable glitch. I’ve tried loading in multiple times but it does not matter, even loaded in to an earlier save got back same problem. After going through the golden staircase I enter the room with no Sigurd or Basim, which I know is supposed to happen after multiple searches to find out what was going on. So I please ask that you please fix this bug without me having to start the entire game over that would be pretty nice.

  • AustinRupp
    3 posts

    I am officially in the same boat. Whooshing sound long white screen. I can move and fight during the white screen, I can also desync myself and reload during that white screen. I spawn into a big empty room. I tried loading old saves, changing the difficulty before, changing the difficulty during the Odin fight. I tried the recommended ps4 fixes in this thread and nothing. So I'm stuck sitting on my hands with 80 hours into the game unable to progress.

  • Greenough84
    4 posts

    Can we get some sort of compensation due to inconvenience when this gets fixed? Like I was planning on doing opal quests everyday and can't do any now because of this. Also sucks that this is going to be the first week I have off for months and I can't play this game.

  • Disc0fish99
    4 posts

    Hi guys
    I have a game breaking issue where in
    ive had the scuffle with Odin and then that’s lead to a cinematic with the stairs but this has then lead to me being stuck in the room by the tree and the story won’t continue I can’t leave or do anything at all
    please help
    121hrs in and now I’m stuck and if not I have only one save with 58hrs back 5 days of play

  • nomaad2
    1 posts

    I'm stuck at Odin battle , died , Sigurd appeared but nothing is happening , Odin is just standing there , Sigurd is probably calling for his army to come down the stairs and that's it. Loaded from autosave nothing happened...so that's it ? Won't be able to finish the game ?

  • Disc0fish99
    4 posts

    Hi guys
    I play on Xbox one
    live recently come to a glitch that stops game progression
    AFTER the main cutscene with the fight in ‘A BROTHERS KEEPER’ it fades to white and then loads me into the room with the tree alone with nothing else, I’m unable to continue I know it’s meant to then have a cinematic with Evior waking up on the arm and jumping down
    I have tried reinstalling the game twice mediating and dying and doing anything possible
    please help I’m 121 hours into the game and if it can’t be fixed have to revert 58hours prior as that’s the only save I have left
    many thanks Dan
    #bug #report

  • Dylan1990_
    26 posts

    @synxc they started replying to other people on a thread about a door being stuck (which i too had that issue) so i mentioned this problem since we are not getting help and they said they are still investigating it so we are no where close to getting to play again

  • Disc0fish99
    4 posts

    same I’m 121hrs in now with a dead save

  • Disc0fish99
    4 posts

    I’ve got the issue on Xbox one
    my games a digital land it has the cutscene but then doesn’t show me getting down or anything and I’m stuck in the cavern as well

  • Dylan1990_
    26 posts

    @nomaad2 did you put away your axe and run to sigurd ?

    2 posts

    Has anyone else ran Into the brother keeper bug where you beet odin and your in the room but no boss fight just blank room can't get out of I have and there is no work around on Xbox one so I'm literally waiting for it be fix

  • mphgp
    1 posts

    @fragnight55 the same thing has happened to me. I’m on Xbox too.

  • Synxc
    12 posts

    @dylan1990_ This is just insane, it’s been well over a week and they are still investigating even though countless people have provided all kinds of reports to them. I am truly disappointed in Ubisoft because of this, it breaks my heart

  • Dylan1990_
    26 posts

    @synxc somebody complained that they were offended by dialogue and they responded in an hour and had it changed but a genuine bug breaks the game and they dont even try help, its embarrassing really

Suggested Topics

Community Details