Welcome to discussions

Quick Suggestions

  • 0 Likes/326 Replies/13287 Views
    2 posts

    Has anyone else ran Into the brother keeper bug where you beet odin and your in the room but no boss fight just blank room can't get out of I have and there is no work around on Xbox one so I'm literally waiting for it be fix

  • mphgp
    1 posts

    @fragnight55 the same thing has happened to me. I’m on Xbox too.

  • Synxc
    12 posts

    @dylan1990_ This is just insane, it’s been well over a week and they are still investigating even though countless people have provided all kinds of reports to them. I am truly disappointed in Ubisoft because of this, it breaks my heart

  • Dylan1990_
    26 posts

    @synxc somebody complained that they were offended by dialogue and they responded in an hour and had it changed but a genuine bug breaks the game and they dont even try help, its embarrassing really

  • Itsthelagg
    1 posts

    @burrocke same [censored] a bunch of BS

  • Synxc
    12 posts

    @dylan1990_ Amen to that brother

  • garantat100
    Original poster 3 posts

    @ubikobold just fix the game already... the other game developers had issues too with the new releases and the fix was fast... why can’t Ubisoft do the same?

  • Giovanni1980470
    1 posts

    After I defeat odin it puts me back in the room with no missions just running around I've reloaded the save even gone to previous chapter and done all again and still the same glitch I've uninstall and reinstall still the same please help Its been 3 days now

  • awesomeki11er12
    1 posts

    I am on the "A Brothers Keeper" and when i finish the Odin fight i load back into the tree room but am stuck there and nothing else happens, I have tried loading previous saves but nothing changes

  • Dylan1990_
    26 posts

    @garantat100 they have replied once in this thread and it was to fix the PS4 like how was this game released in this state, €100 and i can't even play it

  • r.bain
    1 posts

    Same issue here, on Xbox One S specifically and stuck like all of you. I get that there are bound to be bugs but this particular issue is non-excusable.

  • Super_hot
    1 posts

    A major game breaking bug occurs late game during the Brother's Keeper quest that has a fight with ODIN, a cutscene, but afterwards upon exiting Yggdrasil, a strange sound happens in the loading screen and the cutscene that is supposed to occur doesn't, leaving you stuck inside the chamber with no option to escape. Loading saves and even reinstalling the game does not help. Needs to be fixed as I cannot play any further.

  • spanntana
    6 posts

    Nov 24th and still no fix... i have litterally done everything except dobbys shrine... cause why would you need 5 more fabric right?... and yup reloaded my save many times now even from the start of rygjafylke but when i get there eventually... im just standing there alone in an empty room... 134hrs of wasted gameplay if i cant even finish the game... 100€ down the drain.

  • UrCasualGamer
    1 posts

    Same problem as everyone else. I fight Odin, I drop the axe, I go up the stairs, long white loading screen, once done loading I’m in front of Yggdrasil with nothing to do cause the cutscene didn’t load. Whenever I reload, I hear a “shink” sound and I spawn damaged. This is apparently meant to be the last mission in this part of the storyline and I can’t even finish the game! I’m afraid of reloading a manual save that I have since it’s in the “A Love Betrayed” quest

  • DuskDragon56496
    379 posts

    I noticed Ubisoft put an exciting news post talking about how this game has sold more in the first week than any other, well goody goody for you Ubisoft,but I noticed they didn't bother to mention that you might not be able to finish it,such is my case.I'm stuck in a cavern with no ability to get out or venture to the end of the story, and no matter what I try nothing works.So maybe after you guys are done counting your money, swapping spit and patting each other on the [censored] you can provide a fix for that.Because we're not talking about a tree out of place or a whale riding on top of the water,this is a game breaking bug which should have been addressed immediately...and as usual...wasn't!
    There were so many bugs in this game 'it' almost defeats the purpose to even attempt to play,for example,the part where uou're dressed into a costume to go trick or treating,the costume wouldn't come off no matter what I did,and every save from that quest stated data corrupt.I literally had to keep playing trying to find a way to get it off,finally I went back to the town and the mask came off and then later the cape....then about 30 hours later a cut scene played with the mask and cape back on with continued data corrupt saves.but the worst by far is a brothers keeper,I simply can't play any further because I'm stuck there and Ubisofts continued silence on these issues with no fix in sight isn't exactly inspiring me to have any patience or faith that they're even concerned about it.but hey...they sold more copies in the first week than any other game,just a shame a lot of people won't see the end of the game,at least until they get around to it! Get with it Ubisoft,at least show a little courtesy to your customers,little glitches yes we can wait a while for a patch but game breaking glitches we shouldn't have to, and if there's any doubt to what I said review your own megathread on glitches.You're new forum sucks by the way it's a classic example of if it isn't broken don't fix it,well,I guess now you have something to fix,if that was your intention!

  • UnearnedLion678
    5 posts

    @duskdragon56496 I am not sure what is your issue but you need to unequipe your axe to progress

  • DuskDragon56496
    379 posts

    yes i'm well aware of that, and after Eivor is pulled through the doors there's a long white reloading screen where she's just standing in the cavern instead of her and Sigurd being there,geez dude do you think i would have bothered posting if it was something simple?But anyway that's the issue she can't go anywhere and she can't fast travel the game is broken!

  • mgaw2340
    1 posts

    When will the big get fixed for a brothers keeper?

  • StuLife
    1 posts

    @tylar23 same thing happened to me, and I had 70 plus hours put in.... this needs to get patched ASAP

  • Belfahl
    14 posts

    @unearnedlion678 at the rate they're addressing other issues, probably June 2021.

Suggested Topics

Community Details