Welcome to discussions

Quick Suggestions

  • vinckeee
    6 posts


    Yea finally thx man it did work for me on ps4 after 5 days I, am finally out that stupid cave

  • ModernZoro
    3 posts

    Ran into this bug as well on xbox

    • I tried loading previous saves, including ones before leaving Ravensthorp with Sigurd.
    • Un-equiping weapons during valhalla fights
    • changing difficulty levels
    • loading from cloud on a different xbox (original xbox one to xbox one S)

    I did have one load where I did not hear the 'shink' sound... but still end up in the tree room with no cut scene intro to next fight

  • vinckeee
    6 posts

    Switch to inventory and map 10 times and press on atlas when you do that and you can teleport to England back

  • AustinRupp
    3 posts

    @ModernZoro if you have a save from before the mission you could try this: right before Sigurd touches the sphere change the difficulty or switch nudity on/off to reset the game. It worked for me yesterday. I have read that it doesn't work for everyone though and some had to try multiple times. I've also read not taking odins staff has fixed it for some.

  • AnimusLover
    85 posts

    @sofajockey I think Dragon has asked you that question to prove a point that it would be a) difficult to locate the point at which he should go back to stop the bug from occurring and b) no guarantee that going forward it will. He could potentially be wasting his time. Therefore, if all does not go well what then?

  • jeffhenn1
    1 posts

    Stuck after the Odin fight at the tree of life

  • ModernZoro
    3 posts

    @austinrupp No luck. and I completely missed the whole Odins staff thing. Will keep trying

  • DuskDragon56496
    367 posts

    well if it won't correct a save game then what good would it do to go back to an earlier save period, sofa I appreciate your response and your suggestion but to end this nonsense of going back to earlier saves in hopes of fixing the bug I had already tried that several times and it didn't work...ok?As a matter of fact I also tried Ubisofts suggestion of uninstalling and reinstalling the game,what that did was give me a data corrupt in every save slot I had, so my game is lost anyway...doesn't matter anymore.Fortunately I saw that a patch is being released tomorrow so maybe they found a way to fix it, here's hoping!

  • JC_GAMER884
    7 posts

    I just want to follow up on the time frame on when i can be able to play.

  • Synxc
    12 posts

    @vinckeee I thank you my good sir, doing this actually works, however I am not sure if the quest will work on not at all if you leave that area, I will investigate and come back to you

    EDIT: You can get back to England yes, however you can't do any quests as the game thinks you're still in the Yggdrasil area. I do not recommend doing this but if you want to the opton is there for you.

  • thisan48
    5 posts


    You've got to be [censored] kidding right? First I get plagued with the stupid fabric bug for fully upgrading my pouch and quiver before reaching that specific offering alter (A great slap in the face for actually fully expolring the game thanks), then my game randomly crashes (Always during cutscenes and happened 7 times so far) and now I get this game breaking bug where the mission objective disappears and stays that way before and after fighting Odin.

    135 hours played only to be [censored] like this. What a horrendous experience this has been. I've been defending this franchise for a long time and I'm running out of patience. Please fix this.

  • Ubi-Woofer
    Ubisoft Support Staff 768 posts

    Hello everyone,

    Thank you for continuing to share your reports of this issue with "A Brother's Keeper" here in this thread. I've merged a few newer threads about the issue with this one, so I do apologise if any conversations have become disjointed as a consequence.

    At the time of our previous reply, the developers were still in the early stages of their investigation, and had been unable to reproduce the issue. At present, this investigation continues as we have received several reports of the issue, and continue to collect information that may be of help to them.

    If possible for anyone to provide, additional videos of the issue (as requested by Ubi-T00n) and save files of affected players on PC or PS4 (unfortunately it isn't possible for us to acquire Xbox save files) would be much appreciated. Videos should be provided by hosting them on an external site like YouTube and then providing a link, while save files can be prepared by following these instructions and then submitted via a support case or Live Chat. Once submitted, all you need to do is quote your case reference number here in this thread and we'll take care of gathering those and forwarding them for you.

    Please accept my sincere apologies for this issue, and I hope that I'll be able to share more news soon about a fix.

    Official Response
  • spanntana
    6 posts

    @ubi-woofer sooo.... in plain english you are saying even after the patch this quest is most likely still [censored] up?

  • Arsenal2029
    1 posts

    In this quest after you leave the room where you fight odin the screen goes white for a while and when you load back into the room where you and sigurd entered the simulation nothing happens.My understanding is that there should be a scene playing with basim and sigurd but nothing happens.Im stuck in that massive room just able to run around. I have 94 hours played on my save and i dont have a save from before the quest so im screwed.I tried reloading an auto save I restarted my game and tried everything but still no fix. Ubisoft needs to fix this soon as it prevents any further progression

  • kanedapen
    1 posts

    Please put a fix in for this Mother of all glitches!

    81 hours in and cannot progress in Brother’s Keeper quest following boss fight with Odin. It’s a great game but no doubt this leaves myself and others feeling cheated about not being able to finish or even escape via world map.

  • Synxc
    12 posts

    I can confirm, this update fixed the issue!

  • UbiT00n
    Community Manager 73 posts

    @jc_gamer884 Thank you so much for providing this! Will forward it onto the team now.

    Official Response
  • Dylan1990_
    24 posts

    @ubit00n fixed for me too

  • spanntana
    6 posts

    @ubit00n Hooray! Same here!
    i finallly was able to finish the mission! (Remind me to never watch groundhog day again!)

  • ModernZoro
    3 posts

    Patch fixed for me too!

Suggested Topics

Community Details