Welcome to discussions

Quick Suggestions

  • 0 Likes/332 Replies/15437 Views
    1 posts

    I just can't go up the stairs to finish that part of the game

  • hammerthecanary
    10 posts

    I've got past Odin and Basim and got to the animus and after I go back into the Animus with Basim and go back, Hordafylke arc doesn't come as as complete when I wake up and still has the dagger on the alliance map.

    Have carried on for another 10 hours doing other stuff as thought it would eventually pop so can't move on to Hamtunscire arc.

    Any clues???

  • KnifexTwisted
    3 posts

    @crimzenvision Honestly, if I were you, I would go back to that save because although it is 2 days old, I have been waiting probably about 2 weeks now for a fix to this bug so 2 days isn't that bad compared to 14.

  • burbie52
    1 posts

    I am in the Odin fight and I know I need to unequip my axe to leave the area but it wont let me. When I go to my inventory and highlight the axe it has no button to push to unequip that is highlighted to allow mw to do so. The button is there but dark so I am stuck in an endless fight. Does anyone from Ubisoft look at these posts? I also have a few other glitches that have appeared in the game like large fish never appear for me when I catch them I just look like I am holding the air. There are no chickens at my chicken farm in my village and when I update it it never changes and I have also killed 3 legendary beast but only one trophy has appeared in my hall. I hope they fix these.

  • Tedybear315
    1 posts

    Ran head long into this one a short while ago. (12/3 with the latest patch installed) Xbox one base system.

    Finished up listening to Odin (seriously what a head case that fruitloop is...) and I see dinglenuts 'beckoning" me to the open doors and the staircase. I can run to the stairs....and then go right into the stairs! For those that have played older games with the 'cheat code' of "NO CLIPS". That's exactly what the stair case does. I can run right into it! And it's like it doesn't exist. I can go behind it....through it... The one thing I can't do? Is CLIMB the stair case!

    No other interaction is possible. Odin stand their like an idiot repeating the same line.. My "Brother" stands there waving his good arm for me to come over... I can run allllll over but it's pretty well broken.

    I'll try a few other saves, but for cryin' in the sink Ubisoft... This one's all over social media like a rash!
    (and don't even get me started on the fact my character sounds like she chain smoked about 40 cartons of marl's before entering the sound studio)


  • vinckeee
    6 posts

    Hi, 2 weeks ago I reported a major bug to Ubisoft (via this forum and email) but I still did not receive a reply from them. Does anyone share the same experience? I'm really disappointed.!!!!!!

  • Deathw0lf92
    2 posts

    hi everyone,

    is this still not working for you guys? ive teleported out and 100% everything else apart from some of the hoard maps as one keeps spawning after i collect it and another one doesnt appear. i am on xbox 1 does anyone know when this will be fixed?

    also, the door is shut when i go back to see if i can get back in

  • Deathw0lf92
    2 posts
    This post is deleted!
  • DangerCoy
    1 posts

    After I defeat Odin, Sigurd appears. I run right through the damn stairs. 🤣 110 hours into this game and I can’t beat it because of this glitch.

  • thedjc880
    1 posts
    • I've run into this same issue and the worst part is that there's no way for me to even get the patch when the problem is dealt with. Something that doesn't get talked about at all is those of us who are rural gamers. I live so far in the middle of nowhere that internet isn't an option and don't even get enough phone signal to complain about it here until I'm about 30 mins away from my house. I feel like I've wasted $60. This isn't the first game I've had a problem with either and it probably won't be the last, but I wish these companies would make sure the game fully works before they release it to the public
  • UneaseSole
    1 posts

    I cannot contiune on in this damn part "confront Basmin" I can not complete it because the platform ISNT RISING

  • JesskaZombiee
    1 posts

    Xbox one S
    My Brothers Keeper Quest: is glitched when I need to defeat basim it is stuck on him crouched and nothing happenes, I tried jumping off edge to see if killing myself in the game would work but no, I went to other saved things to try to restart the quest but it still gets stuck on that part..I also restarted the game and even restarted my console
    I put so many hours in this game ughhhh

  • feresassal
    9 posts

    After starting to control Basim, right after the "Sigurd Strikes" cutscene, I accessed ANIMUS, but nothing happened. No cutscene, no mission ending progress. The mission is not complete and, no matter what I do, I cannot start the Hamtunscire arc.

    I saw on IGN that there should be a cutscene of Eivor and Sigurd returning to the camp, but none of that happened. Obs: I had enough choices for "the good ending".


  • feresassal
    9 posts

    @hammerthecanary same issue here

  • NimaPasha
    1 posts

    @tyranzyt I Have Same Problem What Did You Do?
    Problem Solved?

  • bookhorn
    1 posts

    When Eivor faces Odin, and is defeated, Sigurd appears and calls for Eivor to stand. She does, and goes toward Sigurd’s gate, but the stairs have no texture; she just goes right through it.

    Please do fix this! It’s really an awful glitch. Would hate to not be able to finish the game.

  • guest-vBE4tqmj
    1 posts

    @disc0fish99 How did you fix it

  • nerwenancalime
    3 posts

    I just got up to this quest and can't get into the circle to progress further. The game freezes when I touch the edge and Sigurd is left hanging in mid-air. (I believe there is a fight with Sigurd after this point, but my game won't even get to that point). I'm on PS4.

  • guest-RXmjHlmK
    1 posts

    Defeated by Odin, Sigurd tells me to stand but then nothing... no cutscene, fight, anything. Check to see if I can reload a save and several are all corrupted. Managed to exit, quit and re load the game and its placed me in valhalla so not too much time lost. Hopefully it works this time round

  • Ricksteri1
    1 posts

    I am stuck after fighting Odin I run to the stairs and nothing happens I just run right through them. This is a bummer 😕

Suggested Topics