Welcome to discussions

Quick Suggestions

  • 0 Likes/331 Replies/13772 Views
    2 posts

    @ubistorm I didn't even get to stun him the cut scene ended and he was just crouched from the begging I've tried stun attacking him shot arrows at him I've jumped of the map it's the standard issue of the game

  • Ubi-Borealis
    Ubisoft Support Staff 3931 posts

    Thanks for providing us with some more information about the trouble you're encountering during your fight with Basim, @Robcoll9214. If possible, would you be able to send us video that shows how you're unable to progress in the fight? We can then pass this along to the development team for them to take a closer look at.

    I'd recommend uploading the video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread.

    Thanks! 😊

    Official Response
  • Micu1982
    1 posts

    There is no gate to run to in Odin fight in My brothers keeper mission..

  • Ubi-WheelyDuck
    Ubisoft Support Staff 430 posts

    Hey @micu1982,

    Sorry to hear that you have encountered this issue with My Brothers Keeper mission.

    Would it be at all possible to share a link to a video with us so we can see exactly what you see?

    Many thanks

    Official Response
  • carminereverse
    1 posts

    @tnoutlaw0816 remove your axe

  • Ubi-Woofer
    Ubisoft Support Staff 1195 posts

    Hey there @carminereverse - welcome to Discussions! Thanks for repeating the solution for passing by the Odin segment of A Brother's Keeper here in the thread.

    If you or any other player still requires assistance with regard to this quest, or if you're unable to proceed despite having your weapons unequipped, please let us know and we'll be happy to assist as best we can! 🙂

    Official Response
  • Blink_Eye3
    3 posts

    First time downloading again (on a different PS4) since last November because I Had the "Brothers keeper" quest and everything went great until I woke up from the Animus to go get into Shawn's van and my game completely crashes into the blue error screen every time. I've tried everything even redownloading the game. I've 72 hours invested so deleting my save file isn't an option. Anyone else have the same problem? Hopefully they've patched it by now.

  • Ubi-Froggard
    Ubisoft Support Staff 597 posts

    Hey @blink_eye3

    I'm sorry to hear your game is crashing with a blue screen. This isn't the same issue that has been reported that others have been experiencing but it sounds like a Sony CE- error screen you are having.

    Does it give you an error code that starts with CE (such as CE-34878-0)?

    If so, this is PlayStation error code. CE actually stands for Console Error and we could only suggest checking their support site or contacting their support. I have linked their site here where you can search the error code for some guidance on what to do.

    Official Response
  • Blink_Eye3
    3 posts

    @ubi-froggard Thank you so much for the quick response! I've got a new PS4 now and I'm about 90% downloaded so Ill definitely keep you updated to see if the problem still exists. Also if my saved files were corrupted because of this, is there any chance in restoring them? Thanks again!

  • Ubi-Froggard
    Ubisoft Support Staff 597 posts

    @blink_eye3 Ah OK, hope that you no longer have the issue on the new PS4. Just something I would recommend though, is to have the game installed on the main PS4 HDD, not an external HDD, just in case you were going to do that.

    Your save data is uploaded to the cloud in-game, so it should detect your save game automatically for you.

    Official Response
  • Blink_Eye3
    3 posts

    @ubi-froggard Awesome, thanks again! Everything works great! I guess it was just my POS PS4 lol.

Suggested Topics

Community Details