Welcome to discussions

Quick Suggestions

  • bossmandav91
    5 posts

    Just finished honor has two edges and the next quest won't start I have no marker or quest in the log any ideas

  • Ubi-Keo
    Ubisoft Support Staff 1443 posts

    @bossmandav91 @xADay2Rememberx I have merged your threads together to create a megathread. We have also received two other reports from players experiencing the same issue.

    Could you please provide a video of your quest log screen. We would need to see your active quests and completed quests. On the completed quests screen please scroll down slowly.

    Official Response
  • bossmandav91
    5 posts

    @ubi-keo I just tried to send video but it said I don't have the privileges

  • bossmandav91
    5 posts
    This post is deleted!
  • bossmandav91
    5 posts

    Problem solved I reinstalled then loaded an older save

  • SirShredsAllot
    3 posts

    After finishing Honor Has two Edges, I went to continue on to the Road to Hamartia quest but nothing has loaded. no quest marker, no directions, nothing at all. I've tried to Uninstall and reinstall the game from my xbox and that didn't work. the game is in purgatory until someone can help me get this fixed.

  • Ubi-Mark.
    Ubisoft Support Staff 1323 posts

    Hello @BBowlin92,

    Sorry to hear that you are unable to proceed.

    Can I kindly ask you to provide us with a short video of this occurring, so we can investigate it further for you?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • SirShredsAllot
    3 posts

    @xaday2rememberx I'm having the same issue, I also can't give medallions to hytham from the order members I've taken out. I only have the Father to track down. I'm super annoyed considering I've spent way too much time on this game just for it to be broken

  • SirShredsAllot
    3 posts

    @ubi-mark I'm unable to upload the video.

  • Sdadams1013
    1 posts

    Cannot complete this region. This is preventing me from finishing the game. There are no mission icons on world map. Any progress on fixing this bug?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello there @Sdadams1013! Welcome to the forums 🙂

    I'm sorry to hear that you've encountered this issue, and are unable to complete Eurviscire. Thanks for taking the time to share your report with us. The development team are aware of this issue and they're currently investigating further. We don't yet have any new information to share from the investigation at this time. I've now passed on your report so they can take a closer look at this as well.

    If we have any new updates to share, these will be posted within this thread and in the News & Announcements forum.

    Thanks 😊

    Official Response

Suggested Topics

Community Details

72
Online
193.3k
Users
32.6k
Topics
163.2k
Posts