Welcome to discussions

Quick Suggestions

  • AegisCruiser1
    1 posts

    Currently not working for me no matter where I stand. Frustrating.

  • nclc-assasin
    1 posts

    Has any one done the reconstruct of ragnar on the Xbox one it is showing the quest but it is not loading for me

  • Ubi-Borealis
    Ubisoft Support Staff 4165 posts

    Hello there!

    As we have had no further reports that players are unable to start "The Lost Drengir of Ragnar Lothbrok" cutscene, we will be marking this issue as resolved.

    If you're having trouble starting the cutscene, please try the steps suggested by @SciPhiFan:

    I spent over an hour searching the internet and trying different variations but finally came across one that really helped. That being the case, I feel I should give credit to "JoeTheBard" who authored the following:  https://www.gosunoob.com/assassins-creed-valhalla/lost-drengr-ragnar-lothbrok-reconstruct-ragnars-death/  I hope this is OK to do this.  Thank you JoeTheBard.

    In his description, he mentions "tap R3, rather than hold it as usual". On the XBOX, R3 = Right Stick. Normally, Holding the Right Stick gives you FOCUS and Tapping the Right Stick on the XBOX LOCKS you on an enemy target, so that locked me on one of the snakes. So I killed all of the snakes, even though other guides I found said not to. Once the snakes were dead, I looked at the marker on the cage and tapped the Right Stick quickly and the cutscene activated.

    If you are still unable to trigger the cutscene after trying these steps, please can you send us a video that shows you're unable to "focus" and start the cutscene. We can then pass this along to the development team for a closer look.

    Thanks! 😊

    Official Response
  • PJc62
    4 posts

    @bobbiloff you absolute legend. As you say just click R3 don’t hold R3. This worked for me after months of failing to trigger this darn cut scene.

  • Ubi-Mark.
    Ubisoft Support Staff 1749 posts

    Hello @PJc62,

    Thank you for sharing this! We're glad that this issue has been resolved for you 🙂 Happy gaming!

    If anyone else is still experiencing this issue, can I kindly ask you to provide us with a short video, so we can investigate it further for you? Many thanks!

    PS: I moved this thread to the Player Support section for better visibility 🙂

    Official Response
  • LimeBirdy
    1 posts

    @wolfslayer6921 holy hell, this actually worked. I had been trying to get around this stupid quest bug for months. Just jump in and mash R3 until the dialogue engages! Amazing.

  • Ubi-Borealis
    Ubisoft Support Staff 4165 posts

    Welcome to the forums, @LimeBirdy! I'm glad to hear that you've been able to successfully trigger the cutscene in "The Lost Drengir of Ragnar Lothbrok" 😄

    If you encounter any further trouble, please don't hesitate to reach out within the forums 🙂

    Official Response
  • Jackie.Chan.O
    1 posts
    This post is deleted!

Suggested Topics