Welcome to discussions

Quick Suggestions

  • azullFR
    717 posts

    @jmcgrane9
    I think you should make a Topic on it, with the title : Quest "The Lost Drengr of Ragnar Lothbrok" Bug
    On PSN community I already know 1 person with the same bug as yours...

  • Fallout09
    2 posts

    @reef11191
    Same for me. I see the green knot icon on the cage but can't interact nor does cut scene trigger.

  • Leftover_Pizza
    13 posts

    @jmcgrane9

    Tap R3 (focus) instead of holding it. That's how I got it to work, after doing it wrong a million times.

  • ApkPaul
    1 posts


    I can't complete Ragnar's drengrs mission because I can't interact with his cage

  • brandynmick
    1 posts

    Trying to reconstruct ragnar’s death at the snake pit is not working. I have tried hittthe r3 button but all it does is highlight in blue where to look. Which I do but I haven’t received the cutscene yet. Is there a way to fix this bug without losing my progress?

  • moriatii
    31 posts

    Finally it works, I knew it would but I still had issues getting it going.

  • kreutzgang
    635 posts

    You have to activate "focus" for it to work. The dagger is rubbish anyway though.

  • Wolfslayer6921
    2 posts

    I found a fix for “reconstruct Ragnar’s death” quest glitch where it keeps saying focus on the cage. I looked at the cage and pushed r3 really fast, maybe like three times, it started the cutscene. (I was inside the pit when I did this)
    I hope this helps/works for someone too.

  • Wolfslayer6921
    2 posts

    @apkpaul

    try pressing r3 super fast about three times while in the pit and looking at the cage. I got the cutscene after I did this.

  • lilflips1311
    1 posts

    Beat all 6 of Ragnar’s drengr way before the river raid update came out and now that it’s out I don’t get the mission to finish it and get his dagger

  • cburcker57
    1 posts

    Same for me

  • ACLAWMAN
    3 posts

    cant complete the lost drengir of Ragnar lothbrok quest as it’s doesn’t let me interact with the cage. It’s so annoying

  • jadefairall
    2 posts

    Can’t complete the lost drengir of ragnor lothbrok as cut scene doesn’t start. Have tried all the suggested fixes and none have worked.

  • firewolf1971
    3 posts

    for the Ragnar Lothbrook Death Scene after you kill the snakes go to the dead snakes from top right all way walk in their positions to left side of cage then look at cage in focus it should start then it is what I did

  • sbenyo
    22 posts

    Same for me. How come a new quest is already buggy?? After long waiting for fixes this is totally ridiculous.

  • NativeRock9015
    3 posts

    I cannot get the cutscene to trigger, I've reloaded previous saves, logged out then tried again. It won't trigger no matter what I do. It's extremely frustrating. Hopefully you will have a fix for this bug soon

  • mrfenske
    1 posts

    @nativerock9015 hi there have you had any luck yet? I'm going mad trying to get it to work

  • VanadiumCobalt
    317 posts

    @mrfenske I will assume you followed the Green Quest icon? When at the pit try looking at the cage for the prompt to focus on it? Does that help?

  • bobbiloff
    8 posts

    Hey guys - I had some trouble with this too - when you're down in the pit looking towards the cage - try clicking the right analog stick, not holding it as you would with the loot pulse, just click it. Or whichever equivalent it is on PC.
    That's how you "focus" on a few things in the game with the camera and then Eivor should talk and trigger the cutscene. Hope that helps 🙂

  • NativeRock9015
    3 posts

    @mrfenske had no luck whatsoever unfortunately. Quests I'll just have to wait till they fix it.

Suggested Topics

Community Details

90
Online
141.8k
Users
25.0k
Topics
129.8k
Posts