Welcome to discussions

Quick Suggestions

  • Lukinator75
    3 posts

    I came across some bug that in the shipyard you can choose the colors of the shields on the ship, and in the Viking ship you can't see these shields. There are some regular random shields or Jomsvikings. I don't know what to do to get these shields on the ship. I set up the Asgard Shields and can't see them, the whole Asgard set will not be visible. Please help. There was no option to hide the appearance in the shipyard.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    Hello there @Lukinator75! Welcome to the forums 🙂

    Thanks for taking the time to report this. Just to check, are you referring to your main long ship or your river raid long ship?

    If possible, could you send us a video that shows the issue you're encountering? We can then pass this along for further investigation.

    Thanks! 😊

    Official Response
  • headbanger866
    21 posts

    I cannot change the shields on the sides of my long boat. I'm on PS4.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    Hello there @headbanger866!

    Thanks for taking the time to report this. I'm sorry to hear you're having trouble changing your shields. If possible, would you be able to send us a video so we can take a closer look at this?

    Thanks! 😊

    Official Response
  • headbanger866
    21 posts

    @ubi-borealis
    Thanks for replying, can you tell me how to upload my video so you can view it?

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    You can upload the video to a sharing platform (such as YouTube or Google Drive), and then post a shareable link within this thread, @headbanger866. That's the best way for us to view a video.

    Thanks! 🙂

    Official Response
  • Lukinator75
    3 posts

    Thanks for taking the time to report this. Just to check, are you referring to your main long ship or your river raid long ship?If possible, could you send us a video that shows the issue you're encountering? We can then pass this along for further investigation.Thanks!

  • Lukinator75
    3 posts

    @lukinator75 I solved the problem. I launched the river raid, my first mission with Vagn, after returning from the raid, my long Viking ship in Raven's Landing already has shields banned.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    Thanks for the update, @Lukinator75! I'm glad to hear that you've been able to resolve the issue.

    Please don't hesitate to reach out if you require any further support 😊

    Official Response
  • Gutao_com_G
    6 posts

    The just-now released Black Raven Ship Set displays the incorrect ship shields. Instead of showing the Black Raven shields on your ship, it shows the Black Flag ones.

  • Gutao_com_G
    6 posts

    @gutao_com_g And of course this is after equipping it in the ship hut in your settlement, obviously. Your ship will have the black flag shields instead of the black raven ones.

  • headbanger866
    21 posts

    @ubi-borealis
    Thanks for replying, but i tried something to see if it would work, and it did. When i changed the shields on my river raid long boat,which worked fine, it solved the problem on my settlement long boat.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts

    Thanks for the update, @headbanger866! I'm glad to hear you've been able to resolve your issue with the shields. Thanks for taking the time to share what worked for you here as well.

    If you have any further questions or concerns, please don't hesitate to reach out 😊

    Official Response
  • GoodGuyC
    2 posts



    the longship has a bug related to the shields i choose in the customization menu the wonderlust type but it still reamins the classic raven,i have tried to select the raven one and relselect after but it doesnt work,

  • Abid653
    6 posts

    Whenever I change my shields on the longship, they always change into the helheim shields even though they are not the shields currently equipped. The only shields I think this bug doesn't happen with is the default shields: the raven clan shields.

    Thanks in advance for any help.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @abid653 Hey there! Thanks for sharing this, it definitely sounds like a strange issue. Could you grab a video showing you having selected different / no shields on your ship then setting out with the wrong shields visible? We'd appreciate having this for review!

    Official Response
  • Abid653
    6 posts

    @ubi-wan



    To be honest, I could've displayed this with more shields but I first noticed this bug occuring when I tried putting the jackdaw shields on. So the 2 that are definitely buggy are the raven clan shields and the jackdaw shields.
    Would have to check the other ones if necessary.

    Thanks.

  • Abid653
    6 posts
    @ubi-wan


    To be honest, I could've displayed this with more shields but I first noticed this bug occuring when I tried putting the jackdaw shields on. So the 2 that are definitely buggy are the raven clan shields and the jackdaw shields.
    Would have to check the other ones if necessary.

    Thanks.

    Sorry I meant black raven shields instead of raven clan shields.

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello!

    Thank you for the update. I reported this issue to the development team and it's currently being investigated. Once we have an update, we are going to let everyone know through the patch notes. Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • Abid653
    6 posts

    @Ubi-Mark Thanks and I forgot to mention I saw another bug which was caused by the recent update I think. My Jomsviking's gear keeps resetting to the default base gear despite me putting different gear on him and it would be difficult to get a video because I'm pretty sure it happens everytime I turn off a game session or go back to him after several hours. I've also seen other players' Jomsvikings gear as the base default gear rather than different gear but it has not affected the Jomsvikings I have already recruited on my longship.


    Thanks again for the help.

Suggested Topics

Community Details

140
Online
140.0k
Users
24.7k
Topics
127.7k
Posts