Welcome to discussions

Quick Suggestions

  • 1 Likes/79 Replies/3180 Views
    Auron418
    13 posts

    This is the shield I have, I got it the day the river raids came out and somehow I can't change it. undefined

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @lithiumxstp & @Auron418 I'm sorry you both have encountered this error with the ship shields, but I've notified the teams of such on their on-going investigation. We will continue to share updates about this error here and on the News and Announcements forum, so please check these locations for new information.

    Official Response
  • Ubi-Keo
    Ubisoft Support Staff 2384 posts

    @twitchity Thanks for reporting this issue. Could you please provide a video to show this.

    Official Response
  • Dicorn
    3 posts

    This is an issue for me aswell. And I have now yet started River raids quest. I just got myself Nilfheim set for my longship and it's awesome, except for the shields...
    I put on the Nilfheim shields but another set appear on my boat, a set I don't even have. I get 2 shields on each side, they are orange and black. I then fast travel anywhere and I get 3 new shields added to each side of the boat, all 3 are different. It seems to make no difference what kind of shield I choose... And I do have pics, it's just that they are 6-9MB and you got a 2MB limit here..

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @dicorn Hi there, and thank you for adding to this thread to let us know you are also experiencing this error with the ship shields. Would you be able to attach these images to a support ticket, then post the case number here please?

    Official Response
  • Grimm5ha
    1 posts

    I'm able to customize the whole ship but the shields on the sides, they stay on the default and won't take any of the custom looks. Any help?

  • afewscarsmore
    83 posts

    @grimm5ha same thing

  • afewscarsmore
    83 posts

     I have an issue when on general longship appear only black and red shield with dragon, even if in menu I choose other (raven shields, berserk shield and so on).

    Same thing on RR longship: in ship menu there is berserk shield, on RR loading screen berserk shields and in game ship and crew have black and red dragon shields.

    Also in ship menu yoms shields (black and red with wolf) are viewed like black and red dragon shields.

  • Ubi-Mark.
    Ubisoft Support Staff 1749 posts

    Hello Vikings,

    Thank you for your patience while our team was investigating this issue. I can see that this issue has been reproduced by the development team and the fix is planned in a future update 🙂 Once it's pushed live, we are going to let everyone know through the patch notes.

    If you have any additional questions, please let us know.

    Official Response
  • Olboney-
    2 posts

    Well I just changed the appearance of my drakkar Shields to Asgardian shields but it keeps showing these ugly black and orange shields instead and now when I change them they remain the same. Is it only me or happens to everyone else?


  • Karloz1995
    268 posts

    @olboney those shields looks very cheap and with no texture.. very flat and weird

  • Olboney-
    2 posts

    @karloz1995 all my shields look like these since then and now, it doesn't matter which ones I choose they are always the sameundefined

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello all!

    I've merged together several similar threads about the long ship shields displaying incorrectly into a single megathread. I apologise if any ongoing discussions have been disrupted by this. By creating a single thread, we can keep all information and updates from an investigation in one place.

    The development team are aware of an issue wherein the shield designs for the main long ship and the river raid long ship will switch with each other. They plan to fix this issue in a future update. At this moment in time, we don't yet have a definite ETA for this update. Once we have more confirmed information, we will share this within this thread and in the News & Announcements forum.

    They have also received reports that long ship shields will always be changed to the Helheim design, even if these aren't equipped on either ship. They are currently investigating this further. If you have been affected by this issue, please can you send us a video that shows the following:

    • Which shields you currently have equipped
    • That the Helheim shields are automatically equipped to your ship


    @Olboney - Could you let us know if those shields are the ones equipped on your river raid longship?

    Thanks! 😊

    Official Response
  • Youldinho
    19 posts

    @ubi-borealis Hello, was unsure if this has been addressed yet? or is it still down for a future update? thank you 🙂

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @Youldinho!

    This issue has not yet been included in an currently released update. I am happy to confirm that the development team intend to fix this issue in a future update! At this moment in time, we don't yet have a definite ETA for this update's release. Once we have more information to share, it'll be posted within this thread or within the News & Announcements forum.

    Thanks! 😊

    Official Response
  • thedevilcomes
    41 posts

    @ubi-borealis encountered this one too in my save. also i still sware i'm missing materials and such from the multiple gear resets. oh well 😞

  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there @thedevilcomes!

    Thanks for sharing your experience with us. We don't yet have an ETA for when the fix for this issue will be released. Once we have more information about the update, it will be posted within this thread.

    I'm sorry to hear you've experienced gear resets, and are missing resources from this. I would recommend checking out if there is a current megathread about the issue you're encountering (such as with the Berserker set or the Yule set). You can share your report in those threads if you haven't already. If you can't find a megathread that matches your gear reset issue, please feel free to create a new one so we can take a closer look.

    Thanks! 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 4132 posts

    Hello there,

    I apologise for the double post. During the investigation into the shield designs showing incorrectly, the development team has discovered that there could be two potential causes behind this issue. I would like to provide you all with a status update from the investigations:

    • After changing the shields on the River Raid longship, the shields on the Main longship change to match, even if a different design has been equipped.
      • Status: Pending fix
      • Comments: The development team intend to resolve this issue in a future update. We don't yet have a definite ETA for when this update will be made available. Once we have more information to share, it will be posted within this thread and in the News & Announcements forum.
    • After equipping the Helheim shields, no other shield design can be equipped.
      • Status: Under investigation (additional videos welcome)
      • Comments: The development team are investigating reports that, after equipping the Helheim shields on the Main longship, players are unable to select a different shield design. If you have been affected by this issue, please can you let us know which shields you tried to equip after the Helheim set. Additionally, please ensure that you have an up-to-date save uploaded to the cloud.


    @Abid653 - It looks like you play the game on a different account to the one you contacted us with. Can you let us know your PSN username? This will help the development team to locate your cloud save.

    Thank you 😊

    Official Response
  • FlingNerd
    1 posts

    Came back to AC:Valhalla after a break to try out the new DLC. There are tons of new bugs honestly, but one I havent seen on this forum yet is one that I have. At least after traveling to Ireland for the first time, the shields on the side of my longship AND river raid ship changed to a shield I don't even own. Its a black shield with what looks like a red tree. Changing the cosmetics of the ship does nothing. I get the same shields no matter what.

  • Garbo3
    778 posts

    @flingnerd is a bug the dev team is investigating so will be fixed in future updates,not in the early June one. We don't have an ETA yet.

Suggested Topics