Welcome to discussions

Quick Suggestions

  • Ubi-Borealis
    Ubisoft Support Staff 2895 posts

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for the longship shield designs in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with the ship shields following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • afewscarsmore
    61 posts

    @ubi-borealis after patch 1.2.2 jomsviking longship shields (black with red wolf) still appears as dragon (black with red dragon) shields (screenshots above in this thread)

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @afewscarsmore,

    Thank you for the update. I'm really sorry to hear that the shields are still displayed incorrectly for you. Can you please provide us with a few fresh screenshots showing this along with your main menu (with the number on the bottom-right corner that displays your current game version), so we can reopen this issue with the development team?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • auridulis
    39 posts

    The shields are still broken in Title Update 1.2.2. Platform: Ubisoft Connect PC.

    Here's an example of the Asgardian Set.

    undefined

    undefined

  • Ubi-Borealis
    Ubisoft Support Staff 2895 posts

    Thanks for providing us with an image, @auridulis. Would you be able to clarify the issue you're encountering with the shields some more for me? It looks like the Asgard shield designs are showing correctly in that image, if that's the scheme you have assigned. Are you referring to the blank wooden shields?

    If so, could you let me know if the jomsviking with these plain shields are community generated, or ones you have hired throughout the story (such as Birna, Finnr and Bjorn)?

    Thanks!

    Official Response
  • auridulis
    39 posts

    @ubi-borealis

    Thanks for your reply.

    Yes, I was referring to the default shield design and the other blank wooden shields. I would expect all shields to match the selected shield design.

    I do not use community-generated jomsvikings. Here's my crew:

    undefined

    undefined

  • Ubi-Borealis
    Ubisoft Support Staff 2895 posts

    Thanks for clarifying for me, @auridulis! I've passed your report along to the development team so they can take a closer look at this. Thanks for letting me know your crew as well! This will be helpful during testing.

    If we require any additional information from you, we will reach out within this thread.

    Thanks! 😊

    Official Response
  • LA_Frankie
    55 posts

    Update 1.3.0 does NOT resolve this issue.

    The shields continue to look out of place; default shields mixed in with custom shields, some shields missing entirely.

  • DESPERADOZ2010
    18 posts

    I am not sure if this is the same issue. but i have the full Jackdaw-set. and i equip it in my shipyard.. but everytime i start the game it has resetted. like i have no hull,sails,shields etc equipped other then the default ones. 😕

  • Ubi-Woofer
    Ubisoft Support Staff 801 posts

    Hey everyone,

    I'll provide a quick update on the issues we have so far had reported regarding the longship / river raid ship shield cosmetics below - please let me know if you have any questions, concerns or feedback to share! 🙂

    • After a river raid, the design of the main longship shields changes to match the design of the shields of the river raid longship
      • Status: No longer occurs as of TU 1.2.2
      • Comments: If you notice this issue reoccurring, please provide a video showing this, and we'll be happy to reopen the investigation with the developers.
    • Main longship shield design cannot be updated
      • Status: No longer occurs as of TU 1.3.0
      • Comments: If you notice this issue reoccurring, please provide a video showing this, and we'll be happy to reopen the investigation with the developers.
    • After updating the longship shield design, not all shields are updated / show the correct design
      • Status: Under Investigation
      • Comments: The developers would appreciate any additional images or video clips that demonstrate this issue. Please also make sure to have a recent cloud save available so that we can also forward this for investigation by the team.
    • Main longship and river raid longship cosmetics reset when starting a Mastery Challenge
      • Status: Under Investigation
      • Comments: The issue has been reproduced successfully, and is under investigation at present. Any additional images or videos that demonstrate the issue that could be provided would be greatly appreciated by the development team.
    • Main longship shield design are stuck with the Helheim design even if it is not equipped
      • Status: Cannot Reproduce on TU 1.3.0
      • Comments: This issue has not been reported again since its initial report several months ago, and has not been reproduced since. To reopen this investigation, we would need both a video demonstrating the issue, and for a recent cloud save game to be available for us to investigate further.


    @LA_Frankie - Hey there! Thank you for replying to this thread. I am sorry to hear that as of TU 1.3.0, you are still experiencing issues with the designs of your longships' shields - both in terms of them being missing, or inconsistent. At present, the developers believe the issues with changing the designs of the shields and the longship shields changing to the selected design of the river raid ship to be resolved as of TU 1.3.0, but are still investigating the issues you mention with the shields not all matching consistently or being reverted to the default. To help with the investigation, would you be able to provide screenshots showing the design you have selected with the shipwright, and then how your shields are appearing on your ship(s)? Thank you very much in advance! 🙂

    @DESPERADOZ2010 - Thanks for your reply! It does sound like the issue you are having may be more complex, and could possibly be linked to an ongoing issue whereby cosmetics may be reset after a Mastery Challenge has been completed. Can you please confirm for me if you have recently taken part in any Mastery Challenges, and also provide a short video clip demonstrating the issue? In the video, it would be helpful if you could show your equipped designs, save the game, quit to the menu, and then reload your save game to show that the items are no longer equipped on your ship. Thank you! 🙂

    Official Response

Suggested Topics

Community Details

124
Online
142.4k
Users
25.2k
Topics
130.5k
Posts