ubisoft discussions

Quick Suggestions

  • malageno
    3 posts

    I'm having an odd issue on PC, Windows 10. So far the game hasn't been as buggy for me except for this:

    I have 4 medallions in my inventory but can't give them to Hytham. The option is faded. I've tried multiple times. Are medallions and codex pages linked, as in, you need at least 4 medallions AND 6 codex pages before these options can be used? I only have 2 codex pages, so wondering if I need 4 + 6 to make it work.

    Also, relevant to Hytham, I can't "mark" any Order assassination targets in my menu. The default PC marker is [space bar] but it won't activate. I hear a bloopy sound effect but no marker appears in-game and the menu doesn't change the target to "unmark". I was doing the Lecestre chapter last night and wanted to kill the dude in the marketplace. Couldn't mark his location. A quick Google search indicated where he should be; for me, however, he wasn't there. I'm confused. I've built Hytham's Bureau in my settlement and got Leap of Faith from him.

  • malageno
    3 posts

    Resolved my issue. Turns out killing the first target in the marketplace happens automatically during the attack on Lescestre in the Sons of Ragner questline. The target appears in the marketplace in a panic and once you take him out, the options for delivering the medallions open up. I can also mark targets now. Odd mechanic in that it's unexplained but there we have it.

  • Yukiyoroi
    9 posts


    Yup. Same problem here.

  • ferrett20
    1 posts

    Hi I am not able to hand over the medallions ANY IDEAS

  • mrc1965
    2 posts
    having the same problem but also with museum dude. playing on PC have not had any other issues until now. kind of a game breaker.

    Me too!

  • GustavoHAndrade
    1 posts

    I cannot collect the codex. I was in one of the bureaus, the one in which we can get the gloves, but codex page was not available to collect, even with the mission activated.

  • russt691969
    2 posts

    Hytham wants 15 medallions but i only have 14. No more of the order to kill except the father but i can’t trigger Hytham meeting me outside of the longhouse for the final clue to target him. Any ideas please?

  • Madeezy
    67 posts

    @russt691969 Same exact situation here. Done everything and he wants 15 medallions and I have 14. He's not appearing outside of Longhouse for me to trigger next quest. No idea what to do.

  • SwordFella45
    1 posts

    I think there is a bug with page 4 of magas codex at the wincester bureau. I have all pages but 4 and I thought maybe I missed it so I went back and on the table is the letter but it not letting me pick it up

  • Dejv.vM
    1 posts

    Same here, I went back to every institute to ensure I picked everything, but the codex page 4 is not registered in my inventory. This is a real bummer, because I really want to finish this quest line.

  • Skaw-X
    4 posts

    @swordfella45 i have the same issue but with the third codex

  • JC-the-Apostate
    24 posts

    On PC, collected all 6 codices, but one seems to be missing. Both quest status and inventory only show 5/6 - missing #2 (Jorvik). I have all 6 quest items (Hidden Ones regalia and the dagger) I've gone back through the play, all the doors are open still, chests are emptied, and no codex to be found.



  • steelvainz
    6 posts

    I have all 6 codex pages in my inventory still after talking to hytham. No option to hand them in anymore and no reward at reda. Please help.

  • x.Mace.X
    1 posts

    Same bug with Codex 4 ... 😞 also some treasure hoards are bugged and and and ;/

  • Landmine70
    2 posts

    @zydrate_addict same problem here with Xbox download ultimate edition.

  • dfbake
    1 posts

    I am at level 194 playing for hours upon hours and still not able to give Hythan medallions or codex pages. When I talk to him the symbol with yellow tree says “ (give order Medallions) (9) the white symbol says (give 6 codex pages).
    I have killed 12 members of the order and 6 Zealots.
    What should i do?

  • Janer64
    19 posts

    @dfbake I have the same problem but I am a much lower level, I have 4 medallions and 6 codex pages, they're simply greyed out.

  • Allenkid
    1 posts

    @russt691969 I have the same issue and have no clue what to do.

  • fobeyer
    2 posts

    I’m having the same issue. Quest doesn’t update, Hytham still has the marker, and dialogue option to turn in is gone. No option to tell to Reda.

  • steelvainz
    6 posts

    @fobeyer I went back and finished asgard. When I did that the mission was available to continue for codex pages.

Suggested Topics