Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Garbo3
    600 posts

    @azullfr Ah so we still dominate the earth πŸ˜†
    .Glad to know am not the only dinosaur here. I will follow your instructions when I launch the game later . Thank you so much for votre aide πŸ™‚ Have a lovely day !!

  • ChimereOrphee94
    4 posts

    Bonjour, voici les preuves.

    Chez Reda (le cheval je l'ai bien acheter avec des opal)



    Mon inventaire (casque)


    et dans le store

  • Garbo3
    600 posts

    Well .I couldn't manage to take screenshots in inventory as take me to stats and couldn't at Reda shop either 😞

  • azullFR
    495 posts

    @garbo3
    Hi !
    I've just found this, it will be easier as there are pictures and more explanations πŸ™‚
    https://thedroidguy.com/screenshot-on-ps4-2021-1146271

    Have a nice day πŸ™‚

  • majora404
    4 posts

    @isuwhat BRO HOLY [censored] I HAVE THE SAME PROBLEM!!! (only im on XBOX)

  • Garbo3
    600 posts

    @azullfr oh. I see. Was trying to use photo mode . I'm idiot lol.
    Thank you so much. Will do tomorrow if they still need pics .But there's thousands with this bug if not all of us πŸ™„.
    Enjoy your evening 😊

  • prokeon
    9 posts

    I'm getting this same issue with Reda this week too with the Berserker helm. I don't own it yet it is showing as ticked in the Reda store yet isn't in my helix store (on PS5). 🐻

  • victoruchiha82
    23 posts

    @ubi-borealis thanks. All we wantend. But now that I got you. What’s up with the berseker helmet in the shop. It states owned. But I didn’t buy it. And on YouTube here where people who owned it but it got deleted from there inventory.

  • Ubi-Borealis
    Ubisoft Support Staff 1911 posts

    Hello all!

    Thank you for continuing to update this thread and to share your reports about the Berserker Helm showing as owned. We appreciate you taking the time to share your experiences, and to send images as well!

    The development team are aware of this issue are investigating this further. I'm happy to announce that they're planning to fix this in a future update. I'd recommend keeping an eye out in the News & Announcements forum for more information.

    @victoruchiha82 - Your post has been moved over to this thread, so you can keep up with the new information and updates here.

    Thanks πŸ™‚

    Official Response
  • isuwhat
    Original poster 176 posts

    @ubi-borealis thanks for the update. If this is not fixed by next weeks Reda weekly reset, can you please advise or confirm this helm will be back in Reda's shop ASAP when the issue is fixed?

    i think its clear many of us would like to own this item πŸ™‚

  • Garbo3
    600 posts

    FINALLY !! Took me ages but managed .undefined

    undefined

  • DragonHale1
    8 posts

    Hello
    I am having the same issue (I won't post screenshots because they are exactly the same as all the screenshots in this thread: helm shows as owned in Reda's shop, but my inventory does not have it. And obviously, since it shows as owned, I cannot buy it either).
    I am playing in PC and I pre-ordered the game. I completed the Way of the Berserker ages ago (and I am now 90 hours into the game) and never did I get any items that I could recall upon competition of the mission. I only got the raider Bjorn to take with me on the ship.

    I pre-order the game for PC but I cannot remember if I bought the base game or a better version like deluxe or something of the sort.
    Where can I check which game I got? Was I supposed to get the gear from the start and didn't realize it?

  • Murluke
    1 posts

    I've got the same problem (PC). Not able to buy this gear at Reda's shop cause it says I already own it.

  • kingoshus
    15 posts

    I am also having this issue, I hope they ensure Reda is stocking it next week so we can still get it after the patch

  • Foepske
    2 posts

    @ubi-borealis Yes, how can we get the item before reda's weekly update?

  • sh3p3003
    2 posts

    Same here got ps4 gold edition but playing on ps5 also is way of the completionist still bugged I did every area and it won't pop 😭😭

  • The9thSin
    3 posts

    @isuwhat same thing for me. I was told Ubisoft knows about this issue and is trying to fix it. I don't know if they're going to put the helm in the next weekly selection or something since a lot of people were not able to get it this week due to the glitch. They definitely should.

  • ubi-smash
    Ubisoft Support Staff 360 posts

    Hey folks, this issue should now be resolved after updating to Patch 1.2.1, but please let us know if you have any further issues moving forward, and thank you for bearing with us during this time.

    Official Response
  • KopfSmertZz
    24 posts

    @ubi-smash : What do you mean with solved? Should everyone have this helmet now as shown in Reda's shop? Because it is not in Reda's shop anymore I believe and I do not have the Berserker helmet in my inventory (AC Valhalla gold edition + Way of the Berserker)

  • Garbo3
    600 posts

    @kopfsmertzz it was available the 27th until 3pm. Then Redas shop added new items. I am sorry that you missed it.

Suggested Topics

Community Details

34
Online
129.0k
Users
22.2k
Topics
115.1k
Posts