Welcome to discussions

Quick Suggestions

  • majora404
    4 posts

    @isuwhat BRO HOLY [censored] I HAVE THE SAME PROBLEM!!! (only im on XBOX)

  • Garbo3
    778 posts

    @azullfr oh. I see. Was trying to use photo mode . I'm idiot lol.
    Thank you so much. Will do tomorrow if they still need pics .But there's thousands with this bug if not all of us 🙄.
    Enjoy your evening 😊

  • prokeon
    9 posts

    I'm getting this same issue with Reda this week too with the Berserker helm. I don't own it yet it is showing as ticked in the Reda store yet isn't in my helix store (on PS5). 🐻

  • victoruchiha82
    229 posts

    @ubi-borealis thanks. All we wantend. But now that I got you. What’s up with the berseker helmet in the shop. It states owned. But I didn’t buy it. And on YouTube here where people who owned it but it got deleted from there inventory.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts

    Hello all!

    Thank you for continuing to update this thread and to share your reports about the Berserker Helm showing as owned. We appreciate you taking the time to share your experiences, and to send images as well!

    The development team are aware of this issue are investigating this further. I'm happy to announce that they're planning to fix this in a future update. I'd recommend keeping an eye out in the News & Announcements forum for more information.

    @victoruchiha82 - Your post has been moved over to this thread, so you can keep up with the new information and updates here.

    Thanks 🙂

    Official Response
  • isuwhat
    Original poster 190 posts

    @ubi-borealis thanks for the update. If this is not fixed by next weeks Reda weekly reset, can you please advise or confirm this helm will be back in Reda's shop ASAP when the issue is fixed?

    i think its clear many of us would like to own this item 🙂

  • Garbo3
    778 posts

    FINALLY !! Took me ages but managed .undefined

    undefined

  • DragonHale1
    8 posts

    Hello
    I am having the same issue (I won't post screenshots because they are exactly the same as all the screenshots in this thread: helm shows as owned in Reda's shop, but my inventory does not have it. And obviously, since it shows as owned, I cannot buy it either).
    I am playing in PC and I pre-ordered the game. I completed the Way of the Berserker ages ago (and I am now 90 hours into the game) and never did I get any items that I could recall upon competition of the mission. I only got the raider Bjorn to take with me on the ship.

    I pre-order the game for PC but I cannot remember if I bought the base game or a better version like deluxe or something of the sort.
    Where can I check which game I got? Was I supposed to get the gear from the start and didn't realize it?

  • Murluke
    1 posts

    I've got the same problem (PC). Not able to buy this gear at Reda's shop cause it says I already own it.

  • kingoshus
    22 posts

    I am also having this issue, I hope they ensure Reda is stocking it next week so we can still get it after the patch

  • Foepske
    2 posts

    @ubi-borealis Yes, how can we get the item before reda's weekly update?

  • sh3p3003
    2 posts

    Same here got ps4 gold edition but playing on ps5 also is way of the completionist still bugged I did every area and it won't pop 😭😭

  • The9thSin
    4 posts

    @isuwhat same thing for me. I was told Ubisoft knows about this issue and is trying to fix it. I don't know if they're going to put the helm in the next weekly selection or something since a lot of people were not able to get it this week due to the glitch. They definitely should.

  • ubi-smash
    Ubisoft Support Staff 794 posts

    Hey folks, this issue should now be resolved after updating to Patch 1.2.1, but please let us know if you have any further issues moving forward, and thank you for bearing with us during this time.

    Official Response
  • KopfSmertZz
    60 posts

    @ubi-smash : What do you mean with solved? Should everyone have this helmet now as shown in Reda's shop? Because it is not in Reda's shop anymore I believe and I do not have the Berserker helmet in my inventory (AC Valhalla gold edition + Way of the Berserker)

  • Garbo3
    778 posts

    @kopfsmertzz it was available the 27th until 3pm. Then Redas shop added new items. I am sorry that you missed it.

  • KopfSmertZz
    60 posts

    @garbo3 : No problem. Reda showed I already owned it, but it was and is not in my inventory, that is why I askes because I'm not sure what update 1.2.1 should have fixed; ownership of the helmet? Or were we not supposed to own it?

  • Garbo3
    778 posts

    @kopfsmertzz just gave us a little gap of time as it was available to buy after update but sadly only until 3pm. Didnt show as owned anymore so you could buy it it you wanted but only until Reda changed his weekly stuff( every Tuesday 3pm.)

  • isuwhat
    Original poster 190 posts

    @ubi-smash hi, can you please confirm if this item will be back in Reda's shop very soon as the window to purchase it was a matter of hours and id presume many many people would have missed it? thanks

  • JamesLogan491
    91 posts

    @ubi-smash Yes, but now there is another problem with Reda's shop, it doesn't show that you already own an item, therefore allowing you to buy something you already own a second time.
    Yesterday I saw the daily item was the Bloody Eagle Totem and it was available for me to purchase even though I have it on the shop's owned tab, I have it in-game and even have it currently as a decoration on Ravensthorpe.
    I hope it will be looked into.

Suggested Topics

Community Details

132
Online
193.3k
Users
32.6k
Topics
163.2k
Posts