Welcome to discussions

Quick Suggestions

  • Toeryn
    9 posts

    @saoakden If you're missing only "worthy", try what I did, equip the hammer, on mine this caused it to unlock after migrating

    @AscendantSpider - I tried many different places to unlock "Rampage" trophy, only church/resource raids worked for me, if you can get the "Raid completed" graphic to show up, it counts. Raids of small bandit/military camps without settlement resources don't trigger it (in my experience)

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello all!

    I apologise for the double post. Thank you for continuing to share your reports regarding your missing trophies with us. I'd like to reach out to you all with an update.

    The development team has began releasing improvements for unlocking trophies with TU 1.3.1, wherein the following fix was deployed:

    Mastery Challenge achievements and trophies didn't transfer between platforms.  


    I'd like to assure you all that the development team is actively investigating this issue at large and will be continuing to bring improvements in future updates. Following TU 1.3.1, the development team have requested that we open up a new Megathread to continue tracking reports of trophies / achievements not unlocking on all platforms. You can find this new Megathread here.

    If some of your trophies still have not unlocked, despite meeting the requirements, please can you share your report within the linked Megathread? This will help us to keep all reports and information in a single place.

    As we have opened up this new thread to collect reports, I will now be locking this thread. Please can you provide full up-to-date reports following the release of TU 1.3.1 in the Megathread we have linked above.

    Thanks! 😊

    Official Response
  • AscendantSpider
    5 posts

    @toeryn Maybe it's because I stealthed the entire thing, but I did complete Evesham Abbey, which I assume was a small church raid, then tooted my horn for the raid. So either that wasn't a church, my stealth killing ruined it, or Ubi not doing something right.
    If leveling my settlement doesn't pop the other missing one, then off my console this game goes.

  • UbiKobold
    Ubisoft Support Staff 664 posts

    @ascendantspider Hey! Could you list the six trophies that you are missing from PS5 but have earned on PS4? I would be happy to forward up your information to be included with this investigation!

    Official Response
  • Garbo3
    778 posts

    Is this issue still going on then after last update? Been up many nights hunting for a PS5 and finally will have it on wednesday!!
    So am all excited about the DLC plus the PS5 but unsure if I should wait and play wrath of the druids on ps4 until this issue is finally sorted out.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hey there @Garbo3!

    The investigation into some trophies not retroactively unlocking upon migrating form PS4 to PS5 has been reopened following reports that the issue persisted after TU 1.2.1. The development team has been investigating this issue further. We don't yet have any new information to share from the development team, and wee wouldn't be able to speculate on an ETA for a fix.

    It's your choice whether you wait for this issue to be fully resolved before migrating to the PS5, as we currently would be unable to guarantee that all of your trophies would be correctly unlocked. I would like to assure you that if you do choose to migrate to PS5 on Wednesday and some of your trophies don't unlock, the development team are looking into resolving this issue retroactively for players.

    If you choose to migrate to PS5 to play Wrath of the Druids and encounter any trouble, please don't hesitate to reach out so we can take a closer look 🙂

    Official Response
  • Garbo3
    778 posts

    @ubi-borealis I will wait,still worrying they don't cancel my order as seen on twitter,hopefully not. But I will wait anyway . As always thank you so much for your prompt reply 😊

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    No worries, @Garbo3! Best of luck in getting your PS5! 😄

    Official Response
  • Garbo3
    778 posts

    @ubi-borealis just got it!!!
    Thanks 😊

  • NLDragon
    5 posts

    @ubi-borealis Maybe this will help in the investigation.
    I just finished the first quest of the dlc and suddenly all but the trophies listed below are now unlocked. So you were right to ask to do a quest but apparently a 'quest' from reda doesn't count?

    Viking Legend (Obviously)
    Rampage
    Skadi's Hobby
    Equine Attack
    Silent Viking
    Row Rage
    A Picture of Grace
    Builder
    Home Sweet Home
    Not the Norse You're Looking For
    Face My Might!
    Ultimate Refinement
    Flying Eivor
    Orlog Champion
    Good Catch!
    Caladfwlch
    Worthy

    Hope it helps.
    If you or the devs have any questions let me know.

    Thanks.

  • fishybrains
    14 posts

    @ubi-borealis Good news, I just completed the Irish outpost and my last two trophies unlocked, Completionist All the way! and Viking Legend

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there @NLDragon & @fishybrains!

    Thanks for providing me with an update following the release of "Wrath of the Druids!" I'm glad to hear that a number of trophies have unlocked for you after completing the first quest!

    I've passed this information along to the development team.

    If anyone else is still has locked trophies following TU 1.2.1, please could you try completing the first quest of "Wrath of the Druids" if possible? If any more trophies unlock for you, please let us know so we can share this with the development team.

    I would also like to assure players that the development team are still investigating this issue further, so if you're unable to access the expansion, please don't be concerned.

    Thanks! 😊

    Official Response
  • bhavz69
    1 posts

    Hello,

    I played Assassins Creed Valhalla and gained a platinum trophy on PS4. I then upgraded to PS5 version and multiple trophies popped with many still missing. In a recent patch update it said any missing trophies would unlock and therefore I could recieve my platinum trophy on PS5 without having to replay the game. Since the patch only three extra trophies unlocked and my platinum and other trophies still won't pop. One of the trophies is to reach settlement level 6, but ive already completed the game and reached that level. Another trophy is to beat all the orlog players, I've already beat them all three times and they all have a completed tick on them yet the trophy doesn't pop. Is there a way this can be fixed on my game? Without having to replay the game?

    Kind Regards

  • Ubi-Mark.
    Ubisoft Support Staff 1324 posts

    Hello @bhavz69,

    Sorry to hear that your trophies are being locked.

    Can you please clarify which trophies are currently missing and provide us with a few screenshots, so we can investigate it further for you?

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • daz-lufc
    16 posts

    Done what’s suggested above and no trigger for me yet 😞

    will keep playing

  • Ripgrind3r
    2 posts

    I am missing three trophies. Caladfwlch, Row Rage, and Skadi's Hobby.

    With Row Rage hitting three boats doesn't work. I wasn't in a good area. It seems have to possibly get all five again.
    Skadi's Hobby doing short slides does not work either. I will attempt these two again at a later time. Not in a rush.

    Doing events, Reda quests, and the last hunting quest with Petra did not unlock any trophies for me. It was a few minutes after doing the quest with Petra that I had asked her to bed. After I had control of my character again all the trophies unlocked except for the three mentioned.

  • Garbo3
    778 posts

    @ripgrind3r for the Row rage go to Cent Coast,grab 5 little boats and put them in a row one after the other separated about 10 meters each, set the game on easy mode otherwise they won't break. It takes 10 seconds once you have aligned the 5 boats in a straight line 😆.

  • Ripgrind3r
    2 posts

    Small update to Caladfwlch. I did unlock it last night after equipping the Excalibur by accident.






  • will7476413
    1 posts

    Hi. A number of trophies have not popped retroactively - including the settlement levels 3 and 6 trophy, and beat all Orlog players. A number of others did not pop (same as below) but they can be gained reasonably quickly in game and are popping as a I play - for example, swim 6kms with a horse! which popped as soon as I took a horse in the water. Please could you fix these issues properly this time as it's very annoying.

  • Docholiday421
    18 posts

    @ubi-mark I did Skadis Hobby to see if it would trigger the others for my platinum and nothing happened except for that one trophy. I am now at 79% even though I 100% the game on PS4

  • Afracious
    1 posts

    I have the platinum on the PS4 version and three trophies won't unlock on the PS5 version: Builder, Home Sweet Home, and Orlog Champion. I upgraded the river raid building and won some Orlog games but they still won't unlock. It seems there is no way to unlock these trophies apart from playing through the whole game again. Are there any plans to fix this issue in a future patch?

Suggested Topics

Community Details

158
Online
193.7k
Users
32.7k
Topics
163.7k
Posts