Welcome to discussions

Quick Suggestions

  • nikinko17
    9 posts


    i want play only main mission
    i cant finish Grantebridgescire
    settlement level 6 still not works i finish vinland asgard jotunheim
    on these Grante.
    i need only pass this level 6 and 10 contracts

    i want pledge Oxenefordscire or other regions left on map but when i go to aliance map it not work

    i also want go there but not work too

    • Sciropescire = Level 130
    • Cent = Level 130
    • Lincolnscire = Level 160
    • Essexe = Level 160
    • Suthsexe = Level 160
    • Eurviscire = Level 190
    • Jorvik = Level 190
    • Glowecestrescire = Level 220
    • Snotinghamscire = Level 250
    • Wincestre = Level 250
    • Hamtunscire 

    pls help

  • ubimicalz
    14 posts

    @cptgug I have no idea how to fix it and I’m stuck

  • ubimicalz
    14 posts

    @ber0nius same bro

  • ubimicalz
    14 posts

    I have completed the grantebridgescire saga but it says we are not allied and now after completing the Jorvik saga I cannot do anything

  • ubimicalz
    14 posts

    I have completed the grantebridgescire saga but it says we are not allied and I cannot progress past Jorvik

  • CptGug
    2 posts

    @fabdlx I think it actually hinders progress. I think that it should give access to the story line in Sciropescire and maybe Cent, since they have a suggested power of 130. Right now i have the possibility of choosing one with a suggested power of 190 or 230 which makes no sense when there are areas with a lower suggested power.

  • ubimicalz
    14 posts

    This glitch is stopping me from doing any more alliances. Has anyone else got this

  • fabdlx
    3 posts

    Well, that sucks then 😕

    Guess i'll stop playing for now until there's any news about this. But i fear the "solution" will be to start over and hope it won't happen again...

  • ubimicalz
    14 posts

    It says I am not allied with grantebridgescire and it now won’t let me progress any further in the story

  • MrGonnY
    4 posts

    I finished all the soma quest but i cant finish the zone like every other ones. I dont have the quest where you have to go back to the village speak to randvi and then it finish the zone Grantebridgescire.
    So i am stuck and i cant progress in the game...

  • MrGonnY
    4 posts

    @ubimicalz Same for me

  • Lil_Weenie
    3 posts

    Hello, I recently encountered a game breaking bug that has halted my entire playthrough. After completing the "Island of Eels" quest, you are supposed to receive the "Report on Grantebridgescire" quest so that you can complete the pledge to Grantebridgescire and continue on with the story. However, after completing the "Island of Eels" quest I was not given the quest to complete the pledge and can no longer progress through the story. It also automatically marks the completed "Island of Eels" quest as tracked whenever I first start up the game so, it's almost as if some part of the game does not recognize that I've completed the quest.undefined

  • Centm
    2 posts

    After completing the Island of Eels Reporting Grantebridgescire does not get triggered or added to quest. Tried reloading and speaking with Randvi but no luck.

    Completed Grantebridgescire quest line but it is not marked as complete in map. I can pledge to Londen.

    Playing on Ps4

  • Ubi-Spud
    Ubisoft Support Staff 702 posts

    Hey there, I'm sorry to hear this. What happens if you fast travel out/in to the settlement and try to turn it in again? Does reloading a previous save help at all?

    Official Response
  • fabdlx
    3 posts

    Just leaving a link to another thread with a couple of reportings of this issue: https://discussions.ubisoft.com/topic/80460/grantebridgescire-wont-show-as-an-ally-on-the-alliance-map?lang=en-US

    Teleporting out/in or loading another save doesn't help. Also kept playing for a while and came back several times to check the map - no changes.

  • WhiteCandy90
    3 posts

    i have same probloem. https://discussions.ubisoft.com/topic/79298/i-can-t-complete-as-island-of-eels-quest
    so i stop playing game until fixed.

  • brownbaby7
    6 posts

    I plegde'd to grantebridgescire and no quests show up once accepting... i have already done the storyline helping soma retake grantebridge. how do i fix this bug as i am now stuck in the story (this was done when i was power level 20 i am now power level 140 so i dont really want to go back to past saves). could i please have some help recifying this problem.

    cheers

  • rectiphye
    9 posts

    @fabdlx yeh I have the same thing bro. like the quest report back doesnt show on my completed or to do. and I cant pick it up anywhere. [censored]

  • jjmugs1
    11 posts

    So I completed the last Soma quest where you go back to her camp after you take Grantebridgescire but after that quest “An island of eels” there’s no option to return Randvi to update her and complete the pledge. This happened a few days ago, I didn’t realize it was a glitch so I went on to pledge every other area I could. After doing all the ones available, I could only pledge back to Grantebridgescire. Still no quests or objectives. As of now I’m stuck pledged to Grantebridgescire because I can’t switch to any of the ones already completed. So I’ve spent 40h already, even got excalibur, thors armor and taken out half the order of the ancients. I really don’t want to restart I hope they can somehow fix this. Very game breaking but I don’t know if it’s a widespread issue. People are having all around quest issues so maybe a way to reset quests idk

  • rectiphye
    9 posts

    @notpuppodogger
    I have lundun to do, but I cant complete grantebridge, gamebreaking bug and what no word from ubisoft. typical.

Suggested Topics

Community Details

119
Online
194.1k
Users
32.8k
Topics
164.1k
Posts