Welcome to discussions

Quick Suggestions

  • 4 Likes/367 Replies/12759 Views
    2 posts

    Edit: if you run into this - trap the body then let it explode. save your game and reopen the game. The enemy respawned for me 🙂

  • fastica
    5 posts

    @schmutzlee Wait, so yo have the 17 wealth completed in East Anglia?

  • JCar4327
    658 posts

    @pjc1506 I'm on Xbox and as soon as I fast traveled to East Anglia it showed up on the map that there was a wealth available in Dunwic..

  • m1au
    58 posts

    yeah you can get to 17/17 again in East Anglia. One guy in Dunwic has a respawned wealth (ingot)

  • fastica
    5 posts
    yeah you can get to 17/17 again in East Anglia. One guy in Dunwic has a respawned wealth (ingot)

    Wow! You're totally right! I just farmed the ingot and got another wealth. It activated when I was close to Dunwic.

  • JCar4327
    658 posts

    @nuka-sk00ma That worked for me as well. Thanks.

  • perkri2000
    1 posts
    hi i'm not getting any more on the lost cauldron i get stuck in the magic cabin.
    I come in but then bugger so I am stuck inside the cabin and in order to get out I have to wake up.
    when are you going to fix it ????

  • TaYeuleCaliss1
    10 posts

    @nuka-sk00ma That worked for me as well thanks a lot

  • Merlin2381
    2 posts

    I just updated the newest patch 1.0.4 and now as soon as I get into game and do one thing (ie) doing a contract, collecting opal, completing mystery. The game will all of a sudden not allow me to fast travel or even manually save the game. I didn't realize it wasn't saving until after I completed a BUNCH of things including a main mission. Ended up dying after that and the auto save sent me all the way back to when I loaded the game in the most current session and all the stuff I had accomplished was reset. Also at one point I had went to the map and when I came back my character was invisible and I was unable to see him/her

  • FR2k707
    13 posts

    @thisan48 That whealth has appeared for me to. I was 100% clear with Vinland before patch. I just went there and noticed the dead enemy you talking about. I traveled back to England and back to Vinland again. Now he acutally was alive! I killed him... But no wealth. Killed him a second time and got the whealth!

  • TaYeuleCaliss1
    10 posts

    I made a video that shows the method found by @Nuka-SK00MA

  • spiriticon
    5 posts


    Magic. This fix worked for me on Xbox One X.

  • omnistrife99
    7 posts

    Update on the Vinland new wealth enemy at Hvallgrof Outpost, if you’ve already killed and looted him you can use explosive corpse, carry him just south east outside the camp and throw him near the 2 enemies that spawn there. He’ll explode when they run over to you, save and then reload that save, he’ll be alive and killable/lootable again! Suggest doing it on an alternative save file so you can go back to the original if it goes wrong, but it definitely just worked for me.

  • BitterPasta
    3 posts

    @omnistrife99 Just tested and can confirm that it works. Let's hope it'll stay collected.

  • xPoppu
    12 posts

    @tayeulecaliss1 Awesome, it worked. Finally got my achievement. THANKS GUYS!!!

  • TheHound71
    6 posts

    In vinland I had 100% completed it minus the legendary animal fight (which I opted to not fight due to the known longhouse bug). Upon return a new treasure was placed on a previously defeated enemy that cannot be picked up. This is potentially "completionist achievement ruining", which is especially upsetting as I've been babysitting this game every step of the way otherwise to make sure things I pick up actually register properly. And i know for a FACT that wealth was completed in Vinland before I initially departed and it only came back after the newest patch. I'm terrified of what new bugs wait for me

  • LazyLaziel
    2 posts


    This trick worked like a charm!

    And as m1au mentioned, the East Anglia Wealth is on Dunwic. Just got both of them and the achievement popped.

    Beautiful work!

  • Alfahunter24
    2 posts

    In Vinland I picked all the wealth but one is not counted and it is still shown on the map and in game it appears to be attached to an enemy that you are not able to loot

  • Grymmdjarr26
    4 posts
    This post is deleted!
  • Jon_ofDad
    9 posts

    @schmutzlee I too have just encountered this, have you raised a ticket?

Suggested Topics