Welcome to discussions

Quick Suggestions

  • Georgerik
    6 posts

    @casual_death There is a workaround for the Vinland wealth issue. I am also stuck with Reda, but it should be fixed in next patch as it is listed in the main topic.

  • Bing0K1ng
    18 posts

    @leoraptor1979 I have the exact same problem. No way to reach 100% in that area now.

  • phoenixash2001
    10 posts


    * Go to Vinland.
    * Make a manual save
    * Carry the body with the wealth out of the camp area (so you are not in the red zone).
    * Plant a trap on the body.
    * The body now needs to explode. You can do this by either:

    _ Finding a patrol and letting them explode it.
    _ Keep heavy attacking the body until it explodes.

    When the body explodes:

    * make manual save!
    * reload that save

    * go back to the camp....and the enemy should, if you did the above correctly, have respawned.

    I just did it...it worked for my friend and now for me.

    Good luck

  • phoenixash2001
    10 posts

    After patch 1.04 you probably miss two wealth points.

    1 in East Anglia and 1 in Vinland.

    If you have completed the map and killed the enemy you can't collect the new weather dot there.

    What you can do:

    1 Go to Vinland.
    2 Make a manual save (just in case)
    3 Carry the body with the wealth out of the camp and red alert zone.
    4 Place a trap on the body....and explode it

    Either leave it in the path of a patrol
    Keep heavy attacking it until it explodes

    5 After it explodes make a manual save.
    6 Reload that manual save

    7 Go back to the camp and the enemy should have respawned.

    This worked for me. Courtesy of a friend of mine who figured this out! Brilliant.

    I hope this works for you too.

    Good luck.

  • XboX.FPF
    22 posts

    I can still not collect the wealth of the dead guy...

  • fastica
    5 posts
    Same here but I already finished everything in east Anglia and now from nowhere I’m 16 out of 17 wealth not cool at all

    Check the Dunwic fort.

  • bomberelli56
    2 posts


    I report a bug occured in Vinland; before patch 1.0.4, I had completed all wealth locations in Vinland. After that patch another wealth appeared, though it’s on a dead body and I can’t get it. Fast traveling and getting killed won’t respawn it, it stays dead, and I can’t complete this last location.

    3 posts

    Xbox one X

    Since 1.04 patch, two new wealth items have appeared. I only had one cairn left prior to the patch. I completed it and no achievement.

    Now I noticed a new wealth item in East Anglia, which I collected, but is one more than showing on all guides and another in Vinland (taking Vinland total to 5, was previously 4), however this is unlootable as it appears on a corpse in a camp...

  • kale3l
    18 posts

    I'm on pc and i had the same issue
    I had to verify my files and after that the dead was not dead anymore 😊

    but the problem was after that my gear was dowgraded

  • Petteflet88
    346 posts

    Here we go again, another bug. 1 wealth in vinland is a dead Guy who is already dead. Does not respawn so it is not alble to be taken.

  • Ubi-Swaggins
    Community Manager 421 posts

    Thanks for sharing the workaround for this.

    I have raised this to the team for further investigation.

    Apologies for any inconvenience caused.

    Official Response
  • Ubi-Swaggins
    Community Manager 421 posts

    @bomberelli56 I am sorry to hear that, can you confirm if you are able to trap the body? If so can you do that, get it to explode and then fast travel away and return? Players have reported that this can fix this issue.

    Official Response
  • LeoRaptor1979
    99 posts

    @bing0k1ng i was at 100% before the patch but now I'm not. I hate that they did this. So I am not the only one this happened to. So they added another wealth but it is bugged if you completed the area.

    I am close to being done with this game because of all the issues.

  • bomberelli56
    2 posts

    @ubi-swaggins it worked! Thank you very much.

  • Ubi-Swaggins
    Community Manager 421 posts

    @bomberelli56 Fantastic, thank you for confirming it worked for you!

    The issue itself has been raised to the team for investigation, but it is good to know that the workaround has solved for you 🙂

    Official Response
  • dannyrhinos89
    6 posts

    So I’m extremely annoyed, I’ve put 70 hours into this so far and I’m the guy who will be going for a platinum trophy.....or so I thought. Basically before the patch I’d completed 100% (wealth, artefacts, mysteries) on,

    • Eurvicscire
    • Ledecestrescire
    • Oxenefordscire
    • Grantebridgescire
    • East Anglia
    • Cent
    • London

    now I’ve just noticed this morning when I was scanning the map that east Anglia and cent is suddenly saying I’ve not collected all the wealth (the mysteries and artefacts are still at 100%)

    Thing is there’s literally nothing left for me to collect in these areas as I’ve already got it all. I’m hoping it’s just a visual glitch and not bugged out completely as that means I won’t be able to get the 100% completion trophy,

    anyone else experiencing the same issue? Or know how to at least fix it back to 100%.

  • SofaJockey
    307 posts

    I'm sharing this in a place people are most likely to see it.

    Patch 1.0.4 caused two wealth items (ingots) to be un-credited from your wealth checklist (in East Anglia and Vinland)

    Credit goes to those who pointed out that you could revisit Dunwic tower to get the first ingot back. It's here, just go and kill the elite soldier to get it:


    Re-obtaining the Vinland ingot is seemingly impossible because the elite with the ingot is dead (assuming you did it already), but no, there's a cunning workaround.

    Credit to @phoenixash2001 for setting out the process for Vinland (in brief). Sadly I was too dim to figure it out just from that, but 'Saint Nick' on YouTube had posted a version. https://discussions.ubisoft.com/topic/84570/patch-1-0-4-discussion-drops-nov-26/192

    So here in detail: In Vinland, head back to Hvallgrof Outpost. Do a hard save before you reach the outpost in case something goes wrong.
    You'll need to find the dead body of the elite who has the ingot (who hasn't respawned).


    Use your raven to spot him. You may have to carry a few bodies out of the cave (if they were killed in there) to select the right one.


    Carry him out of the gates (out of the 'you can't save' area) and lay him down, setting the 'exploding body trap' on him.

    Then attract some other enemies over to explode the body (or I understand you can just whack the body with a heavy attack).

    Then once everyone is dead & exploded, make another hard save.

    Re-load the hard save you just made. Because you just exploded the body, that elite respawns when you reload, so go and kill him (again).


    And there you have it, the two carelessly lost wealth items are back in your wealth log.

    Assuming you have dodged various other event bugs, the completionist trophy is back on the menu.

  • GILMoRe-UK
    14 posts

    Not sure if I'm missing something here. I killed the elite and when I went back to collect the ingot it was not there even though it now appears on the map. I re-checked the underground and those items had already been collected from a previous visit. This happened when I arrived at Dulwhich as part of the main mission arc.

  • Mongolkhan77
    4 posts

    I completed all territories in Norway and England. But I can’t get one last wealth in Vinland cause the person who has the wealth is dead and I can’t collect it. I completed all wealth and mysteries in Vinland before but after patch 1.0.4 it seems some it reset some wealth in some territories. Please help because this is the last thing I need to do to get the “Completionist All the Way!” achievement.
    I play on Xbox One X.

  • Mongolkhan77
    4 posts

    I got a same issue with in east anglia. But one wealth popped up when I purchased the season pass and Beowulf side as well. Then I just went over to that one last wealth and picked it up.

Suggested Topics

Community Details