Welcome to discussions

Quick Suggestions

  • Wojdan025
    2 posts

    Hi,

    Before 1.0.4 update, i have all the wealth in the East of England (including Thor's helmet), but after the update one wealth was gone.

    undefined

    undefined

  • MythraNova
    4 posts

    @wojdan025 I thought I had the same problem but no, they just added a new wealth in Dunwic, southeast of east anglia.
    In your second picture, just below your cursor in that tiny island.

  • Wojdan025
    2 posts

    @mythranova
    Wealth was there, thank you.

  • barbaro_d_urso
    2 posts

    I have the same problem. In Vinlandia there's this dead enemy with the golden point that doesn't release the wealth.


  • SergiuH90
    2 posts

    In Vinland Outpost i killed the man carrying the wealth and looted him with the autoloot skill but the wealth marker does not dissappear and i cant complete 100% vinland.Besides ,it shows one more wealth in east anglia that is not supposed to be there

  • Tecnomax84
    1 posts

    Ho lo stesso problema su Ps4

  • Casual_death
    1 posts

    Hi guys so I still can't interact with Reda after the update and that's laughable, coming to wealth collection I completed all the territories across all the maps except for Vinland cause a npc has wealth on him and after killing him I can't collect that loot as it presents so option for it and also I tired dying and respawning so that the Npc could comeback to life but he still remains dead and with no loot option what I'm I supposed to do .....?! I need this sorted to complete the achievement, after putting in 190hrs in this game it's [censored] me off that I can't finish it for this small reason (PS4)

  • Jon_ofDad
    8 posts

    @munkytech I have found a fix for this, I saw it on another post maybe reddit.

    If you lay a trap on the guy with the wealth and get another guard (or animal I suppose) to walk over it the body disappears. Then fast travel away and cine back the wealth guy should have respawned. 😊

  • pokeriks18
    4 posts

    Same here but I already finished everything in east Anglia and now from nowhere I’m 16 out of 17 wealth not cool at all

  • LeoRaptor1979
    98 posts

    I have already completed Vineland. I heard they added a new wealth there after patch 1.0.4. When I try to collect it the guy is dead. Anyone else notice this? How can you get it if the guy is dead?

  • Georgerik
    6 posts

    @jonofdeath
    Thanks! This works! I had a problem to find a living enemy, so I had to carry him about 200m from the camp, but after the trap exploded, I fast traveled to nearest sync point and returned to respawned enemy which after kill gave me the wealth.

  • Georgerik
    6 posts

    @casual_death There is a workaround for the Vinland wealth issue. I am also stuck with Reda, but it should be fixed in next patch as it is listed in the main topic.

  • Bing0K1ng
    18 posts

    @leoraptor1979 I have the exact same problem. No way to reach 100% in that area now.

  • phoenixash2001
    10 posts

    *POSSIBLE WORKAROUND WEALTH TREASURE IN VINLAND*

    * Go to Vinland.
    * Make a manual save
    * Carry the body with the wealth out of the camp area (so you are not in the red zone).
    * Plant a trap on the body.
    * The body now needs to explode. You can do this by either:

    _ Finding a patrol and letting them explode it.
    _ Keep heavy attacking the body until it explodes.

    When the body explodes:

    * make manual save!
    * reload that save

    * go back to the camp....and the enemy should, if you did the above correctly, have respawned.

    I just did it...it worked for my friend and now for me.

    Good luck

  • phoenixash2001
    10 posts

    After patch 1.04 you probably miss two wealth points.

    1 in East Anglia and 1 in Vinland.

    If you have completed the map and killed the enemy you can't collect the new weather dot there.

    What you can do:

    1 Go to Vinland.
    2 Make a manual save (just in case)
    3 Carry the body with the wealth out of the camp and red alert zone.
    4 Place a trap on the body....and explode it

    Either leave it in the path of a patrol
    Or
    Keep heavy attacking it until it explodes

    5 After it explodes make a manual save.
    6 Reload that manual save

    7 Go back to the camp and the enemy should have respawned.

    This worked for me. Courtesy of a friend of mine who figured this out! Brilliant.

    I hope this works for you too.

    Good luck.

  • XboX.FPF
    22 posts

    I can still not collect the wealth of the dead guy...

  • fastica
    5 posts
    Same here but I already finished everything in east Anglia and now from nowhere I’m 16 out of 17 wealth not cool at all

    Check the Dunwic fort.

  • bomberelli56
    2 posts

    Hello,

    I report a bug occured in Vinland; before patch 1.0.4, I had completed all wealth locations in Vinland. After that patch another wealth appeared, though it’s on a dead body and I can’t get it. Fast traveling and getting killed won’t respawn it, it stays dead, and I can’t complete this last location.

  • ULCER_9MM
    3 posts

    Xbox one X

    Since 1.04 patch, two new wealth items have appeared. I only had one cairn left prior to the patch. I completed it and no achievement.

    Now I noticed a new wealth item in East Anglia, which I collected, but is one more than showing on all guides and another in Vinland (taking Vinland total to 5, was previously 4), however this is unlootable as it appears on a corpse in a camp...

  • kale3l
    15 posts

    I'm on pc and i had the same issue
    I had to verify my files and after that the dead was not dead anymore 😊

    but the problem was after that my gear was dowgraded

Suggested Topics

Community Details

26
Online
131.0k
Users
22.7k
Topics
117.9k
Posts