Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @balla_jazzuz Thanks for clarifying that, this would be the thread here I assume.

    Thanks for providing that workaround, I'll close this thread and point others to the linked thread for updates.

    Official Response
  • NessiDS
    1 posts

    @outlaw365 Have you tried the following order? For me it only worked with saving and reloading.
    Blow up the body with the trap, save game, reload, go back to the camp

  • DrPhilUpOnYa
    1 posts

    Hello,

    I am trying to complete all trophies, on ps4 and in the process of going back through to obtain a 100% completion in all territories I needed to grab a wealth that was not showing across the map.

    Im assuming its a Carbon Ingot, beings that its on a NPC Elite, at the Hvallgrot Outpost.

    Once I got close it showed the Wealth Icon and a Deadbody but cant loot...

  • Koyen123
    2 posts

    @lamoi This has potential to be the best AC game yet only if they scrap the whole project and do it from scratch. And preferably allow people who did Odyssey and Origins to be in charge of it.

    As it stands right now this game is pure hot garbage IMHO.

  • sanastian
    4 posts

    @ckealiddy It worked for me ty.

  • KeepItValhalla
    11 posts

    1) Enemy Captain in East Anglia drops a nickel ingot. I've killed him about seven times now, acquired the ingot and titanium EACH time, but it doesnt register as wealth collected.

    2) Enemy Captain in Vinland drops an ingot (cant remember if carbon or nickel). Only difference from #1, is that this enemy DOES NOT respawn. The marker is pointed to his dead body but I cannot loot him. I've tried save and quitting over and over again but he just will not respawn nor be lootable.

    These two are preventing me from getting 100% territory completion.

    Hopefully they fix this. The idea of doing a second playthrough in which I need to do redo ALL mysteries, wealth, and artifacts does not sound appealing at all.

  • TCubie
    4 posts

    Re: [Unable to loot wealth from body in Hvallgrof Outpost in Vinland](/topic/86867/unable-to-loot-wealth-from-body-in-hvallgrof-outpost-in-vinland)

    I'm having the same issue. Its the last thing i need for the "Completionist All the Way!" achievement


  • Cristianson3rd
    1 posts

    Can confirm. Though I swear I actually got that wealth as I usually complete all territories with no exceptions... but, yeah It shows that I have one wealth left in Vinland and I just cant take it to complete all territories. This is literally the only thing left before I can get the completionist all the way trophy!

  • OxIdOAC
    22 posts

    @killgore1981 That works. Thanks

  • Fractal009
    63 posts

    @nessids

    Worked for me ..

  • BMTeliko
    3 posts

    Getting this same issue as well. I have the 1.04 patch and even tried progressing further in the story hoping they might repopulate the camp as that has happened before when I killed someone with wealth and was unable to collect it. Every time I return to Vinland the camps are still cleared and the body is still just laying there.

  • D4rKy26
    62 posts

    @bmteliko try to put a trap on that dead body, then lure an animal to it let the body explode, then travel to norway and then back to vinland, go to the spot where the dead body was a new enemy should spawn there kill it then autoloot it.

  • Fabrychenko9o
    3 posts

    Good evening,
     I gained about 160 hours of play on this title, finishing the main story, and all the rest.
     Trying to get the trophy "Top to Bottom!" I ran into an unpleasant bug.

     Having obtained everything in England, Norway, Asgard, Jotunheim the trophy does not unlock.

     Although I have already completed everything in Vinlandia on the first visit, I try to go back, maybe something had escaped me or I had not been able to complete it ...

     Indeed, the map shows a "wealth" to be obtained. I go to the place, an outpost that I had already completed, the "wealth" is in a soldier lying on the ground dead, from my first visit I guess, but it is not possible for me to plunder him and that "wealth" I am unable to obtain as a consequence the relative trophy.

     How can I solve?

     Thanks,
     Fabrizio.

  • Agent-LeeGT
    2 posts

    Yes I have the same issue (PC)

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey all! We really appreciate the information here. Our team is aware of issues with wealth resetting in certain areas, including in Vinland since the latest title update. We're looking for more information on this issue. If you're experiencing this issue on PlayStation or PC and would like to aid in this investigation, please gather your save game files, then create a case with our dedicated support team, so these files can be forwarded to the game team for investigation!

    Official Response
  • Angiebcn89
    3 posts

    @petteflet88 what the hell... I never thought of making the body explode hahaha I won't try it now if it won't solve the problem.

    Let's hope Ubisoft fixes it... Now it is really the last thing to get for the platinum (I already got the sturgeon and the "Good catch!" trophy, the other one I mentioned I was missing).

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey there,  Fabrizio! Thanks for the information on this. I'd like to get a closer look at things - is it possible for you to provide us with a clip of this occurring?

    Official Response
  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey all! Thanks for reporting this. I'd like to know if the workaround offered by D4rKy26 (Thanks for sharing!) Helps solve the issue for others. Additionally, we'd also greatly appreciate having any video / clips of this occurring, so we can take a closer look.

    Official Response
  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    Hey all! Thank you all so much for the information shared here, it's incredibly helpful for our team's investigations. The only other thing we'd like to grab from players specifically on PlayStation and PC are save game files from those experiencing this. To help, create a new support case with our dedicated team, and attach the files mentioned to the case!

    Official Response
  • Smrtiak.SVK
    127 posts

    @ubiwan I receive this wealth after setting trap on this body out of the camp, killing another NPCs and load manual saved game, and this guy with wealth was in camp, I killed him and I get wealth.. Uh, but bugs in this game are worse than was bugs in Odyssey... because there is so many of them... And you was making advertisement like your game gone GOLD before Valhalla was released, but you were lying to us. This game is still unfinished even after 2 patches. This is like cheating from developers to us. But I pay money for complete game... So I was FORCED by YOU use inventory editor to receive fishes I was hunting almost 10 HOURS, when I find out they are not in game yet, I find it in this forum...So sorry, but this was wasting my time, and I deserved to get his fishes after so much hours fishing them even if it was from inventory editor. But after I finally get swordfish, I saw no unlocked trophy "Stinky, but deadly" on my PC... another bug! Come on... There are bugs in your bugs... This is terrible...

Suggested Topics

Community Details

25
Online
129.7k
Users
22.4k
Topics
116.3k
Posts