Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • EvolvedEv1l
    3 posts

    @nessids this worked for me thank you

  • AwakentheDead
    18 posts

    I’m on PS5 NA and have the same issue. I had Vinland 100% completed and returned after I finished all there was in All other locations. Now it shows I have a missing ingot from the same location, same enemy that was already dead. Cant loot him. I tried burning his body. I tried moving him. Throwing him into the nearby lake. Nothing works.

  • sandythehippy
    39 posts

    @guest-ugsmhl0w same. Last wealth I have is on the body of an enemy, but cant collect it. Wont allow me to remove it from his body, not an issue of knowing where the wealth is, it just won't pick up

  • purplebint
    1 posts

    I have the exact same issue. Dead guy in Hvallgrof Outpost has the wealth marker on, unable to loot
    I'd already completed vinland so not sure why this has popped up. Can we get a fix please?

  • Aphemra
    2 posts

    Also happened to me. As someone who wanted to grab this platinum before Cyberpunk released, this is pretty frustrating.

  • cirione
    1 posts

    Same problem on PS4. I've clear this area doing main mission. After finishing game i've come back and there was an unobtainable loot on corpse.

  • cormacboy2001
    6 posts

    One of the wealths has respawned in Vinland after recent update and is now unlootable. Its the only collectible I need to the completionist achievement.

  • rorzabal
    1 posts

    I had this same issue. When I completed Vinland, all the wealth locations were complete. However, patch 1.0.4 added a new wealth location to both Vinland and East Anglia. So I had a corpse lying there in Vinland that could not be looted, and the camp would not repopulate. It was keeping me from the 100% achievement so I tried all kinds of things to get this completed.

    I found a workaround! Make sure you have the skill that allows you to Set Trap (press Right stick, on Xbox at least) on corpse. Once a trap is set on the corpse, you need a guard to trigger the trap and blow up the corpse. I ended up carrying the corpse out of the camp, then THROWING the corpse at some patrolling guards. The corpse blew up and was no longer interactive. At that point, do a Manual Save, reload the game, and the camp the guard came from should be repopulated. Kill him again, get the loot and the 100% achievement.

  • Zhina_zhu_94
    2 posts

    I am playing on PC. I looted the wealth (ingot) in Dunwic in East Anglia, but the wealth does not tick off in the region, and it did not even appear on the map or marked on the map when I first discovered it.
    I did not start East Anglia, to be more specific , I am not even completed any of the main story since I reached settlement

    Below is the video showing this bug.



  • Ubi-Wan
    Ubisoft Support Staff 610 posts

    @zhina_zhu_94 Hello there! Thank you so much for providing this information, as well as this clip! I'd like to know if you still have trouble with this wealth after verifying your games files, or perhaps even getting further into the story?

    Official Response
  • Zhina_zhu_94
    2 posts

    @ubiwan

    Hi, I have verified my game files and revisited the area with a save which do not have the mentioned wealth claimed yet.
    It still does not work for me.

    As for the story, it will take some time for me to get into East Anglia Arc, although I am not quite optimized about such action will resolve the issue.

    If I have any update, I will post it here.

  • Growler.RM
    1 posts

    @loquacious_b Dude, you have no idea how bad this bug for me. I've completed the whole game with all the trophies except for "Completionist all the way". I badly need this wealth to do so... I hope somebody from Ubisoft sees this because as far as I can see this is a very rare bug and it's very annoying. My bug is on PS4 though.

  • ikamandi
    2 posts

    I couldn't collect this wealth at hvallgrof outpost, Vinland. It's supposed to be on an enemy, but its marker just on some rock formation, not any enemy.
    I tried blow up corpses to respawn them, didn't work.

  • FeXorzist
    1 posts

    I can‘t loot the mop at „Hvalgrof-Outpost“ in Vinland which got the wealth. Can someone help?

  • AwakentheDead
    18 posts

    @rorzabal just stumbled upon this solution myself. I carried the guard all the way to Nyhofn thinking the innocents would explode him but they didn’t. So I just shot him with arrows until he exploded. Then I traveled out of Vinland and back and the enemy had respawned at the camp. Killed him and looted him. PS4 trophy gained.

  • Natael2
    4 posts

    I am missing only 1 treasure from Vinland to get the Completionist all the way trophy (after 138 hours spent on a first run of the game, havin to roll back to a manual save made at 99 hours due to "The Big Finish" paint create bug) and I am now at around 130 hours again, so adding up is over 160 hours in the game.
    This treasure is apparently on a corpse of an enemy that cannot be looted (does not give the option) and that do nots respawn, I visited all Vinalnd territory and all enemies killed remain dead, so there is NO way to get the treasure now, and I do not have any save prior to Vinland, and of course I am not very much into replaying again 30+ hours after the 160+ already done.
    I am attaching screenshots as a proof of this.
    I play on PS4undefinedundefinedundefined

  • hottscill
    1 posts

    In Vinland, at Hvallgior Outpost, I cannot loot the guard that holds the wealth. Fast traveling and/or going to England and returning back to Vinland will not reset the guards. HELP!!!


  • Angiebcn89
    3 posts

    Today's patch didn't solve the issue for me, but I tried @Smrtiak-SVK 's process and it worked. 3 weeks later I got the platinum thanks to you. On to the next game 🙂

  • dannyboi41681
    2 posts

    Also having this problem, all other areas complete, just waiting for Ubi to fix this

  • axlslak23
    97 posts

    another solution is to change difficulty. Apparently that respawns that guy as well.

Suggested topics

Community details

20
Online
125.1k
Users
21.6k
Topics
111.3k
Posts