Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Georgerik
    6 posts

    @jonofdeath
    Thanks! This works! I had a problem to find a living enemy, so I had to carry him about 200m from the camp, but after the trap exploded, I fast traveled to nearest sync point and returned to respawned enemy which after kill gave me the wealth.

  • Ubi-Borealis
    Ubisoft Support Staff 1381 posts
    Best Answer

    Hello there!

    I have merged together several megathreads about the missing loot in Hvallgrof Outpost together into a single megathread. I apologise if any ongoing discussions have been disrupted by this. By creating a single thread, we can keep all updates and information from an investigation in one place.

    The development team marked this issue as resolved following the release of TU 1.1.1. If you are still having trouble collecting this wealth, I would recommend trying a workaround that has been shared by several other players within this thread:

    Carry the body to a nearby camp with patroling guards. (Brúhamarr outpost is ideal for this). Place the body on the road where guards are patrolling. Set a trap on the body. Make sure the guards discover it and activate the trap. This disintegrates the body. Travel back to England. Travel back to Vinland.The live guard should now be respawned in the Hvallgrof Outpost. This will be the only guard in the camp and will be lootable.


    If you're still unable to loot the wealth after trying this workaround, please don't hesitate to send us a video that shows you're unable to collect the wealth from Hvallgrof Outpost so we can pass this along to the development team for further investigation.

    @luffare820604 - I apologise for the delayed response. Would you be able to let me know if it's the wealth in Hvallgrof Outpost you're having trouble with? If so, have you tried the workaround above?

    Thanks! 😊

    Official Response
  • Georgerik
    6 posts

    @casual_death There is a workaround for the Vinland wealth issue. I am also stuck with Reda, but it should be fixed in next patch as it is listed in the main topic.

  • phoenixash2001
    10 posts

    *POSSIBLE WORKAROUND WEALTH TREASURE IN VINLAND*

    * Go to Vinland.
    * Make a manual save
    * Carry the body with the wealth out of the camp area (so you are not in the red zone).
    * Plant a trap on the body.
    * The body now needs to explode. You can do this by either:

    _ Finding a patrol and letting them explode it.
    _ Keep heavy attacking the body until it explodes.

    When the body explodes:

    * make manual save!
    * reload that save

    * go back to the camp....and the enemy should, if you did the above correctly, have respawned.

    I just did it...it worked for my friend and now for me.

    Good luck

  • phoenixash2001
    10 posts

    After patch 1.04 you probably miss two wealth points.

    1 in East Anglia and 1 in Vinland.

    If you have completed the map and killed the enemy you can't collect the new weather dot there.

    What you can do:

    1 Go to Vinland.
    2 Make a manual save (just in case)
    3 Carry the body with the wealth out of the camp and red alert zone.
    4 Place a trap on the body....and explode it

    Either leave it in the path of a patrol
    Or
    Keep heavy attacking it until it explodes

    5 After it explodes make a manual save.
    6 Reload that manual save

    7 Go back to the camp and the enemy should have respawned.

    This worked for me. Courtesy of a friend of mine who figured this out! Brilliant.

    I hope this works for you too.

    Good luck.

  • XboX.FPF
    22 posts

    I can still not collect the wealth of the dead guy...

  • bomberelli56
    2 posts

    Hello,

    I report a bug occured in Vinland; before patch 1.0.4, I had completed all wealth locations in Vinland. After that patch another wealth appeared, though it’s on a dead body and I can’t get it. Fast traveling and getting killed won’t respawn it, it stays dead, and I can’t complete this last location.

  • Petteflet88
    346 posts

    Here we go again, another bug. 1 wealth in vinland is a dead Guy who is already dead. Does not respawn so it is not alble to be taken.

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    @bomberelli56 I am sorry to hear that, can you confirm if you are able to trap the body? If so can you do that, get it to explode and then fast travel away and return? Players have reported that this can fix this issue.

    Official Response
  • bomberelli56
    2 posts

    @ubi-swaggins it worked! Thank you very much.

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    @bomberelli56 Fantastic, thank you for confirming it worked for you!

    The issue itself has been raised to the team for investigation, but it is good to know that the workaround has solved for you 🙂

    Official Response
  • Mongolkhan77
    4 posts

    I completed all territories in Norway and England. But I can’t get one last wealth in Vinland cause the person who has the wealth is dead and I can’t collect it. I completed all wealth and mysteries in Vinland before but after patch 1.0.4 it seems some it reset some wealth in some territories. Please help because this is the last thing I need to do to get the “Completionist All the Way!” achievement.
    I play on Xbox One X.

  • Mongolkhan77
    4 posts

    @bomberelli56 how did you make it explode? I got the same issue.

  • Outlaw365
    1 posts

    @jonofdeath Unfortunately it didnt work for me and now his body disappeared. Guess I have to w8 for a new patch or sth....

  • jeje_71
    69 posts

    @outlaw365 if his body disappeared, the guy should reappear in the original position in the camp after a reload.
    fast travel didn't work for me, but reload did.

  • Fractal009
    63 posts

    I will try this aswell but men, why is it we have to make such things to fix a mess from Ubi ???? explain to me because I dont understand 🙂

  • jeje_71
    69 posts
    I will try this aswell but men, why is it we have to make such things to fix a mess from Ubi ???? explain to me because I dont understand 🙂


    because people continue to buy their games even if they release buggy games and lots of times never fix problems in the savegames as long as it does not affect too much people...

    money, simple as that.

  • Angiebcn89
    3 posts

    @petteflet88 I am having this exact same issue. It's even more anoying when this ingot is the only thing preventing me from getting the platinum trophy hahaha That and the [censored] sturgeon

    More info for the Support Staff: It's one in the Hvallgrof Outpost, here's a screenshot and a little video.



    undefined

  • Smrtiak.SVK
    108 posts

    Well, I have the same issue 😒

  • sanastian
    4 posts

    Trying to Finish the 100% of each territory for the trophy "Completionist all the way!" In Ps5 the trophy never popped. I went map by map looking for the missing Wealth, Mystery or artifact and found I had 4/5 Wealth in Vinland even knowing I had finished this map at its 100% already I went to check out the missing wealth and I found the missing Wealth to be in an enemy dead body.
    Somehow the wealth was removed from my progress and the enemy never respawns so I can't get to finish my 100%. I tried attaching an image to this post but every size and resolution says its too big if there's any other channel to do that I will gladly send the detailed pictures you need.

Suggested topics

Community details

5
Online
124.0k
Users
21.3k
Topics
110.0k
Posts