ubisoft discussions

Quick Suggestions

  • harry2517
    1 posts

    @gokislav I did it and it solves the problem. Thanks man!

  • Siberix5102
    4 posts

    @acmute If I get stuck again, I will try this. But now, since the patch, I can't save the game manually and autosave is not working. So I've uninstalled and waiting for a fix.

  • thegeordielad99
    1 posts

    After speaking to Petra and starting this quest upon noticing it was in a higher level area I decided to come back to it later. I then started a raid on a monastery and she appeared to help. Now she is stuck 3000m away and is stuck walking all the way back to the area in which it should start. Every time I start my game its selected as the default quest and she remains 3000m away. I go over to her to trigger her walk but upon moving a certain range she stops until you go back to reactivate her movement. She doesn't get on your horse and as soon as you get on yours to get ahead of her Eivor says I'll get back to you later and she stops moving. Anyone any ideas how to fix this? I tried a raid closer to the objective area but she didn't appear to help out unfortunately. It's really beginning to bug me 😞

  • Saint_Marcus
    1 posts

    I had the same error, once I followed the elk and she came back but glitched out near the fishing hole NW of the settlement. The second time I followed her away from the Elk and she almost due north of the settlement then stopped again at an invisible wall about the same distance North along the Y axis or Latitude.

  • Gokislav
    21 posts

    @harry2517 No problem 🙂

  • SheytanEterna
    3 posts

    @gokislav I have the very same Issue, you said we should wait at the cliff where the quest should be finished.. I have no clue where that is though. Can you help me find that spot?

  • miksamiksa15
    1 posts

    Hey there!

    I was playing a mission called 'Have You Seen This Man' where you go with Petra, meet a while elk and find her brother. I've reached the point where Petra asks you to run in a straight line. I do exactly that and... nothing happens.

    What *should* happen, after Googling and watching a few vids, is that lightning throws you into the sky and you land and progress with the mission. I believe my case is a bug.

    Is there any way that can be solved? I'm on PC and all auto-saves just bring me back to the start of the mission.

    Thank you!

  • DogasGaming
    1 posts

    @guest-cv0qs9gg likewise, I'm getting the same bug! Ubisoft please fix this!

  • UbiKobold
    Ubisoft Support Staff 882 posts

    Howdy everyone! Thanks for letting us know that you all have encountered this issue in the 'Have you seen this man?' quest. Gokislav mentioned a workaround earlier in this thread, however, if that does not work for you please provide a video showing this issue from your gameplay. You should be able to post the video to YouTube as unlisted and then send the link here.

    Also, please check out our guide here: (https://support.ubisoft.com/en-GB/Article/000060522) as it is known to resolve a decent amount of in-game issues.

    Official Response
  • mosessargent85
    1 posts

    I am having trouble finishing this quest. I go into the basement to investigate the clues and the one over the pool of blood shows up and as I approach the symbol disappears and I cannot interact with it and thus cannot continue with said quest. And I have progressed way too far into this game so I have no save file to load to try and reset the mission please help

  • shangrish
    2 posts

    after petra see's the elk again after the fighting the wolves it gets to an area where she just stops and nothing can be done..

    petra doesn't move and you cant fast travel anywhere.

  • Nightmare_2000_
    1 posts

    Go to the cliff on the left. You should see the deer. Walk up to it and you should enter the cutscene even though Petra is glitched. Hope this helps.

  • RybackStorm
    1 posts

    I've been unable to complete 'Have You Seen This Man?' for some time and this has now locked me out of redeeming Legendary animal rewards because Petra/Wallace aren't in the settlement.

    Platform: Xbox Series X - Physical Copy, latest patch.

    1. I descended into the Apollo temple (Think that's what it was called?)
    2. Killed the boar
    3. Investigated 2/3 clues

    However I'm unable to investigate the 3rd clue which is the pool of blood. I see it highlighted with Odin's Sight and I see the 'eye' icon but I cannot interact with it.
    I've long since passed a save prior to this so I cannot rollback and try again. I've seen other people post about this issue but I've taken a clip/screenshots to demonstrate.

    Fast travelling, restarting, doing other quests, exiting the Animus and returning doesn't help.


    Video Example:

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi Rybackstorm! I greatly appreciate you bringing this error to our attention and would like to thank you for including the screenshot and video in your post. I've shared both of these with the proper teams, so we can get this issue looked into further. Please stay tuned for updates. 😊

    Official Response
  • Bushwickedly
    109 posts

    Manual Saves every 15 minutes and BEFORE engaging each quest will save you tons of hurt going forward. Auto-saves for this game can overwrite themselves in a 5-7 minute span, meaning the oldest one is 7 minutes old. In game like this with a 200+ hr possible play time and numerous issues, manual saves are a must and worth the minor inconvenience of manually overwriting old saves. Me personally, I let it fill up with 20 manual saves (PS4) then go back to man save 1, and overwrite that, then 2, 3, etc.. That way, I ALWAYS have 20 manual saves on-hand spanning 5-10 hours back roughly. Usually enough to restart a bugged area.

  • KOBI9800
    1 posts
    This post is deleted!
  • remijdio
    4 posts

    @billy_buttons Had the same thing happen to me but changing my gender didn't work. I ran all over...like ALL OVER and nothing. At the very least it would have been nice to be able to save during the quest so I didn't have to retry it 3 times 😞

  • Darksider32685
    1 posts

    Has anyone else had a problem with the clue in the temple and not being able to interact with it?

  • Puma9426
    1 posts

    During the quest "Have you seen this man?" I cannot interact with a clue at The Church of Pluto to continue the mission. Constant restarts and a full reinstallation has done nothing to fix it.

  • Vaxintoxicated
    1 posts

    @coolzero I’m having the same issue and talking to support about it. Did u find a fix ?

Suggested Topics