Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Dags097
    1 posts

    I'm also having the same issue, have you found the solution yet?
    Thanks!

  • hhamburger
    1 posts

    I can mark him, but he shows somewhere below ground to the West of Buckingham. As far as I can tell there is no way to reach him. Which means I can't finish that branch of the Order. Any advice?

  • guest-RxwoQ4Gj
    2 posts

    I can't locate him, he is not where he should be or I missed something. HELP

  • guest-wlbWtX7S
    3 posts

    So I have encountered not a glitch of the bell himself but the map at Brimclif. So I was chasing him and he fell down the cliff and fell through the map so now he is stuck inside the cliff with no way of confirming the kill. I have tried reloading and marking and unmarking him but nothing has worked. He is still inside the cliff dead but I can't confirm it. Any help would be appreciated. Obviously this is a game breaking bug because now I can't complete the order tree and identify the father.





  • HGWanderer
    1 posts

    Hello, in my game Beneseck of Bath (The Bell)

    is missing. when I activate the follow option the tree symbol is right inside a rock wall. I tried everything. even slowly killing everyone in the monastery. nothing works. even if i stand right infront of the rock wall and activate odins vision i cant see anything. im playing on the xbox.

  • Ubi-Orion
    Ubisoft Support Staff 148 posts

    Hey there.

    Thanks for reporting this to us. The issue is planned to be fixed with a future update, please keep an eye on the forums for news on when these updates are happening. We do apologise for the inconvenience caused whilst we're working on getting this resolved.

    Official Response
  • guest-eFwX7iOq
    2 posts

    @hhamburger did you ever figure it out, because I’m having the same problem about the Bell being underground.

  • UbiKobold
    Ubisoft Support Staff 531 posts

    Hey there everyone! Thank you all for your patience and I am sorry that many of you have experienced an issue with locating The Bell! As NoDiceGramma mentioned, you can mark him via his info page which will then mark him on your map.

    However, a couple of you mentioned that The Bell appears bugged when you locate him. Could you provide any video from your gameplay that shows The Bell behaving strangely/appearing to be bugged?

    Also, if you have marked The Bell but he is showing underground, please provide an image or video from your gameplay as well. Also, let me know which platform you are playing on. For videos, just post it to YouTube as unlisted and then provide the link here. Thanks!

    Official Response
  • guest-eFwX7iOq
    2 posts
    This post is deleted!
  • Ubi-Borealis
    Ubisoft Support Staff 2131 posts

    Hello there!

    I've merged together several similar threads about The Bell's disappearance into a single thread. This will help us to keep all information and updates from an investigation in one place. I apologise if any ongoing conversations were disrupted by this merge.

    The development team has marked this issue as resolved following TU 1.2.0. If you are still unable to find The Bell following this update, please can you provide us with a video that shows the following:

    • The current TU you have installed. You can view this on the main game menu, in the bottom-right corner
    • The Bell shown as tracked in your Order menu
    • That The Bell is not in the location he should be, or that the marker is inaccessible


    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. You can check this by looking for the cloud icon on your desired save file.

    We can then pass your report along to the development team for a closer look.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details

49
Online
130.4k
Users
22.6k
Topics
117.2k
Posts