Welcome to discussions

Quick Suggestions

  • Ubi-Keo
    Ubisoft Support Staff 1878 posts

    @alegrosa I am unable to confirm how long it will take for the dev team to resolve this issue. There are no further updates at the moment and it is still being investigated.

    Please keep checking here for updates on the game.

    Official Response
  • chefguy85
    1 posts

    The "A Cordial Invitation" mystery in Sherwood forest will not initiate. I don't have the option to speak to the Anglo-Saxon Soldier. Reloading, exiting the animus, fast traveling haven't gotten this to change. I've had a few other open world events in this game start working after completely closing and restarting the game but this one seems to be stuck. This is the last activity I need to complete in England.😞

  • Jongsten
    5 posts

    @ubi-woofer Hi thanks a lot for the follow-up!

    Unfortunately, this is still not fixed.. I still can't talk to the NPC and get the well-deserved platinum trophy. I tried to create a case on the Ubisoft support page but it's not possible.

    It says that the chat is currently unavailable. Please choose a different method.
    I waited another month for this to be fixed but no luck so far. I would love some assistance on this. 🤗

  • DaSnake1019
    1 posts

    When i arrive at the world even location, i only see dead bodies on the ground. No prompts or anything/anyone to interact with.

  • Ubi-Wan
    Ubisoft Support Staff 635 posts

    @dasnake1019 Hello there! I'm sorry to hear this. Our teams are aware of issues regarding 'A cordial Invitation' and are looking to gather more information. We ask that those affected by the issue create a new ticket and attach a copy of their save game files to it for review. If you'd like, post your case number here after the case is created so we can ensure things are in the right place! Additionally, it'd be a great help to ensure your latest save is uploaded to the cloud.

    Official Response
  • Jongsten
    5 posts


    Hi there again,

    I just made a case on the Ubisoft support page. The reference number is 14366358.

    Before making this case, I also wandered around the area to see if the NPC was around. I did not find him, unfortunately.

  • Ubi-Borealis
    Ubisoft Support Staff 3895 posts

    Hello there @Jongsten!

    I apologise for the delayed response. Thanks for providing us with an update of your experience with "A Cordial Invitation," and for opening a support ticket. Thanks for letting us know that you've checked out the surrounding area as well. I've passed this information to the development team so they can take a closer look 🙂

    Official Response
  • dannyp607
    1 posts

    A Cordial Invitation - No Speech Buuble

    Playing AC Valhalla on PS4 and this is the last wealth / Artifact / Mystery I need to complete the game.

    There its no speech bubble over Robin Hood after I kill all the Picts?

    Any idea how to resolve please?

    I have already tried fast travelling and doing other bits.
    Exiting the animus
    saving previous load..\

  • PumaTropfen907
    1 posts

    I killed the guys but the guy disappeared and I can't restart the mystery apparently. Is this issue known is it gonna get fixed?
    It s the only thing that stops me from completing the game....

  • Ubi-Mark.
    Ubisoft Support Staff 1591 posts

    Hello @PumaTropfen907,

    Sorry to hear that you are unable to complete this mystery.

    I can see that this issue has been reported to the development team and it's currently being investigated. In order to speed up the investigation, can I kindly ask you to provide us with your save files with this link?

    Many thanks and if you have any additional questions, please let us know. Apologies for any inconvenience caused by this.

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3895 posts

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "A Cordial Invitation" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
    If you are still encountering issues with "A Cordial Invitation" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3895 posts

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.2.2, we will now be locking this thread.

    If you encounter any further trouble with "A Cordial Invitation," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details