Welcome to discussions

Quick Suggestions

  • TheRealMrClean1
    1 posts

    Same problem

  • elleth05
    1 posts

    After following Wulfthilda to the church in Brisleah can't talk to her to continue the quest.I didn't exactly follow her and went to the adjusting building to open up a chest and kill some wolves,upon return to the church Wulfthilda doesn't have a speech bubble.Playing on Ps5.

  • STEELMAN012
    2 posts

    @elleth05 same thing for me. Hoping we get a patch soon. Your suppose to follow her and search for survivors but I guess if u don’t follow right be hide her the game gets confused lol.

  • premi_pulkit
    19 posts

    @sheeld Exactly same thing. The quest does not progress. Ubisoft, can you please advise (& please do say reinstall 50 GB of game)

  • Dusty13B
    2 posts

    Been stuck here for 8 days... CAN WE GET A FIX ALREADY!? Thanks

  • JoanOfSnark314
    1 posts

    Still not fixed? I've tried everything except going back to my save from the day before (multiple hours of game play earlier). I don't want to stop playing but this is ridiculous.

  • Winemiller32
    2 posts

    When it says “Follow Wulfhilda to Brisleah”, Wulfhilda walks in this church and is then frozen in place. You cannot continue the quest or interact with anything from there on. Very bugged.

  • Winemiller32
    2 posts

    It’s the Prey In the High Hall quest.

  • xxARMY2260xx
    1 posts

    @smokingood2019 same wonder when they will fix it

  • Nomad_gr
    1 posts

    same here,try earliers save points,verify files,reinstall the game but nothing.She stand and the dialoge never start

  • Ubi-Ginge
    Ubisoft Support Staff 257 posts

    Hey Valhalla430!
    The dev team have been made aware some players are unable to interact with Wulfhilda. They're currently looking into this

    Official Response
  • B.Ant
    1 posts

    the mission is bugged AF

  • X3l3brium
    1 posts

    Quest: Prey in the high halls (Legend of Beowulf)

    Arriving at the Brislea homestead and entering the building where Wulfhilde is, nothing more happens. 
    Wulfhilde does not step up to the altar and therefore no interaction with her is possible.
    Quest can't be continued in this way.

    Reboot, uninstall etc pp have already been performed.

  • Ubi-Swaggins
    Community Manager 420 posts

    Hey folks,

    Sorry to hear that.

    This issue has been logged with the dev team and they are looking into it further.

    Apologies for any inconvenience.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 704 posts

    Hey there! Are you able to reload a save from before you followed her to the church? And did you do anything else before trying to talk with her, such as looting the nearby house?

    Official Response
  • tiosaamcg
    1 posts

    same here!

  • Soulstorm1997
    1 posts

    Same here, hope this will be patched, would loose over 16h of progress and wouldnt start again. How the hell could Ubisoft charge up to 100 bucks for a pile of gamebreaking Bugs...

  • hayleyyelisee
    1 posts

    I have the same issue. Please fix this 😞 I just want to play my very expensive game. Also still can't save. All previous saves are now corrupt (even autosaves) so I don't even close the game out because of this.

  • Rayrizzzle17
    1 posts

    I loaded a previous auto save from a fight with wolves right before heading to the church. But this time I followed Wulfhilda all the way to church without sidetracking anywhere and it worked. I was a le to interact with the blood stain on floor and talk to the leader on the floor above.

  • Riphide
    2 posts

    I have a fix for this. It’s ridiculous but it works. Leave the area and get a dead body that you can carry. Put it on the back of your horse and bring it to the church. Then proceed to throw the
    body at her towards the alter When she’s almost to the alter the quest should update.

Suggested Topics

Community Details

28
Online
196.7k
Users
33.4k
Topics
166.9k
Posts