Welcome to discussions

Quick Suggestions

  • MushroomStampN
    2 posts

    @akorna Sadly, I tried 3 previous Autosaves (different stages of quest)... ALL of them actually when they loaded, loaded me back to teh church and the Autosave time stamp mas made current... WEIRD.. so then after trying to load previous autosave points... they ALL became the SAME point... Game breaking bugs is what made me stop playing LEgion, and now it seems I will stop playing Valhalla if I encounter one more bug 😞

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Prey in the High Hall" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "Prey in the High Hall" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Akorna
    14 posts

    @mushroomstampn Yup, I had the same thing as @guest-VeFA0suF except that for me, just like you, all autosaves seemed to have "changed" into the same point. So there was no way for me to reload an older save. Even worse, the manual save from the day before (I would have lost +-8 hours of progress but fukkit) had the same "save content" as the latest one, so even that one spawned me at the church with the bugged npc again. So... not even a way for me to return. Can't say it gets better... not yet at least.

  • Valhalla430
    1 posts

    I followed wulfhilda to brisleah and looted instead of talking to her now she's stuck in the church and I can't interact with her I've put 45 hours into the game and don't have a save around this quest please help if this isn't fixed I'll stop playing im not restarting and losing 45 hours of work

  • Nowmane
    3 posts

    I have the same problem, she just stands in the middle of the church and waits for me 😞

  • STEELMAN012
    2 posts

    im Having problems with progressing through the bar wolf dlc. The point after you have met the nun and go to the church to see if the group of Vikings are a cause of the attacks. Once u get there you are suppose to check for survivors but the women just goes in and stops. No dialogue option comes up. And I know you are suppose to find the guy upstairs who is the only survivor to see what he knows. Is anyone else having this issue with this quest

  • TheRealMrClean1
    1 posts

    Same problem

  • elleth05
    1 posts

    After following Wulfthilda to the church in Brisleah can't talk to her to continue the quest.I didn't exactly follow her and went to the adjusting building to open up a chest and kill some wolves,upon return to the church Wulfthilda doesn't have a speech bubble.Playing on Ps5.

  • STEELMAN012
    2 posts

    @elleth05 same thing for me. Hoping we get a patch soon. Your suppose to follow her and search for survivors but I guess if u don’t follow right be hide her the game gets confused lol.

  • premi_pulkit
    19 posts

    @sheeld Exactly same thing. The quest does not progress. Ubisoft, can you please advise (& please do say reinstall 50 GB of game)

  • Dusty13B
    2 posts

    Been stuck here for 8 days... CAN WE GET A FIX ALREADY!? Thanks

  • JoanOfSnark314
    1 posts

    Still not fixed? I've tried everything except going back to my save from the day before (multiple hours of game play earlier). I don't want to stop playing but this is ridiculous.

  • Winemiller32
    2 posts

    When it says “Follow Wulfhilda to Brisleah”, Wulfhilda walks in this church and is then frozen in place. You cannot continue the quest or interact with anything from there on. Very bugged.

  • Winemiller32
    2 posts

    It’s the Prey In the High Hall quest.

  • xxARMY2260xx
    1 posts

    @smokingood2019 same wonder when they will fix it

  • Nomad_gr
    1 posts

    same here,try earliers save points,verify files,reinstall the game but nothing.She stand and the dialoge never start

  • Ubi-Ginge
    Ubisoft Support Staff 127 posts

    Hey Valhalla430!
    The dev team have been made aware some players are unable to interact with Wulfhilda. They're currently looking into this

    Official Response
  • B.Ant
    1 posts

    the mission is bugged AF

  • X3l3brium
    1 posts

    Quest: Prey in the high halls (Legend of Beowulf)

    Arriving at the Brislea homestead and entering the building where Wulfhilde is, nothing more happens. 
    Wulfhilde does not step up to the altar and therefore no interaction with her is possible.
    Quest can't be continued in this way.

    Reboot, uninstall etc pp have already been performed.

  • Ubi-Swaggins
    Ubisoft Support Staff 340 posts

    Hey folks,

    Sorry to hear that.

    This issue has been logged with the dev team and they are looking into it further.

    Apologies for any inconvenience.

    Official Response
  • Ubi-Spud
    Ubisoft Support Staff 698 posts

    Hey there! Are you able to reload a save from before you followed her to the church? And did you do anything else before trying to talk with her, such as looting the nearby house?

    Official Response

Suggested Topics

Community Details

59
Online
138.7k
Users
24.3k
Topics
125.8k
Posts