ubisoft discussions

Quick Suggestions

  • simpleDude21
    2 posts
    This post is deleted!
  • I_amlorde
    2 posts

    I am having this issue where Bárid is stuck in the Stalls in Kilchrist, Dublin and Ciara is standing at the entrance to the ceremony. Upon entering the area of the ceremony my mount becomes unavailable and I cannot talk to anyone. Back at the stalls, I try to use force to move Bárid, ie, swinging my axe at him, running into him while on my mount and although it sometimes gets him to move, quite far as well, he always ends up walking back to the same spot in the stalls and just standing there. I really hope this gets fixed. Soon.

  • lotia0613
    1 posts

    On escort baird mission, barid doesn't move. he keep staying in the stable, but kiara arrive at the party. please fix it. I can't go back because I played main mission!!!!!

  • Ubi-Karl
    Ubisoft Support Staff 1534 posts

    Hey @lotia0613, thanks for reaching out and welcome to forums!

    As it stands, I can confirm that have received a number of contacts regarding this specific issue and it is currently under review by our development team.

    Apologies about the inconvenience this may have caused for the time being and as soon as we will have further information, details will be posted here, in our official forums, so keep an eye!

    Official Response
  • MrChiaroscuro
    1 posts

    I am having the same problem, Ciara is no where to be found (quest track gliches) and Bárid is sitting on his throne at the palace (not in the stables!). Can´t move him and can´t progress in the quest.

    At the beginning of the quest I didn´t go to the market to search for Ciara, rather decided to follow the Dublin´s Reach quest, and I opened all trade spots. If I have to select a different save game I will loose hours of progress.

    Edited: manage to unstuck the quest. Fought Bárid at castle a little, he stands up, draw the sword but eventually sits again in the throne. But when I approach the tavern after that the cutscene (of drunk Ciara offending a couple) started and I was able to continue the story (by fist fighting the couple).

  • ShawnL_85
    2 posts

    Has there been a fix for this yet, as I am having the same frustrating issue.

  • ShawnL_85
    2 posts

    @shawnl_85 an hour and 45mins later I was able to block him (square button ps4) all the way to the destination.... ugh

  • Ubi-Karl
    Ubisoft Support Staff 1534 posts

    Hey everyone, appreciate your detailed input as well as sharing workarounds that have helped to complete the quest 🙂 .

    This particular matter is still under review, so appreciate your continued patience and as soon as we will have more information, details will be posted here, in our official forums as well as AC Valhalla website, so keep an eye!

    Official Response
  • Galvit314
    4 posts

    @ubi-karl I'm confused why we're always told the issue is being investigated, but the dev team updates of issues under investigation and expected fixes in next versions don't address it:

    Target: 1.4.0 (Expected release: Fall 2021) 

    The below issues are currently targeted to be addressed in a future update.
    [NEW] Haptic feedback disabled since Title Update 1.3.2
    Constant New Quest Alert since Title Update 1.3.1
    Blacksmiths in all locations do not have the option to Enhance Gear for Pants.
    Workaround: Equip the pants you want to upgrade
    Large Swords are held upside down in the off-hand
    English description present for Svartalfar weapon pack items, regardless of selected language.


    River Raids 
    Long loading screen during transition between River Raids and settlement on PS4 

    Wrath of The Druids Expansion 1 
    Contracts may disappear from your quest log if you die and reload  
    Workaround: Rebooting the game should solve this issue 
     World events or side activities-related issues:   
    Milk of Humankind / Audumbla is unable to move  
    ULC quests disappear from Quest log 
    The Mysterious Berserker - The quest disappears after changing the sound language from English to other languages 
     General issues   
    Screen tearing on PS5  
    Some achievements / trophies do not retroactively unlock after bringing your progression onto another platform.  
    Note that the experience may vary depending on the combination of platforms used for cross-progression.
    Experiencing this issue? Report it in our dedicated Megathread or via Ubisoft Support.
    A Little Problem / Man's Best Friend ability not unlocked after completing the quest    
    Players may fall through the map in a cave near Anlaf's Lookout  
    Potential Workaround: Fast travel away if you get stuck  
    Avenge quests are difficult to spot  

    Additionally the dev pipeline detail that goes along with those updates suggests main quest progression bugs take priority over most other issues ("Flagged issues are categorized and prioritized based on frequency, severity, and/or player impact. (E.g. Main quest progression blockers will generally see a higher priority than side content or quality of life issues)", yet the list of updates for 1.4.0 has items like this:

    • [NEW] Haptic feedback disabled since Title Update 1.3.2

    and this:

    • Blacksmiths in all locations do not have the option to Enhance Gear for Pants.

    So haptic feedback and unenhanced pants are seen as more important content and not just "side content or quality of life issues" while players continue to report being unable to progress the main quest with this bug?

    It's really hard to believe the claims that people are actually looking at this, and I remain unconvinced it would take this long if anybody was actually bothering to look into the issue.

    Can Ubisoft just admit the no one is actually looking at this or planning on doing anything to resolve this game breaking bug?

  • RingKnockerBE
    5 posts

    Hi team,

    Eventually I've restarted the quest by loading a previous safe file.
    I was ble to continue the quest beyond the stables and have no issues anymore.
    Thanks for the continuous updates!


  • Bernoulli85
    4 posts

    Ciara has been waiting for Barid for months now. Is there anyway we can just set him as non-essential for the mission to kick off? I'm tired of not being able to continue this quest and I don't have a save to revert to.

  • I_amlorde
    2 posts

    after adding a new expansion they have YET to fix the issue in Chapter 1 of the Wrath of the Druids expansion. I honestly specifically bought the season pass because of the Irish DLC and I haven’t even been able to do anything with it. I want some sort of refund and I can tell you right now I will never buy another assassins creed game at full price after the terrible response to this bug. I’ve told everyone I know who’s been interested in this game to stay far away

  • ConcreteNomad
    1 posts

    Same issue here. Ciara is at the ceremony and Barid is still stuck at the stalls. I cannot push him very far and shooting him does nothing. Please fix as I cannot continue the Ireland arc or provide me with a refund for the DLC.

  • Waxy_strength
    1 posts

    I have this problem too please let me know if you find a fix.

  • Roadkiller555
    2 posts

    Same issue here, Ciara is already at Tara, Barid is stuck at the stable.
    How do I fix this? Don't have recent save game...

  • trainer0880
    1 posts

    @ubi-smash mine is in the cloud

  • StubafJorgdin
    1 posts

    Oh boy. I came here because I took a break from the quest line to do all of the exploration and gathering. I do not have a save from before starting the quest and have completed all the mysteries, exploration, and collectables in Ireland. So 7 months later and there's still no fix for this? Basically I'm locked out of the entire story for the expansion?

  • crimescene32
    1 posts

    we have the same bug and still no fix braid is stucked

  • JoeTBear
    1 posts

    Come on Ubisoft. This has been an issue since the DLC came out and its coming up on 5he end of 5he year with still no fix. Seriously just add a reset quest function so we can get on with it or a hot fix that will trigger next cutscene once you enter Tara without both NPC.

  • Roadkiller555
    2 posts

    Same issue here, Ciara is already at Tara, Barid is stuck at the stable.
    How do I fix this? Don't have recent save game...
    @ubi-smash ...

Suggested Topics