ubisoft discussions

Quick Suggestions

  • FaskKeyrok
    1 posts

    @guitarrist4 I have discovered that the enemy in question is a "man at arms" and resides nearby the northern entrance to Donegal. Hope that helps at all.

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello there @FaskKeyrok! Welcome to the forums 🙂

    Thanks for sharing your experience with "Courting the Kings" within this thread, and for letting us know where you located the enemy with the King's Pass is located. Hopefully this helps other players who having trouble locating the Pass 😄

    Official Response
  • ShoGuin
    1 posts

    Still happening. Key stuck in geometry below floor level in the fort. I'm unable to progress any further.
    Either fix this (it's been 5 months) or provide means to reset this quest.

  • Ubi-Mark.
    Ubisoft Support Staff 2974 posts

    Hello @shoguin,

    Sorry to hear about your experience.

    I can see that this issue is currently being investigated by the development team and as soon as it's resolved, we will let everyone know through the patch notes. Can you please confirm if you have the current save uploaded to the cloud, by any chance? Additionally, can you please provide us with a short video, so we can pass it along to the ongoing investigation?

    Many thanks and if you have any additional questions, please let us know! Apologies for any inconvenience caused by this.

    Official Response
  • Diaz_3087
    2 posts

    Hey, after today's title update I finally got the key for the prison in my inventory and was finally able to progress my game. Took a long time but it's finally fixed.

  • Ubi-TheBerry
    Ubisoft Support Staff 5442 posts

    Thanks for the update @diaz_3087 , great to hear you've since been able to continue!

    Enjoy and if there's anything more we can help with, please let us know!

    Official Response
  • beatbox0121
    1 posts

    I'm still unable to progress in the courting the kings mission as I cannot get the King's pass to appear at all. It tells me the location of it and when I go there, no one has it. This has been a problem since the DLC came out. I have waited, patch after patch to see if it has been fixed yet it hasn't been fixed for me.
    I play on Xbox One and I want to send you my save file but I cannot acces the save files to submit it.

  • DixieDynamite
    32 posts

    I cannot progress the Courting the Kings Mission because the last guard that I need to kill to secure the prison spawned inside the wall of the fortress. There is no way to reach him and as such, all I ended up doing for an hour was running around searching with all the prisoners following my every step. This has now prevented me from moving forward in the story in a DLC that I paid for. I'm quite disappointed. I've attached a photo showing the green V where the guard is. He doesn't show up under Odin's site as red and the raven won't pick him up at all. I've reloaded the game and earlier saves with no success. When will a patch be put out to fix this as I see many people are having the same issue, which is breaking the entire DLC. Also, despite shrinking the photo, your site keeps giving an ERROR: Something went wrong while parsing server response, so I can't provide the photo or any video. I am playing on PS5. Please help!

  • natedog8998
    1 posts

    I'm having a problem with the courting the kings mission in Ireland and it's preventing me from progressing the game. I have got to the part where I have to get a kings pass by killing a guard and the first time I went there I killed all the guards and couldn't find the key. So I reset from the last save and when I went back no guards had spawned and the key was still not there. I have come back to the game multiple times hoping that it would be fixed but it still has not. Please help it's getting annoying as I have spent money on the season pass and can't access the content.

  • BuzzardBee
    11 posts

    @dixiedynamite I'm in exactly the same situation. Reloading earlier saves does nothing to change the issue. I manage to get the pass just fine. I acquire the key to free the prisoners and the moment I'm down below and say "I hope this key works" or something like that, I can clearly see the last guard up above stuck in the stone ramparts with no way whatsoever of reaching him or killing him. I'd already killed all other guards before freeing the prisoners. I even tried not doing that and waiting to go around on a killing spree after freeing them and there's still that one final guard trapped inside the wall.

    I mean, how the hell does this sort of thing continue happening in games to this day? You'd think someone would have figured out how to fix this sort of issue years ago since it comes up in nearly every single damn game released. Do they just cut-n-paste and not bother at all with testing this sort of thing because they know it's a crapshoot -- maybe the majority of players won't trigger this game-breaking glitch and it'll be fine and screw the handful of players who have their game experience ruined because they cannot progress any further? Is that the reasoning??

    It does no one any good to keep saying that the devs are aware of the issue and are working toward a solution when months keep passing by without any fix in sight. It's November 2021, folks, and this is still broken for some of us. This is just ridiculous.

  • Zorroman2
    1 posts

    @ubi-borealis I'm still having the issue where I'm unable to collect the king's pass. Here is a link to my in game video showing this. I included my inventory in the video to show that I don't already have the key either. The marker is visible, but Odin's sight doesn't reveal the key, and Synin doesn't reveal the location either. I've killed every enemy in the camp, even the ones outside of the area the quest marker is in. Still nothing.

  • BagongTipan
    2 posts

    @Ubi-Mark. I'm still having the issue. The key still is spawned inside the wall of the castle. I'm unable to continue the story

  • Ubi-Orion
    Ubisoft Support Staff 1363 posts

    @natedog8998

    Hey there.

    Sorry for the delay in getting back to you.

    Do you have a marker on your map for the key to collect or is there nothing at all? If possible could you provide images and/or video of this issue we could take a look at please?

    Official Response
  • AbyssHawk
    1 posts

    @zorroman2 Playing 2 days and already have same problem with this quest. This NPC with pass is not spawning at all.

  • ArmagedonGigolo
    1 posts

    @dixiedynamite You can wallglitch (running attack+bait) inside where the guard is stuck, kill him then just quick travel out. At least ubi programmers are consistently amateur...

  • Le.0
    1 posts

    I'm playing on PS4. The DLC is unplayable at the moment. "King's pass" cannot be located... help!

  • Tg1Star
    1 posts

    I’m having the exact same issue. Is there a way to fix it because I can’t continue on with the main story line otherwise

  • LadyFade
    2 posts

    Hi there.

    Was enjoying Druids greatly when trying to finish Courting Kings and the last guard I had to take out to clear the fort spawned in a wall.

    Cant progress etc. very disappointing. I’ve notified it has been many months since this bug was first reported.
    Would love if it could be fixed.
    thank you.
    A long time AC fan. 🙂

  • LadyFade
    2 posts

    @ladyfade just so you know I reopened the game today and the mission had fixed its self 👍🏻

  • Ubi-Oxavo
    805 posts

    Hey @tg1star, thanks for getting in touch. I apologize for the delay with my response. If I understand you correctly, you also can not collect the key in "Courting the Kings"?

    Could you please confirm for me that you have installed the latest game update and also the platform you are playing on?  I would kindly ask you to record a short video and send us a link so we can investigate this further. Please also make sure that your latest saves are uploaded to the cloud.

    Please let me know if I can help you with anything else.

Suggested Topics