Welcome to discussions

Quick Suggestions

  • UNSOLVED Unable to re-play Trials of the Morrigan / restore Trade Posts on second playthrough | POST HERE

    3 Likes/188 Replies/4761 Views
    Egomatik
    4 posts

    @ubi-mark almost a year later and still not even a pending fix on this? I would like a refund for The season pass and The game itself if this is still a problem in The end of The week.. I really love The game but these kind of issues is turning that love into The exact opposite

  • Egomatik
    4 posts

    @kingkoopa369 i just now fixed drumlish trade post and i had The same problem with The wolves that spawn in The house, i killed Every Wolf i could, fast travel to The nearest harbor, meditated, rode back to The trade post and killed The wolves again and that time it worked and now i completed that quest d, im gonna try lisburrow now

  • Egomatik
    4 posts

    Lisburrow and the rest seems to be impossible.. Even when i have the deed and cleared out the trade posts, everything is already built and logged as "Controlled" but the Quest itself is not completed and when you are at the trade post nothing happens.
    As i said, i want a refund for the game and the season pass.. it would be different if i bought a game and didnt like it, now i bought the game, loved it and then it just break.. we should be able to claim a refund for this when Ubisoft clearly cant fix the problem.

  • Egomatik
    4 posts

    @ubi-mark you seem to avoid my message tho, i want my money back for The season pass and The game itself if there still isnt even a pending fix for The trade post. It would be different if i bought a game and didnt like it, but i bought a game and The season pass and grew to love The game only for it to stop working for almost a year? That would be a valid Base for a refund.

  • Durden3141
    1 posts

    @ubi-borealis just adding to the thread as another user experiencing this issue. Finally bugged me enough to do some research and find out if it was weirdly expected behaviour or not. Thankfully I didn’t start my second play through until after the Trials of Morrigan was fixed.

    If there are any specific steps, procedures, or data I can provide to help the investigation please let me know and I’ll do my best to help out. Otherwise I will patiently await a future fix.

    Thanks for the support you provide, it’s a tricky job and I appreciate you doing it.

  • GamesGuruJr108
    3 posts

    I've also experienced the same issues re: trading posts already appearing as "controlled", even though I've yet to complete the deed quests to unlock them. Here's the link to my gameplay video:



    Really hope this gets fixed soon, as it's annoying to have the trade post quests in the list when they can't be completed. In addition to being unable to fast travel to trade posts other than the one in Rathdown, which was a main quest requirement anyway.

  • TheNorfolkian
    604 posts

    @bielik01 Congrats on finally getting that trophy knocked out after a long wait.

  • IMDiscoMan
    6 posts

    Any update on restore trade posts?

Suggested Topics