Welcome to discussions

Quick Suggestions

  • Taklishim
    21 posts

    @ubi-borealis I misundertood by reading through this thread.

    I thought the issue was:
    you get to Ireland on a subsequent playthrough,
    the trade post is already claimed,
    and producing goods

    You can find the deeds for the others, and even complete the Rathdown quest, but after Rathdown you can't turn in the deeds to "activate" the trade post because it's already claimed, active, built, producing goods.

    That is my issue, and apparently many others in this thread.

    Do we need to start a new thread for this, because regardless it seems on subsequent playthroughs trade posts are not functioning correctly for many people and has been this way for months (my experience)

  • Ubi-Borealis
    Ubisoft Support Staff 4636 posts

    The issue you're encountering is the issue being investigated within this thread, @Taklishim. I apologise for any confusion that has been caused.

    To clarify, we've received reports from players who have been able to restore the trade posts successfully during their first playthrough of "Wrath of the Druids." During subsequent playthroughs, however, the trade posts appear to be fully restored but cannot be reclaimed using deeds. Am I correct in understanding that this is the issue you have encountered?

    If this is the case, please would you be able to provide us with a video that shows the trade post appears to be restored, but is marked as unclaimed on your map (as if it wasn't fully restored). We can then forward this to the development team as part of the ongoing investigation.

    Thanks! 😊

    Official Response
  • Davorian0
    4 posts

    Hello, I am playing through AC valhalla for the second (or maybe third) time, and I am having (yet more) trouble with the Irish campaign. It seems like certain elements of progress from my previous playthroughs are persisting (like the trading posts) and I can't for instance set up any new trade posts, since they seem to look "already bought" and I acquiring the deeds to the trading posts doesn't seem to work. The quests for acquiring the posts remain in my log, but I can't complete them.

    I also can't redo any of the combat mysteries in the areas, like the altar combat trials.

    Are these things permanently stored in the cloud or on the account or something? Is this by design?

    This is very frustrating 😞 I would like to do a completely new playthrough and this element is preventing me from getting that "completion" feeling.

    If you know a way to fix it, or can fix it for me if I send you some saved game files, I would be greatly appreciative.

  • azullFR
    1737 posts

    your issues are under investigation by the Ubisoft Team,
    here is what @Ubi-Borealis 👍 wrote few days ago (August, the 25th) :

    • Unable to re-play Trials of the Morrigan
      • Status: Pending fix
      • Comments: The development team will be deploying a fix for this issue in a future update. Once we have more information to share regarding an ETA for the fix release, we will let you know within this thread and via patch notes in the News & Announcements forum.
    • Unable to restore Trade posts
      • Status: Under investigation (additional images/videos welcome)
      • Comments: The development team is currently investigating this issue further. Once we have any updates to share with you all from the investigation, we will let you know within this thread.

    this is from the Megathread (with more infos) there :

    Hope this will help you a little 🙂

  • Ubi-Mark.
    Ubisoft Support Staff 1823 posts

    Hello @Davorian0,

    Thanks for reaching out and I'm really sorry to hear about your experience.

    As @azullFR mentioned, these issues are currently being looked into. Thank you for sharing!

    I also merged this thread with our megathread for your better visibility of our communication regarding this issue.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know!

    Official Response
  • CursedBard
    2 posts

    I remembered something that may help with the broken trade post issue. It was all good in my first playthrough. But at the start of a new game, some of the items you normally purchase through Azar are already immediately in my inventory, including settlement decorations. She still has them for sale once you go to Ireland. Maybe it is more about the records Ubisoft keeps on their players that is making Wrath Of The Druids unable to be played through a second time? Like how they keep track of opals and opal purchases, for instance?

  • Taklishim
    21 posts


    I have shared access to the game files referred to in the following videos in Support Ticket 15278233.

    In an effort to capture the trade posts being completed and active already on a subsequent playthrough I started a new game roughly 8 hours in. I finished the first pledge to open up Ireland, went to Ireland, played through the quests until Rathdown Takedown and as you can see in this video I rode to Rathdown and the storehouse and Lodging are already built, I control the post and it's generating goods, but I haven't done a thing! I didn't clear out the bandits, didn't finish the quest.

    Second half of the video is me immediately riding to Lidsurrow to see what was up there and you'll see by the end of the video it's already controlled, active, and producing goods. I know from experience if I went out to the swamp nearby and grabbed the deed from Ichroe Bog I wouldn't be able to turn it in since it's all working already.

    So I started another game, about 10 hours in this time and level 102. I just finished the blockade quest and Azar is ready to take me to Ireland when I noticed on the table behind him the "check on trade chest" icon. I clicked on it and you can see i'm at max storage for all of the trade goods. I took a video of this.

    I went ahead and saved this game in a different file which is in my support ticket.

    I did go to Ireland on that game and yes, everything was built and up and running.

    I included both game files from the above videos and my last subsequent playthrough where the trade posts worked as intended in the hopes there's something in there that can help.

    I also tried a couple things;

    1. Turned off network access on my PS4 during all Azar quests - didn't help
    2. Turned off network access during the WoD launch quest - didn't help

    Wish I knew why my previous subsequent playthrough worked fine, but the these two didn't.

    Is there anything else I can provide that will be helpful?

  • Ubi-Nacho
    Ubisoft Support Staff 1003 posts

    @taklishim Hi there,

    I've been able to check this support ticket for you, and I can confirm everything is intact.

    Everything you have provided so far is very helpful! Should the support team need any further information they'll be sure to let you know. Someone from the team will be able to respond to your ticket shortly. You may find that the team would ask you to carry out some troubleshooting, however if there's anything that you have completed already, you can just let them know.

    Thank you.

    Official Response
  • bielik01
    Original poster 1306 posts
    This post is deleted!
  • bielik01
    Original poster 1306 posts

    THANK YOU! After three and a half months I was able to complete Wraith of the Druids.

  • Ubi-Froggard
    Ubisoft Support Staff 1227 posts

    @bielik01 Glad to hear that! Thanks for letting us know 🙂

    Official Response
  • dexterslef
    3 posts

    It wont let me finish the quests so they're just stuck in my quest log and map. I have to use another whole Xbox account to do them.

  • Ubi-TheBerry
    Ubisoft Support Staff 1370 posts

    Thank you for sharing this @dexterslef , sorry to hear you had to use another profile to complete the quest, we'll pass this onto the team to make them aware.

    If there's anything more we can help with at all, please let us know!

    Official Response
  • KingKoopa369
    6 posts

    @ubi-milky no I deleted my original playthrough and it didn’t resolve the issue…

    The new update allowed me to complete the 2 Trials of the Morrigan I had done on my first playthrough and allowed me to gain the Drumlish trade post (the mission marker finally appeared and I had to kill 2 wolves that spawned inside of one of the outpost upgrade buildings I had purchased in my first playthrough with the Piercing Shot ability) but I’m still unable to get Lisdurrow and Athlone, they say “controlled” and I had bought all the upgrades for them on my first playthrough but I can’t complete the missions to make them fast travel points

  • Ubi-Borealis
    Ubisoft Support Staff 4636 posts

    Thanks for sharing more of your experience with us, @KingKoopa369.

    The development team are still investigating why some trade posts show as controlled despite not being restored during subsequent playthroughs. This means that a fix for this issue was not deployed in TU 1.3.1. I apologise for any confusion or disappointment caused by this. Here is an updated status of the investigations that are being discussed within this thread:

    • Unable to re-play Trials of the Morrigan
      • Status: Resolved
      • Comments: The development team deployed a fix for this issue in TU 1.3.1. If you are still encountering trouble with the Trials of the Morrigan, please don't hesitate to reach out so we can investigate further.
    • Unable to restore Trade posts
      • Status: Under investigation (additional images/videos welcome)
      • Comments: The development team is currently investigating this issue further. Once we have any updates to share with you all from the investigation, we will let you know within this thread.

    Thank you! 😊

    Official Response
  • Agulair
    1 posts

    Ive recently started a new game and comenced the "Wrath of the Druids" DLC. starting the quest that requires me to obtain access to the first trade post "Rathdown". I complete and claim the trade post and start to gather the others but on the map they all say they are claimed and all upgraded, im reaping the resources from them but the map icon appears white and i cant fast travel to any of them. Also, after continued clearing of the map, finding the deeds to each Trade Post, it triggers the missions to claim them.

    In short im unable to complete any of these missions that trigger after finding the deeds in exploration because the game thinks ive already done it.

    I have completed this DLC in another saved game without this issue.

  • Ubi-Borealis
    Ubisoft Support Staff 4636 posts

    Hello there @Agulair! Welcome to the forums 🙂

    I'm sorry to hear that you've been unable to restore trade posts during your subsequent playthrough of Wrath of the Druids. I've moved your report to our ongoing Megathread about this issue. The development team are aware of this issue and they are currently investigating further. I've passed on your report so they can take a closer look at this.

    We don't yet have any updates to share from the investigation at this time. Rest assured that as soon as we have any new information available about restoring trade posts, we'll let you know within this thread.

    Thanks! 😊

    Official Response
  • Quasar108
    6 posts


    I have an issue with the trading posts. When I approach them there are other folks fighting beside me. The trading posts are already upgraded. I don't have to search for the deed. I don't receive the quest to find them. And above all I can't use the trading posts to fast travel. I couldn't find any resolution to this problem in the forum. Could you help me?

  • Ubi-Milky
    Ubisoft Support Staff 1378 posts

    Hello quasar108 thank you for getting in touch with us.

    Can you let me know what locations on the map/area's you have this issue with trading posts?

    Can you remember what you did in-game or what quest you completed, before this issue started occurring?

    Do you have a video clip to demonstrate what is happing exactly?

    Official Response
  • Quasar108
    6 posts

    @ubi-milky Hello Milky,

    It occured after I picked up the mission from Azar regarding the first trade post. First I sailed to the Lambay Abbey, then I went to Rathdown. When I arrived the merchants were already there fighting the bandits. Once I defeated the bandits evereything were already built. It was the very same situation in Drumlish and Lisdurrow. Although now I can use Rathdown to fast travel, but not Drumlish and Lisdurrow. Rathdown's icon on the map is also full coloured but not the other one's. This is the first time this problem occures to me. I have already liberated every trade posts in previous games. I also verified the game files. If I make a video about this where can I upload?

    Yours sincerelly,

Suggested Topics