Welcome to discussions

Quick Suggestions

  • Ubi-Orion
    Ubisoft Support Staff 763 posts


    Hey there!

    Thanks for the info. I would host the video somewhere first and then provide us with a link to the video if possible. Our file upload system on support cases has a file size limit so a link would definitely be preferred if possible as it might be difficult to compress it enough to allow it to upload. Cheers!

    Official Response
  • Florian558
    1 posts

    @quasar108 Ich habe das selbe Problem.

  • Ubi-Orion
    Ubisoft Support Staff 763 posts


    Hey Florian.

    We're only able to offer support in English on this forum I'm afraid. If you're able to translate for us we'd be happy to assist or you can find the German player support forum here. Thanks!

    Official Response
  • Quasar108
    6 posts

    @ubi-orion Dear Orion,

    I uploaded on youtube:

    But I encountered a new problem. As you can see in the video, I sync with the viewpoint, and after that the Athlone trading post is already unlocked. Previously I had to go to the trading post and fight off the bandits to get a trading post unlocked.

    Yours sincerely,

  • Ubi-Woofer
    Ubisoft Support Staff 1268 posts

    Thank you for the video you provided, @Quasar108.

    Having read your previous posts, I just want to clarify - is this not your first playthrough of the game and its expansions? Have you already played through them before, and taken over the trading posts before, as that's what I understood from you writing:

    This is the first time this problem occures to me. I have already liberated every trade posts in previous games.

    If so, I'd like to make you aware that we're investigating an issue currently whereby reloading a save after a post has been built, or else playing a new game after claiming the posts in a previous playthrough, can prevent them from being claimed again - even if you acquire the deeds.

    We'll keep affected players updated with new information as we receive it, but for now, thank you for any additional information you can provide to us as well! 🙂 I'll share your video with the developers for them to review as well.

    Official Response
  • Quasar108
    6 posts

    @ubi-woofer Dear Woofer,

    Yes, you understood it correctly. I have taken over the said trading posts in my previous playthroughs. I think twice. Do you have any information regarding when the bugfixes will be due?


  • Ubi-Keo
    Ubisoft Support Staff 2777 posts

    @quasar108 I'm afraid we have no further information at this time.

    Please keep checking the known issues list and the news and announcements page for updates.

    Official Response
  • cunningham1191
    7 posts

    Currently having the exact same issues with the trade outposts.

    This is my second playthrough, both on the XSX and the outposts are fully upgraded before I even get there. However, they remain white on the map and are unable to fast travel to, with the exception of Rathdown, which is both green and can be fast traveled to.

    I mean, on one hand, this brilliant as I can get Dublins trade level to 5 bloody quick! On the other, the white circles are annoying!

    Haven’t found any of the Trials yet, so not sure if that's still broken or not but will update if they are.

  • Ubi-Mark.
    Ubisoft Support Staff 1811 posts

    Hello @cunningham1191,

    Sorry to hear about your experience.

    I can see that this issue is still being investigated and as soon as we have an update, we will let everyone know through this thread and the patch notes. I also forwarded your report to the ongoing investigation.

    Apologies for any inconvenience caused by this and if you have any additional questions, please let us know.

    Official Response
  • odinmoon
    2 posts

    Very disappointing. No bugs when it comes to collecting cash from us.
    No excuses for these bugs. This game was ruined from the start sadly.
    Great game, great idea, poorly managed.

  • Egomatik
    4 posts

    @ubi-mark almost a year later and still not even a pending fix on this? I would like a refund for The season pass and The game itself if this is still a problem in The end of The week.. I really love The game but these kind of issues is turning that love into The exact opposite

  • Egomatik
    4 posts

    @kingkoopa369 i just now fixed drumlish trade post and i had The same problem with The wolves that spawn in The house, i killed Every Wolf i could, fast travel to The nearest harbor, meditated, rode back to The trade post and killed The wolves again and that time it worked and now i completed that quest d, im gonna try lisburrow now

  • Egomatik
    4 posts

    Lisburrow and the rest seems to be impossible.. Even when i have the deed and cleared out the trade posts, everything is already built and logged as "Controlled" but the Quest itself is not completed and when you are at the trade post nothing happens.
    As i said, i want a refund for the game and the season pass.. it would be different if i bought a game and didnt like it, now i bought the game, loved it and then it just break.. we should be able to claim a refund for this when Ubisoft clearly cant fix the problem.

  • Egomatik
    4 posts

    @ubi-mark you seem to avoid my message tho, i want my money back for The season pass and The game itself if there still isnt even a pending fix for The trade post. It would be different if i bought a game and didnt like it, but i bought a game and The season pass and grew to love The game only for it to stop working for almost a year? That would be a valid Base for a refund.

  • Durden3141
    1 posts

    @ubi-borealis just adding to the thread as another user experiencing this issue. Finally bugged me enough to do some research and find out if it was weirdly expected behaviour or not. Thankfully I didn’t start my second play through until after the Trials of Morrigan was fixed.

    If there are any specific steps, procedures, or data I can provide to help the investigation please let me know and I’ll do my best to help out. Otherwise I will patiently await a future fix.

    Thanks for the support you provide, it’s a tricky job and I appreciate you doing it.

  • JayBug79
    2 posts

    so i just got to doing a second playthrough of the Ireland DLC with a different Eivor entirely

    (I did the female first cause i did the let the fate's choose option at the begging)

    But apparently the trade post are still not unlocking correctly, i get all the materials in my chest next to Azar, I just can't complete the quest or use the fast travel option. As for the trials of morigan I have done 2 so far and have had no problems with them activating.

  • Ubi-Froggard
    Ubisoft Support Staff 1155 posts

    Hey @jaybug79

    Sorry to hear you are having an issue with this. I'm just trying to see if this is a known issue already. Can you just clarify, is it that the Trade Post appears as fully built, but not claimed? If so this is a known issue we have reported.

    Official Response
  • GamesGuruJr108
    3 posts

    I've also experienced the same issues re: trading posts already appearing as "controlled", even though I've yet to complete the deed quests to unlock them. Here's the link to my gameplay video:

    Really hope this gets fixed soon, as it's annoying to have the trade post quests in the list when they can't be completed. In addition to being unable to fast travel to trade posts other than the one in Rathdown, which was a main quest requirement anyway.

  • TheNorfolkian
    828 posts

    @bielik01 Congrats on finally getting that trophy knocked out after a long wait.

  • jorisgoud
    1 posts

    I am replaying Valhalla for the second time, and once I started the Wrath of Druids for the 2nd time, I saw a variety of anomalies relating to trading posts, trading items and bugs with missions, it seems that trading post enhancements are maxed as soon as I freed the first one & trading items in the chest were maxed out with all items. What I think is happening is that some data from my first playthough is populated in my 2nd playthrough and creating some issues with the trading post related missions, ie I cannot unlock the 2nd trading post.
    Let me know if I need to provide a save file or additional information

Suggested Topics