ubisoft discussions

Quick Suggestions

  • UbiExcellent
    756 posts

    @lukkytass-toxic Greetings! Thanks for reporting this issue you're having with this mission. Would you be able to go into more detail or send over a video showing what happens when you try to complete this mission? Once received, I'll be happy to investigate further!

  • Skailon
    2 posts

    Same problem. Literally unplayable. No advices worked for me

  • Yoan_the_Red
    2 posts

    The third stage of the Cruel Destiny Boss fight on PC, where you are tackled into a pit, is bugged to the point where I cannot continue to play the game in any way. I have seen that a lot of people, regardless of platform, have had this same issue. I have tried every solution proposed on this forum to fix this, from verifying files, running as administrator, turning all graphic settings to low (I typically run on High settings), and I have even uninstalled and reinstalled the game. Nothing. Any other fixes I should try? Or better yet, when can we expect a patch to fix this issue? The game is unplayable as a result of this this bug and it is very disappointing.

  • juno.na
    1 posts

    @oropher333

    me too. i have same problem.

    so i just want refund.

    i dont want to continue the game.

  • Ubi-Swaggins
    Community Manager 437 posts

    Hey folks,

    The team are aware of this particular issue and are looking into it further.

    If you are encountering this problem, please contact our support team on our website and provide a copy of your save file. It will help the team in getting to the bottom of this issue.

    Official Response
  • isaacagudo97
    1 posts

    While im fighting kjotve in the single combat, and he push me of the platform, there is a loading screen, when the game loads, my character is just laying on the floor and i cannot get up, no matter what i do, i cant move.

  • originalphillip
    1 posts

    Same, tried all graphics settings recommended. Tried verify installation, geforce experience optimize and just waiting for it. Nothing works. Apparently I can't get a refund because I played more than 2 hours? This is really pathetic, as is the lack of feedback on this issue.

  • LeGueiz
    4 posts

    Same for me.
    Eivor just laying in the mud waiting for better times.
    4 days since first post and no admin taking care of the problem... what a waste of money!

  • LeGueiz
    4 posts

  • Alpha_Chiken
    1 posts

    @ubi-spud I tried the workaround but I'm still laying on the ground watching two sheildmen trying to hit me. At least the sheildmen can move though.

  • Yoan_the_Red
    2 posts

    @ubi-spud Still nothing has worked. I've tried every workaround posted here and nothing. I even uninstalled and reinstalled the game. Nothing. When can we expect a patch that allows us to play the game? This is on PC by the way.

  • Spirex2001
    2 posts

    The game Assasins creed Valhalla is literally unplayable, I am in a fight with this first boss called Kjove, he rushes me of this cliff thing and then im stuck, Eivor doesnt move and so doesnt Kjotve either. I can't undo the mission and I always get in the same bug all the time. I demand a refund of the game since I cannot play it. And also I can't send them a support message either, I think this is a cash grab tbh, I cant put my screenshots because they demand MSinfo so it takes up all the space is the report. Give me my money back or im suing. My gamertag: Spirex2001

    Specs: 
    i5 6600k
    GTX 1080 
    SSHD: 2TB
    SSD: 500 GB

  • DreadGrrl
    165 posts

    @spirex2001
    While I understand the sentiment, do you have any idea what the costs to sue Ubisoft would be in small claims court? The filing fee would be more than what you paid for the game (many times more), and that would just be the start of the associated costs.

    I’ve had to sue people in the past, and it has mostly been to prove a point. What we were awarded by the court certainly didn’t make the endeavour worthwhile.

    Just get your credit card company involved.

  • Spirex2001
    2 posts

    @dreadgrrl Yea I know, I wrote this when I was furious. Here's a video of the bug:

  • chrisolaus
    6 posts

    @isaacagudo97 Yeah got the same issue for 3 days now... So annoying 😞

  • chrisolaus
    6 posts

    When ur fighting Kjotve he's grabbing you and charging into a pit a loadingscreen occurs.
    Afterwards the character's (Eivor) stuck on the ground, cant move or anything.

    Tried a few fix that other players said would work but without any succes.

    Hope we get a bugfix for this asap. Im stuck at this point and have been now for 3 days.
    Kinda disappointing tbh..

    /

    Chris

  • kneef77666
    1 posts

    @chrisolaus

    Hi there,

    I had the same issue and none of the fix here worked, so i tried one thing : disable master volume and : it worked !

    I really hope this works for you too, i know how this bug is annoying.

    Matt.

  • ArtoriosVII
    1 posts

    Nothing happens after I'm knocked into the pit, I lay there and can't move and kjotve sits there looking like he's having a nervous breakdown

  • chrisolaus
    6 posts

    @kneef77666 Oh my god! It really works 😃

    I woulda never thought about disabling the master volume.

    Big thanks mate, cheers!!

  • Skailon
    2 posts

    Reposting to update for developers:

    in the quest 'A cruel destiny' you're supposed to kill the big bad boss.
    However, after a while, he storms you and runs into a pit with you over the shoulder.

    This triggers a long loading screen for me and then loads in with my character on the ground, the boss just hunkering a bit away, everyone else looking at us.
    Nothing happens, no controls react and there is no audio playing except for the background music for the fight.

    This makes game literally unplayable. No patches since day one patch. I bought a subscription and clocks are ticking, but i cant even progress. No workarounds works for me. If i set the minimum settings, game starts loading even longer. At maximum settings it doesn't work either.

Suggested Topics