ubisoft discussions

Quick Suggestions

  • Smetanol
    3 posts


    By putting my graphics settings to very high, putting 100% resolution scaling and native resolution 1920x1080 (and leaving capped 30 fps by mistake) has made me able to progress past second block at the england camp.

    Loading was much quicker, though I did catch characters shuffle noises abit (I also do notice some strange shuffling noises during initial start of the game when game warns about auto save feature)

  • theangelbelow
    1 posts

    @ubi-spud Still having this issue. I've tried the work around mentioned in this thread, but now I'm getting stuck on the loading screen that you can move around on. I can't even get back to the fight to see if it worked.

  • MilkyBrownAlex
    1 posts

    Utter joke.. honestly... I tried the workaround but still nothing? fed up with this every time I buy a ubisoft game something always goes wrong. cant even get simple things right!!!! embarrassing

  • Riki_Martini
    9 posts

    Same bug here. I'm able to load into the pit where I'm lying on the ground and sometimes minion NPCs are attacking me, doing no damage, and Kjotve is just standing still in the pit. I'm getting sound though, and sometimes the NPCs will be taunting.

    Earlier in the fight, before the charge, after reloading an autosave Kjotve's health bar was in the center of the screen instead of the top, but that only happened once.

    Get up Eivor...get up...

  • Riki_Martini
    9 posts


    I tried to turn the graphics to Low, VSync to Adaptive, and the Scaling to 50 from 90 and that somehow successfully triggered the cutscene that let the fight continue. Weird.

  • Riki_Martini
    9 posts

    I also think it's a programming mistake, but in the pit on the side towards the fortress wall, you can get the Discovered Location event popup for the fortress.

  • rgallilei
    1 posts

    Same for me stuck after loading screen when the boss throw me down to the pit

  • UncleOleg97
    3 posts

    Same problem.
    GTX1060 6Gb

  • Costochondria
    2 posts

    Im having all of the issues mentioned in this thread. We've all noticed the long dialogue load times too. My theory is that the loading is bugged out, so it tries to play the cutscene when loading is 'done' but in reality we still have the loading screen. So when the loading screen finally goes away, the game state is stuck where it would be while we're about to watch the cutscene, and it can't restart the scene, so we're just screwed.

  • CountWhackular1
    4 posts

    @fusrodavros I have the exact same problem. Even reinstalled the game and still the same thing happens. Spent 60€ on a game that I have only played for 3 hours. Does anyone have a fix for this?

  • Chuvisco88
    2 posts

    I am currently stuck in the midst of the fight against Kvjote.
    First I died and the cutscene with Odin loaded, then I attacked Kvjote until he grabs me and runs through some edge.
    The screen goes black with the loading spinner icon at the bottom.
    After a moment I hear some talking whilst still having the black screen.
    Half a minute or so later, the black screen vanishes and I am back in the game.
    Sometimes I end up stuck lying on the floor with Kvjote standing a few meters away.
    Other times I am standing but can't move.
    And sometimes I am being attacked without taking damage, but still unable to move.
    What can I do to fix this?

  • Sarricakes
    1 posts

    Hey! My SO has been struggling with the exact issue all evening - He solved it!
    Go to your graphics settings and turn 'World Detail' to any setting OTHER THAN low! Try the fight again 😄

    Hope this helps!

  • woweeitsali
    1 posts

    @ubi-swaggins hello, I'm having this same bug and I went to your support website and it won't allow me to access live chat after filling in the support form.undefinedundefined

  • Marcel31221
    1 posts

    Hay, can help me I have a problem, you have relatively at the beginning the boss fight against the guy who murdered your father, then he jumps down a little cliff with you in the middle of it and there starts my problem like he jumps down with me it starts to load up while I have a black screen and after that I can't move anymore , but I can still look around with the mouse and so who can help me with the problem?

  • vencelj1996
    3 posts

    @uncleoleg97 yea its not in graphics probably belive me or other part of the game wouldnt work too. Probably sopme bug they need to fix i hope soon i wanna play this. Btw i have gtx 1660 ti 6gb .

  • VulgarButFluent
    1 posts

    @oropher333 having a similar issue at the same point, the fight goes well, we enter the third stage where we go down into the body pit and then all the AI goes inactive and im stuck on the ground unable to move or get up. birds and rats are moving, Kjotve is breathing heavy in the corner, but i cant do anything.

  • belarifon
    1 posts

    I can't get the fight to activate, I talk to the guy in the tower, to the cut scene, and at the end they walk off, camera stays fixed and the snap back to standing at the table and it just stays like that until you hit a button. The quest says my fate lies behind the gates of his fort, I go there and nothing happens, there also isn't a waypoint for the quest... I tried reloading an autosave, it still doesn't work, I have turned it of and started the game again... I'm at a loss on how to fix this... I can't progress in the game... I better not have to restart with a new save this is freaking dumb!

  • ppehrson
    1 posts

    None of the suggested settings work for me, neither in combination nor separate.

    This is NOT okay for a game with this price tag!!!

  • GardenGnome35
    2 posts

    I have now just encountered this issue as well. Very frustrating

  • StolenSteel
    1 posts

    Same issues, waiting for any updates to fix it.

Suggested Topics