Welcome to discussions

Quick Suggestions

  • Doomgrinders
    1 posts

    If killed by Kjotve, the fight will not resume after brought back by odin. Can't attack and he just stands there.

  • murphsauce
    2 posts

    This company is a joke. Pathetic that games with teams this large release games so broken that players can't even get to the meat of the game

  • oropher333
    10 posts

    After i died in the last phase of the Kjotve fight, and respawned.
    All i had to do was shoot a few arrows when he started to swing a corpse around and he started trying to run up the wall, and boom the cutscene happened.

  • Mikko00
    2 posts

    @mikko00
    Got it working after verifying the game files again and letting GeForce Experience to optimize the game

  • leonpolarny
    2 posts

    I have the same problem here. I tried 6 times. I don't know what to do next...

  • leonpolarny
    2 posts

    Today I tried several times on different settings. I tried on low details = nothing changed. AV closed = nothing. I verified all installed files in uplay before I started game = nothing. Even waiting for half an hour doesn't work. I'm devastated.

    Sometimes Eivor is lying on the ground.
    Sometimes he is standing. Sometimes he is biting by one or two guys and he can't move.
    Kjove always standing near the wall arounding by moving rats.
    I can as the rest of You move camera around Eivor but I can't fight and do anything.

  • ibenaxelson
    3 posts

    @chiconspiracy have the same issue, i have tried what feels like everything. i am thinking of re-downloading the game, but i am not sure if it will work. its a truly gamebreaking bug. hope they fix it soon. im already in love with this game 😧

  • ParakeetPowers
    1 posts

    i have the same issue i cant seem to find a fix please let me know if you do
    thanks

  • Ubi-Swaggins
    Community Manager 429 posts

    Hey folks,

    I am sorry to hear that you are encountering this issue.

    It has been raised to the team and they have requested save files of affected players to help them look into it.

    If you can do so, please send us a copy of your save file via our website.

    Official Response
  • Smetanol
    3 posts

    I also had same problem - after boss grabs you and runs into the pit with you screen goes black and game attepmts to load in the cutscene with enemy on walls cheering, but that doesn't happen and game hangs.
    this bug also happened to me in other places - for example when you right after reclaiming your ship land at first friendly settlement with a quest of choosing commander in hand to hand combat, right after you finish following quest giver and before you get competitors described in a cutscene.
    I managed to circumvent the bug by placing resolution scaling to 50%.
    I also noticed that game consumes all available CPU resources - capping my CPU usage at 100%. That doesn't happen on other games.

    My processor: Intel Core i5-3570 overclocked to 3.70 GHz
    My GPU: NVidia GeForce GTX 1060 6GB (ti)
    Game is installed on 2 HardDrives with Raid 0
    My motherboard: Gigabyte Z68AP-D3

    PS: Task Manager doesn't say which GPU is used by AC:Valhalla, but in options menu Game detects my NVidia GeForce GTX 1060 6GB

  • VelvetWomble
    1 posts

    Hi,

    I get through the first part of the quest just fine - then when Kjotve picks Eivor up and we fall into the pit, I have a very long load, after which it loads, but Eivor is lying on the ground and Kjotve is just standing still, and nothing else happens. The second time I tried to load in, one of the Vikingr starts attacking me but I take no damage, and am still just lying on the ground.

  • Caldswell
    1 posts

    Just putting another fix which worked for me. Simply put the game in windowed mode and Adaptive Vsync. Zero problems once i done that.

  • Geodox1
    1 posts
  • Martin.SG
    1 posts

    I have the same problem. I don't konw what sould I do.

  • Dave_the_human
    5 posts

    I'm having the same issue. I've also been having incredibly long loading screens when trying to talk to NPCs. I wonder if it is related? Is anyone having the Kjotve fight issue experiencing the same? I read somewhere it might be an issue to do with cutscenes loading improperly but am unsure if that is the cause.

  • sokka75020
    1 posts

    HI, I'm having the same issue. The loading time is really very long when Kjotve's health is at 50% and he takes me to the arena. Then the 2 characters are frozen and no action is possible. I play the PC version. What can I do please ?

  • murphsauce
    2 posts

    None of these workarounds have worked for me. Still stuck after many attempts

  • Braan2011
    1 posts

    I have this same issue (PC version) and it is completely blocking all progress in the game. I have also noticed the long loading screens sometimes when talking to NPCs that Dave_the_human mentioned, so it could be related like he said.

  • vencelj1996
    3 posts

    Hello

    I would like to ask about the bug or somthing that i have while fighting Kjotve. Everything runs normal but after he throws us down the pit after the black screen i get the problem and i cant continue the game.After that i can still look around and music is playing but characters are not moving. I will send u the immage in attachemnt folder so u guys can see in what position im staying. Please for fast respond and repair i really enjoy the game and this is kinda ruining my gameplay 😕 Btw i allready try to switch off motion blur and tried to verify files on ubisoft and epic games.undefined

  • Smetanol
    3 posts

    I caught similar bug again and it seems I am stuck for good now.

    After arriving to England and freeing 2 prissoners in a camp. during the cutscene Siggurd says "Others are here, come". after that game goes into same dark screen with loading animation, I can hear shuffle of few people, after a minute or 2 of loading game removes loading black veil and all the characters of cutscene, except for prisonners are standing here, I cannot move, open map or call raven.

    I assume it happens when there are many NPC to be manipulated and game/my PC cannot complete placing them in given limits, which causes soft lock.

    Other quirk I noticed, which may be same bug but with no soft locking - near the town of king of norway there's a fly agaric mystery mission. Once you eat it game spawns 4 characters to battle you. In my game it takes few seconds to place them, enough time to reach them on foot. when they are just placed, all of them have same body build, but shortly after - (in 3 seconds or so) their body build, their armor and weapons change to appropriate... and after that they wreck me cause they are 250 challenge rating, while I am 25.

    Putting game to windowed mode with lowest available resolution on lowest graphics doesn't let me progress.

    I will attempt adaptive Vsynch, but I doubt this will change anything. if anyone else finds any other work arounds, feel free to post them here.

Suggested Topics