Welcome to discussions

Quick Suggestions

  • KorianaD
    1 posts

    I noticed while in Jotunheim I no longer had my second weapon. It has disappeared entirely. I saw others report this over a week ago in other forums. When will this be fixed? I love the game, but I cannot have my weapons disappear on top of the wall clipping, horses bike pedaling on their hind legs until my game crashes, boats dueling and dancing in the air, quest lines just noping out of existence to prevent any progression, and various other hilariously awkward graphical bugs. Please fix, I want my Raider Axe back. It had my good runes, was maxed Flawless.... it was my leftie.

    Sorry for typos, this is from my phone.

  • WoholF.SEGAF
    1 posts

    My axe dissapeared during a mission where you help Rollo escape some guards, I thought I would get it back after but I never did did this hapen to anyone else?

  • zopgy
    2 posts

    lost my blacksmith hammer at the very same place

  • Mr.Highland
    2 posts

    @prasalm i have the samme issue. I just lost my mythical raiders axe yesterday, and today i lost my housecarl axe...
    it seems to happen when i am using my torch. its like the game replaces my weapon with the torch, and when i throw it away, the weapon isnt coming back...

  • Mischievous_06
    1 posts

    Herkese merhaba!

    Bugün Ubisoft destek temasa geçti. Benim Scimitar kılıç ve Varin balta oyunda kayboldu. Benim Varin balta yükseltme sırasında kayboldu, ben opal ile benim Scimitar kılıç aldım ve 1 veya 2 saat sonra kayboldu. Yetkili kişilere haber verileceğini söyledi ama benimle aynı sorun alabildiği ihtimaline karşı konuyu burada açmak istedim.

  • Raynorss
    2 posts

    during my gameplay suddely several of my wepond just suddely dissapear from my inventory weponds like Excaliber, Varin's Axe and more but can't recall name of it. this happend when I was doing missions, combat roamming around this need to be fixed!!! and I also ofc want my weaponds back Please!!!

  • Orthruss
    1 posts

    I've spent a lot of time and resources upgrading weapons I wanted to use just for them to randomly disappear out of my equipment slot and inventory nowhere to be found. This makes me not want to play the game anymore as it only happens to equipment I actually want to use. Why play if I just risk losing items I've worked hard for. this needs to be hot fixed immediately! It's literally breaking the game for me.

  • GrimReaper4884
    1 posts

    I lost my axe without doing anything just checking my inventory I found out that I don't have it.

    1 posts

    My fafnir's fang has also disappeared 😞

  • Dnkrish
    1 posts

    I lost my Excalibur and it doesn't show up in my inventory, i tried fast travelling, restarting the game then i found on reddit that its a bug where if you have the dual swap perk (shift +T) sometimes it brings up the torch which is key-binded to T as well and throws your weapon on the ground without an option to pick it!
    I have contacted the support team via submitting my case and it still didn't get solved. I provided proof as well that i earned the loot. Even though i completed the main story and Ragnarok Storyline, I still need my loot because I'm interested in playing this game's DLC.
    Looking forward for some immediate help.

  • Bing0K1ng
    18 posts

    My Varins Axe is suddenly completely gone from inventory. I had it upgraded to legendary and based all the game on using it. How to get it back?

  • NotThatDroid
    1 posts

    Dual-wielding two Dane axes and noticed that one was missing during my gameplay suddenly. Seems to be a common bug when dual-wielding and possibly linked to when getting a torch out and/or swapping hands. Now my Dane axe Sepulcher, is completely missing (tiered high, missing great 2 great runes and one "triangle" (I forget the type) weapon rune. However, I can still see it and give it to my Jomsviking. Please see screenshots for reference of my inventory vs my Jomsviking.

    I spent a lot of time hunting down the resources for this weapon to have it gone and built my character and upgraded my armor to be a great weapon dual-wielder. Now I'm both missing the weapon I spent so much time on and am now scared to dual-wield weapons I care about.

    Loading previous saves show the weapon as still missing even though I'm positive I had it during those saves. Is there a way to recover the weapon in-game, reobtain it from loot, or have it recovered via my Ubisoft account?undefinedundefinedundefined

  • reycopuresc
    1 posts
    I tried to recover through the salves and it was not possible to restore, where I had the weapon.

    SEPULCHER AX + 6 on 2 stones. N
    Note that it was gone only when I upgraded the item at the blacksmith in the camp, but it had gone through some self-rescue points.

    Tentei recuperar através dos salves e não foi possível restaurar, onde possuía a arma.

    SEPULCHER AXE + 6 in 2 stones. N
    Notei que tinha sumido apenas quando fui fazer upgrade no item no ferreiro no acampamento, mas tinha passado por alguns pontos de auto-salvamento.

    In Morning - In Asgard with weapon losted
    Location Weapon Drop
    Build Type

    Absence of visualization in the inventory, but the customized viking of the fleet has access to the axe.

  • snoddas1099
    10 posts

    Missing weapon, blacksmith axe. Google the problem and many have the same issue. So what is the point to play when my upgraded gear vanish? There is no option in game to throw away a handheld weapon. Must be a bug involved when throwing torches.
    Any why to get it back or must I restart far back in saves? 
    This is not OK....

  • Avve1000
    1 posts

    I lost mine too, i dont remember where but it was around the same time as your incident. Very annoying

  • Romanos2314_GR
    1 posts

    I lose some of my weapons too anyone can provide us a resolve?

  • Ptm2214
    1 posts

    So last night I was playing and lost a mythical axe as well as a mythical spear both with full runes and fully upgraded. They are no longer in my inventory and neither are the runes. Any ideas? Is there a way to fix this? Thanks

  • Mr.WaffleMan24
    2 posts

    I've lost Varin's axe and HouseCarl's axe for no reason? I don't want to restart my whole 15 plus hours of game to get it back can you guys pls fix this -_____-

  • Mr.WaffleMan24
    2 posts

    there is a glitch in the game where if your weapons and then switch to your torch and throw away the torch, the weapon gets deleted from your inventory. I already lost 3 weapons -____- . This glitch has been around since release don't think Ubisoft cares tbh

  • doomkoch
    1 posts

    Same Problem here, but its bugged on every past savegame, no matter if 8 hours or 45 hours of playtime

Suggested Topics