Welcome to discussions

Quick Suggestions

  • reycopuresc
    1 posts
    I tried to recover through the salves and it was not possible to restore, where I had the weapon.

    SEPULCHER AX + 6 on 2 stones. N
    Note that it was gone only when I upgraded the item at the blacksmith in the camp, but it had gone through some self-rescue points.


    Tentei recuperar através dos salves e não foi possível restaurar, onde possuía a arma.

    SEPULCHER AXE + 6 in 2 stones. N
    Notei que tinha sumido apenas quando fui fazer upgrade no item no ferreiro no acampamento, mas tinha passado por alguns pontos de auto-salvamento.

    In Morning - In Asgard with weapon losted
    undefined
    Location Weapon Drop
    undefined
    Build Type
    undefined
    Blacksmith
    undefined


    Absence of visualization in the inventory, but the customized viking of the fleet has access to the axe.

  • Ubi-Borealis
    Ubisoft Support Staff 2906 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for weapons/shields being knocked out of Eivor's hands in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with gear missing from your inventory following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • More information about the gear that is missing from your inventory (what it is, when it went missing, how it went missing etc).

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • snoddas1099
    10 posts

    Missing weapon, blacksmith axe. Google the problem and many have the same issue. So what is the point to play when my upgraded gear vanish? There is no option in game to throw away a handheld weapon. Must be a bug involved when throwing torches.
    Any why to get it back or must I restart far back in saves? 
    This is not OK....

  • Avve1000
    1 posts

    I lost mine too, i dont remember where but it was around the same time as your incident. Very annoying

  • Romanos2314_GR
    1 posts

    I lose some of my weapons too anyone can provide us a resolve?

  • Ptm2214
    1 posts

    So last night I was playing and lost a mythical axe as well as a mythical spear both with full runes and fully upgraded. They are no longer in my inventory and neither are the runes. Any ideas? Is there a way to fix this? Thanks

  • Mr.WaffleMan24
    2 posts

    I've lost Varin's axe and HouseCarl's axe for no reason? I don't want to restart my whole 15 plus hours of game to get it back can you guys pls fix this -_____-

  • Mr.WaffleMan24
    2 posts

    there is a glitch in the game where if your weapons and then switch to your torch and throw away the torch, the weapon gets deleted from your inventory. I already lost 3 weapons -____- . This glitch has been around since release don't think Ubisoft cares tbh

  • doomkoch
    1 posts

    Same Problem here, but its bugged on every past savegame, no matter if 8 hours or 45 hours of playtime

  • DracheSen
    1 posts

    I have the same problem and to play 3h hours since my last savegame with the axe.

  • zimpirate1
    9 posts

    It happens to all my gear.

  • cleider12
    2 posts

    I also lost my weapons ... I have more than 5 play hours since the last save with all the weapons. I am done for this game ...

  • Saker3ze
    1 posts

    so today i was playing the game and i had 2 spears equipped .. so i had to use a torch in a dark tunnel and after i threw the torch my maxed mythical fafnir spear disappeared from my hands and its no where to be found in weapons.. if i want to load the game i will lose 15 hours of play time which is alot for me .. please help and thanks in advance.

    i think this is might help understanding the bug https://www.reddit.com/r/ubisoft/comments/jsbpln/lost_a_weapon_in_valhalla/

  • DJRenegade
    1 posts

    So I noticed tonight that my attacks seems weak, I then realised I didnt have my axe equipped in my main hand. When I went to my inventory to re-equip it, thinking I must have accidently un-equipped it, I noticed it was no longer there. Annoyed at losing my most upgraded weapon I shrugged it off and put it down to some crappy bug. When I went to equip another axe I then realised I could no longer equip weapons in that hand at all. I played for a good 10 hours tonight and did a lot of exploration, not a lot of fighting which is why it took so long to notice. I dont fancy losing all of that progress and have almost immediately lost interest in the game.

    Is there a fix for this? Will there be a fix for this?

    I have tried restarting the game but it seems the bug has become one with my saves 😞

  • Alek2011
    1 posts

    Today while playing AC Valhalla and using the Draugr poison hammer paired with the blacksmiths hammer, I was battling enemies and in a cave. I had to use a torch due to light a few times and shortly after I noticed that my Draugr Hammer was gone and I was now punching enemies with my mainhand. I checked my gear and it was gone as if I had never even purchased it or fully upgraded it. I reloaded all of my recent auto saves and none of them had the hammer in them. I loaded a save that was 3 hours behind and guess what? My hammer was there.... I have read people saying it is a torch issue and it causes your mainhand weapon to disappear no matter which weapon it is. I am forced to now go back three hours and lose completing all of Linconscire. This seems to be an issue for more than just myself. Ubisoft I know your game is riddled with bugs but come on. I’m putting money into the game for dlc and then it disappears and better yet I have to go back 3 hours worth of game time to get the weapon back all in hopes that it doesn’t go away again. Players should be getting compensated for all the bugs we’re dealing with.

  • Hatty1993
    1 posts

    G'day All,

    I lost both of the spears (Fyrd and another one) I had in my primary hand. Once during combat, I went to the escape menu while gaming and when I resumed Eivor was no longer wielding it and it had disappeared from my inventory altogether.
    Then later I was looting the Spartan Shield and while my weapons were on my back and i squeezed into a crack, my spear became lodged and I couldn't pick it up? This too disappeared from my inventory.

    Cheers.

  • Lucifer_Hell
    1 posts

    @rardain Yeah same thing happened to me after I discovered where the Excalibur was located. So what happened in my case was that I was dual welding Scimitar in main hand and Carolingian Longsword in off hand when I interacted with the Excalibur before I had all the tablets. After that I noticed that I only had one sword on my back, so I checked my inventory to see if it just got unequipped but it was completely gone from my inventory.

  • GoDodgersGo
    3 posts

    I'm guessing this hasn't been fixed yet, happened to me recently, not sure when... I swear ubisoft makes the buggiest games! I'm waiting on another bug of theirs they seem to be ignoring. Have they even responded recently to this thread? Every fu*king game of theirs is infested with bugs and they don't seem to care! From Assassin's Creed, For Honor, Division 1 & 2... all them infested. Does ubisoft even have a QA department? If I don't get a satisfactory outcome to these bugs, I think I'm done with Ubisoft, too many good games out there to deal with this fu*king bs over and over

  • JaSamDzekiChen
    2 posts

    Well i was climbing a ladder, and Eivor had a torch, soo when i pressed the button to drop the torch, he threw his axe, so now i dont have Varin's axe, can someone help?

  • JaSamDzekiChen
    2 posts

    @jasamdzekichen couldn't pick it up at all btw

  • P_UDDING
    11 posts

    I lost this item from my inventory already a while ago and couldn't get it back so far. I thought that the title update might solve this issue but I am still missing it.
    Hope it gets fixed soon bc I really liked that axe.

    Also still have to huntsman armors in my inventory, but the update should have fixed that? It says "removed duplicate gear from inventory". Didn't work for me yet.

Suggested Topics

Community Details

44
Online
143.1k
Users
25.3k
Topics
131.4k
Posts