Welcome to discussions

Quick Suggestions

  • Niater2
    1 posts

    yeah lost varin's axe just when i upgraded it to gold and last save is on 30h. I have 72h...

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for weapons/shields being knocked out of Eivor's hands in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with gear missing from your inventory following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • More information about the gear that is missing from your inventory (what it is, when it went missing, how it went missing etc).

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Z.E.U.S_
    5 posts
    This post is deleted!
  • RaulTorres510
    1 posts

    I traveled back to Norway and it was back in my inventory

  • Superroo777
    2 posts

    i logged in and all of my armor is gone or reset to the lowest rate. 55 hours in and its all gone. All games load with me on my mount inside a merchant. i requested a refund. this game is a waste

  • Techmo775
    1 posts

    Hi so I was playing Valhalla last week when I noticed my Eivor was punching instead of using her axes (Varins axe and the Berserker axe), I then noticed they weren't in my inventory anymore and had deleted from my character.

    I've searched up how to get them back but I don't have any saves to roll back to i would have to restart the game which I've already put 26 hours into and really don't want to. Is there anyway you can get them back for me or are they gone forever?

    I was really hoping to take Varins axe to the end of the game with Eivor since its her fathers axe and I thought it would be nice to do but am completely unable to, any help would be greatly appreciated 🙂

    Cheers

  • sh0wt3k2020
    1 posts

    Hace una semana mande un ticket support porque las armas que compré hace un tiempo desaparecieron de mi inventario y no han vuelto a aparecer, llevo 1 semana al menos esperando y sin respuesta. Sin embargo es extraño porque en mi jomviking si que aparecen esas armas pero no en mi inventario.

  • P_UDDING
    11 posts

    @raultorres510 wow you were lucky then, I tried and still nothing

  • UbiKoality
    Community Manager 440 posts

    @sh0wt3k2020 Hey there! I'm sorry to hear that you have not received a response on your case. Can you please let me know your ticket reference number? I would be glad to review it further to ensure it's been placed with the correct department. Thank you!

    Official Response
  • Rizzan7
    1 posts

    So is there any update to this. I lost The Blacksmith's hammer about a week ago and noticed there hasn't been any update on this chain in a bit.

  • Kakarot0114
    4 posts

    Update: Yesterday my weapons appered in my inventory. I beleive (/hope) that it was the Ubis doing. Thank you very much!

  • SN33DS
    4 posts

    Some weapons such as fafnir’s fang are missing from my inventory though I can still give them to my johmsviking. I haven’t lost them to the torch and dual swap glitch as I have never used them...
    Is there a way to fix this ?

  • jdunn7692321
    1 posts

    I lost literally EVERYTHING, RANDOMLY. This is insane, literally, everything I've purchased, save the berserker set, is gone. All my helix credits (close to 5000). This is crazy, I love the franchise but if something isn't done to remedy this on ubisoft' end, i don't think ill be checking any other releases out.

  • WhskyDltaFoxtrt
    7 posts

    I logged on and now some of my Raven clan armor, like my cloak and such and some of the weapons are just......GONE......ive tried to reload or whatever but this SHOULD NOT be happening, I had everything fully upgraded.......please help

  • AutolocusCXX
    1 posts

    All my axes just disappeared. This is just ridiculous. More so is that UBISOFT longer seem to be replying to this thread. At least give us an update guys!

  • adrian_z3
    1 posts

    i lost my Suttungr Claw. any way to get it a back?

  • XandArt13
    3 posts

    Lost my off-hand dagger щ(ಠ益ಠщ)
    Anyone was able to return their weapon?

  • SiblingChris
    10 posts

    The whole torch thing makes sense, as I just lost enhanced sarcophagus shield after chasing fulke around with a torch and chucking them at her. Looks like only option to get it back is the save before the whole Sussex story arc 😭

  • WAFFLEKING2000
    1 posts

    As of 28/01/2021 I have lost my raven clan shield which I had upgraded to mythical. Any resolution that doesn't require the loss of progress will be a huge help please.

  • SN33DS
    4 posts

    I haven’t seen this issue on the know issues post but it seems I am not the only one experiencing this. Some weapons such as fafnir’s fang are missing from my inventory though I can still give them to my jomsviking. I haven’t lost them to the torch and dual swap glitch as I have never had the chance to use them in the first place. How do I get them back ?

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts

    Hello there @SN33DS!

    I'm sorry to hear that you're missing some of your weapons. Would you be able to provide us with more information?

    • Is it only Fafnir's Fang you're missing? Or are other weapons missing?
    • When did you first notice their disappearance?
    • If possible, would you be able to provide a video that shows the weapons as missing from your inventory for Eivor, but that they can be given to your jomsviking? This will be helpful for further investigation.


    Thanks!

    Official Response

Suggested Topics

Community Details

141
Online
190.8k
Users
31.8k
Topics
160.5k
Posts