Welcome to discussions

Quick Suggestions

  • I3uschi
    7 posts

    For me Valhalla also crashes very often.

    My System is a i9 9900k and a RTX 3080.
    All my other games work fine, for now it's just this game.

    The most frustating thing is, that the game doesen't auto-safe very often. That means you have to replay a lot.
    Yes, i often use F5 but sometimes i forget it.
    Now that it happend the second time where i have to replay so much, i will quit playing this game.
    Maybe i will give it another chance in the future, i don't know.


    Here is my story with Valhalla:

    Huge fan of this series, bought the game for over a 100€ at release.

    Played a bit and performance sucks for no reason.
    When i compare how well it runs on AMD GPUs and i never got an answer, why it runs so poor on nVidia cards.
    Yes it is an AMD supported game but does this mean you have to [censored] on nVidia owners?

    After the release of rBar, things got a little bit better. Frames are still not good, but more playable in 3440x1440p.
    Sadly there was a graphical bug. Water, spider webs flashing like crazy and also there are missing textures.
    The game launched November 2020 and Ubisoft is not a 20 men dev-team. How is that even possible, that the game is still in such a bad state after so many month!?

    Today we have a new driver. 466.77 and i think these flashes and missing textures are fixed.
    So weird, there is nothing in the patchnotes but it seems fixed. Sometimes you really can't understand computers, doesen't make any sense.
    And now the game crashes over and over again, letting me play the same things over and over again. nice 😕

    Yeah Ubisoft i know, u got my money so for you guys everything is fine.
    Hopefully i will learn from that for the future cause it looks like that i'm an idiot.
    I pay for games, i would never cheat, i support where it's possible and that is what i get...

    Thanks for reading, stay safe and have a great day. 🙂

  • Ubi-Mercury
    Ubisoft Support Staff 228 posts

    @i3uschi - I'm sorry to hear that you're also experiencing frequent crashes. Are there any error messages shown when these occur?

    @crocodilius - Sorry to hear about these graphics card issues you've encountered. Could you please try these basic troubleshooting steps to see if they help?

    Official Response
  • I3uschi
    7 posts

    @ubi-mercury Well, after the game crashes, the only thing i can do is sending the "bug report". And that's what i'm allways doing.
    I just can hope that devs read or care about this. And of course that it helps to find out what is going on and why the game is crashing.

    I tried so many different things. Valhalla is the only game on my PC that is crashing (and i have a lot of games). So now it's up to the devs looking into it...

    I will get a 3090 in the near future and try it again.

  • odemivu
    1 posts

    @i3uschi i can't even send a crash report. Game just crashes wihout any messages.
    y-day everything was good but today after your new patch we got some bug or this is feature? 😉

  • I3uschi
    7 posts

    @odemivu Well true, i think today there was no bug report/message. And of course it's a feature 😉

  • Ubi-Mercury
    Ubisoft Support Staff 228 posts

    Thank you both for providing these details. Did you both happen to already try the previous troubleshooting steps posted?

    Official Response
  • I3uschi
    7 posts

    @ubi-mercury Hello, so here is what i tried: (I tested 2 days to make sure, here is the answer)

    • Repaird files
    • run game as admin (The game doesen't even start after that, no idea why)
    • turned off every 3rd party app like msi afterburner, hwinfo, geforce exp...


    Sometimes i can play a little longer, sometimes it crashes after 5 mins...

    How does it look like?
    Its a freeze, there is a short flash, picture is not moving anymore and game closes (once it freezed and didn't close)
    Since the latest update, i can't send the "bug report" anymore.

    The only thing left is, reinstall ubi and game. I will try...

  • Ubi-Mark.
    Ubisoft Support Staff 1302 posts

    Thank you for the update, @i3uschi!

    Can you please reach our team through either our support website or social media:

    Facebook
    Twitter

    Our team will be more than happy to assist you further with these crashes.

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • I3uschi
    7 posts

    @ubi-mark So here how things are after testing 2 weeks:

    I reinstalled the game and the ubi launcher.

    I could play 6 days without any crashes.
    I started playing without any 3rd party app, for like 2 days.
    After getting no crahes, i got more brave and tried again playing with Afterburner, RTSS, hWinfo, GeForce Exp.
    Everything worked since day 6. Nothing changed, but crahes came back.

    So, reinstall game and launcher again... (god thx for speedy internet ^^)
    It didn't help, still crashes. (with or without 3rd party apps)
    Next day, i didn't change anything, no crahes... (i have no idea)
    Since then it works just fine. With 3rd party apps, overclocked GPU, tabing in' and out... Since then it's rock stable. (I have no idea again ^^)

    But still, i think the crash report doesen't work anymore after the last update. So, just saying, things are getting harder to fix for you without any data right!?

    So, after a ~100 hours of clearing everything* on the map, there was no crash.


    *Everything? No, 1 mission is buged. In Hamtunscir, there is a priest on a little island and the nun. I can't speak with him, so i can't fight against the nun, tried so many things to triger the priest.
    But nothing...

    Noooooo, really!?!?!?
    What have i done to this game?
    On top of that, i know i'm a stupid nVidia owner and i got this non-optimal performance compared to amd gpus...
    ... so i wonder: What will the game try next to punish me?

    Anyway. Have a great day @all 🙂

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts

    Hello again @I3uschi!

    I apologise for the delayed response. Thanks for reaching out to us with an update! I'm glad to hear that you haven't been experiencing any more crashes in-game 😄 Thanks for sharing what steps you tried to troubleshoot this issue with.

    I'm sorry to hear you've encountered trouble with "Saint Faith" whilst clearing out your map. You can follow the dedicated Megathread for this issue here.

    If you have any further questions or concerns, please don't hesitate to reach out.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details

123
Online
190.6k
Users
31.7k
Topics
160.3k
Posts