ubisoft discussions

Quick Suggestions

  • 0 Likes/103 Replies/5010 Views
    4 posts

    @ElijahJoJo this method worked for me! I had the same problem that everyone else is having and I went down to the river and picked up the dead body and brought it to the tower and the dialogue prompted. Side quest completed! Thank you so much! 🙏🏻

  • FearLess_Kane01
    1 posts

    Every time I go to the door it’s closed , I made up to the part where the guy confronts you I beat him and ever since then it’s bugged , and that’s it it won’t advance and now the door closed! Everytime I walk away she repeats her first lines when you approach!! Hope they fix soon ! I also got another mission that’s bugged the guy with clothes mission he won’t move he keeps shouting on the mountain ! This game is unbelievable broken lol

  • Cthulhu1234
    1 posts

    I made that part too - but when i did it at first time the doors was open and the other opponent was inside with her, killed him too because i thought that was a part of a quest)... now on that save i have closed doors , crying first beated npc close to the river on his knees and 0 interaction close to tower (even she doesnt speak anymore).

  • Eucliditus
    1 posts

    Experiencing the same bug. I went and attacked the first guy, which lead to me standing outside 'Guarding'. Nothing happened so I moved away for a second.
    When I moved, I was unable to re-interact with the tiles to stand 'guard'. The enemy was inside the house already with her, so I killed him. Nothing happened.
    I reloaded, and then the door was closed. I can no longer reset or complete the mission. 😞

  • Farelio
    1 posts

    I cannot proceed with the "guard the lady in the tower" quest because the "enemy" spawned motionless behind the lady and i killed him with assassination, and now nothing happens.

  • Noncryptic
    2 posts

    @farelio I have the same issue with this quest, except I did something different.

    I fought the attackers and killed them, I talked to the woman but then the quest was never completed and now the door is closed. If she's in there I can't get in, and
    It's still on my map.

    I play with an Xbox One X.

  • Ubi-Ginge
    257 posts

    How can we assist Quagliagol27?

  • Ubi-Raziel
    197 posts


    Hey! I'm not familiar with this issue but we can look into it for you.

    Would it be possible to provide a short video presenting this issue? Your quest book, map location and no way to complete the quest.

    In the meantime, I recommend verifying game files to see if that helps.

    Thank you!

  • RedIndianRobin
    188 posts

    @ubi-swaggins Nope doesn't work for me. Is this going to get fixed or am I screwed?

  • RedIndianRobin
    188 posts

    After standing in front of the tower and the lady, nothing happens, the quest breaks and the lady won't speak anything. I reloaded save, quit game, fast travelled, nothing works.

  • AhmadOmar606vip
    1 posts

    Unfortunately I have the same problem and I expect it will be fixed in the next update

  • BackslicknicK
    8 posts

    I have the same bug, and I killed the man inside the tower and now the door is closed.
    There is no dead body beside the crying man by the river.
    the lady doesnt start to talk when I walk towards the river.
    I can confirm that it doesnt work


  • BRiAnWinN
    1 posts

    To the west of the southwestmost synchronize point in Ledecestrescire, there is a world event with a lady in a tower waiting for her lord to come save her. Halfway through the event, it stalled out and I can't progress it any further. I tried doing a few missions, fast traveling away, nothing fixed it

  • Asbel-Lyhant
    19 posts

    @brianwinn I’ve had a similar issue with the beaeulf quest, ncpwaiting for me to enter church even though I’m stood at the side off her! I’ve seen so many people complaining about these bugs and nothing has been done about them

  • Seananthon
    1 posts

    The mission seems to have dead locked. upon entering the quest her champion stands guard by the entrance, and the game gave me the option to assassinate him, instantly, when consulting with friends they had no option to-do this i later found out i wasn't even supposed to be able to see the woman but the door had not been rendered on my game, anyway i killed him, my friends however beat him up and he ran away as part of the quest. I cannot progress through this quest anymore the woman isn't even there anymore and the door has suddenly apeared, i cannot restart before i did this as my autosaves all lead me back to the same point after the bug, loading before that would put me 4 hours back.

  • GermanGamerGuy
    1 posts

    Got the exact same issue. Hopefuly it will be resolved with the next patch. It really bugs me out that I can´t complete the region

  • Sleeprage
    3 posts

    @seananthon I have this glitch also. I tired to load to Norway and return but that did not fix it. I also tried to restart the game (force quit) and that did not fix it either. I hope the devs see this and can resolve the issue as I really want to 100% this.

  • La-D1x
    4 posts

    @seananthon I also had this bug, but you can complete it, you just need to go there again, then go towards the water/lake south, and when you hear her talk, then just stand still and let the dialog play out, that was how I and alot of others completed it.

    I hope it helps you.

  • Barbario94
    1 posts

    @la-d1x It's Works! Thanks!

  • fuc-kin-e
    2 posts

    Good day,
    I want to report for a bug with this mystery.
    the locked lady that need to be guarded to leave the tower, i cannot pass this mystery.
    I watch some videos how to pass it and you need to stay and guard to the front door to kill some guy but for me i dont have investing (button) icon and i cannot do nothing, staying long time there searching, loading from old saves and etc.
    Can i somehow to reset this mystery from the start ?
    Someone else have this issue ?

    Thank you.

Suggested Topics